summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-03-30 21:40:27 +0000
committerMike Frysinger <vapier@gentoo.org>2012-03-30 21:40:27 +0000
commitd11d34be06e15b64dc5097c42b3b599cf09d2f86 (patch)
tree3ab4feca643c0ac53a169729a9cc186d04349980 /sys-fs
parentAdding sys-devel/libtool as a DEPEND, bug 401527 (diff)
downloadgentoo-2-d11d34be06e15b64dc5097c42b3b599cf09d2f86.tar.gz
gentoo-2-d11d34be06e15b64dc5097c42b3b599cf09d2f86.tar.bz2
gentoo-2-d11d34be06e15b64dc5097c42b3b599cf09d2f86.zip
Migrate to EAPI=4 and fix static-libs handling #410251 by Fernando V.
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsprogs/ChangeLog7
-rw-r--r--sys-fs/xfsprogs/xfsprogs-3.1.7-r1.ebuild103
2 files changed, 109 insertions, 1 deletions
diff --git a/sys-fs/xfsprogs/ChangeLog b/sys-fs/xfsprogs/ChangeLog
index 2991f695ee97..d91d5a453de0 100644
--- a/sys-fs/xfsprogs/ChangeLog
+++ b/sys-fs/xfsprogs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/xfsprogs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.141 2012/03/30 17:06:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.142 2012/03/30 21:40:27 vapier Exp $
+
+*xfsprogs-3.1.7-r1 (30 Mar 2012)
+
+ 30 Mar 2012; Mike Frysinger <vapier@gentoo.org> +xfsprogs-3.1.7-r1.ebuild:
+ Migrate to EAPI=4 and fix static-libs handling #410251 by Fernando V.
30 Mar 2012; Diego E. Pettenò <flameeyes@gentoo.org> xfsprogs-3.1.4.ebuild,
xfsprogs-3.1.5.ebuild, xfsprogs-3.1.6.ebuild, xfsprogs-3.1.7.ebuild:
diff --git a/sys-fs/xfsprogs/xfsprogs-3.1.7-r1.ebuild b/sys-fs/xfsprogs/xfsprogs-3.1.7-r1.ebuild
new file mode 100644
index 000000000000..d1368434a6d5
--- /dev/null
+++ b/sys-fs/xfsprogs/xfsprogs-3.1.7-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-3.1.7-r1.ebuild,v 1.1 2012/03/30 21:40:27 vapier Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="xfs filesystem utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="libedit nls readline static static-libs"
+REQUIRED_USE="static? ( static-libs )"
+
+LIB_DEPEND=">=sys-apps/util-linux-2.17.2[static-libs(+)]
+ readline? ( sys-libs/readline[static-libs(+)] )
+ !readline? ( libedit? ( dev-libs/libedit[static-libs(+)] ) )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ !<sys-fs/xfsdump-3"
+DEPEND="${RDEPEND}
+ static? (
+ ${LIB_DEPEND}
+ readline? ( sys-libs/ncurses[static-libs] )
+ )
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ if use readline && use libedit ; then
+ ewarn "You have USE='readline libedit' but these are exclusive."
+ ewarn "Defaulting to readline; please disable this USE flag if you want libedit."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.1-sharedlibs.patch
+
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in || die
+ sed -i \
+ -e '1iLLDFLAGS = -static' \
+ {estimate,fsr}/Makefile || die
+ sed -i \
+ -e "/LLDFLAGS/s:-static:$(use static && echo -all-static):" \
+ $(find -name Makefile) || die
+
+ # libdisk has broken blkid conditional checking
+ sed -i \
+ -e '/LIB_SUBDIRS/s:libdisk::' \
+ Makefile || die
+
+ # TODO: write a patch for configure.in to use pkg-config for the uuid-part
+ if use static && use readline ; then
+ sed -i \
+ -e 's|-lreadline|\0 -lncurses|' \
+ -e 's|-lblkid|\0 -luuid|' \
+ configure || die
+ fi
+}
+
+src_configure() {
+ export DEBUG=-DNDEBUG
+ export OPTIMIZER=${CFLAGS}
+ unset PLATFORM # if set in user env, this breaks configure
+
+ local myconf
+
+ if use readline ; then
+ myconf="--enable-readline --disable-editline"
+ elif use libedit ; then
+ myconf="--disable-readline --enable-editline"
+ else
+ myconf="--disable-readline --disable-editline"
+ fi
+
+ if use static || use static-libs ; then
+ myconf="${myconf} --enable-static"
+ else
+ myconf="${myconf} --disable-static"
+ fi
+
+ econf \
+ --bindir=/usr/bin \
+ --libexecdir=/usr/$(get_libdir) \
+ $(use_enable nls gettext) \
+ ${myconf}
+
+ MAKEOPTS+=" V=1"
+}
+
+src_install() {
+ emake DIST_ROOT="${ED}" install install-dev
+
+ # handle is for xfsdump, the rest for xfsprogs
+ gen_usr_ldscript -a xfs xlog
+ # removing unnecessary .la files if not needed
+ use static-libs || find "${ED}" -name '*.la' -delete
+}