summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-24 12:00:09 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-24 12:00:09 +0000
commitc10cc5e9249f0b5fb320db124bbcf53eb529c5bc (patch)
tree0a1e1ca56cfaea02c49354d861f8733ad84a6725 /sys-fs
parentold (diff)
downloadgentoo-2-c10cc5e9249f0b5fb320db124bbcf53eb529c5bc.tar.gz
gentoo-2-c10cc5e9249f0b5fb320db124bbcf53eb529c5bc.tar.bz2
gentoo-2-c10cc5e9249f0b5fb320db124bbcf53eb529c5bc.zip
Version bump #200397 by Hanno Boeck.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/quota/ChangeLog7
-rw-r--r--sys-fs/quota/files/digest-quota-3.153
-rw-r--r--sys-fs/quota/quota-3.15.ebuild80
3 files changed, 89 insertions, 1 deletions
diff --git a/sys-fs/quota/ChangeLog b/sys-fs/quota/ChangeLog
index e57fb88f8b94..7168df2d3a89 100644
--- a/sys-fs/quota/ChangeLog
+++ b/sys-fs/quota/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/quota
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.31 2007/07/12 18:34:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.32 2007/12/24 12:00:08 vapier Exp $
+
+*quota-3.15 (24 Dec 2007)
+
+ 24 Dec 2007; Mike Frysinger <vapier@gentoo.org> +quota-3.15.ebuild:
+ Version bump #200397 by Hanno Boeck.
12 Jul 2007; Jeroen Roovers <jer@gentoo.org> quota-3.14-r1.ebuild:
Stable for HPPA (bug #184382).
diff --git a/sys-fs/quota/files/digest-quota-3.15 b/sys-fs/quota/files/digest-quota-3.15
new file mode 100644
index 000000000000..d22d9b9e04ac
--- /dev/null
+++ b/sys-fs/quota/files/digest-quota-3.15
@@ -0,0 +1,3 @@
+MD5 5a1c2f5e669aba825e0126d2f30ee622 quota-3.15.tar.gz 313030
+RMD160 a6ae9091c000bed092f7dd2a9bcc66b730d0b7af quota-3.15.tar.gz 313030
+SHA256 9272806f605a1df889e7e9ae903a65c1ac4e80bcaf83f9bcb25fb51092ebd1ae quota-3.15.tar.gz 313030
diff --git a/sys-fs/quota/quota-3.15.ebuild b/sys-fs/quota/quota-3.15.ebuild
new file mode 100644
index 000000000000..25637ad375f2
--- /dev/null
+++ b/sys-fs/quota/quota-3.15.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.15.ebuild,v 1.1 2007/12/24 12:00:08 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="nls tcpd ldap rpc"
+
+RDEPEND="ldap? ( net-nds/openldap )
+ tcpd? ( sys-apps/tcp-wrappers )
+ rpc? ( net-nds/portmap )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/quota-tools
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # patch to prevent quotactl.2 manpage from being installed
+ # that page is provided by man-pages instead
+ epatch "${FILESDIR}"/${PN}-no-quotactl-manpage.patch
+
+ # Don't strip binaries (from Fedora)
+ epatch "${FILESDIR}"/quota-3.06-no-stripping.patch
+
+ append-cppflags -DLDAP_DEPRECATED=1
+
+ sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable ldap ldapmail) \
+ $(use_enable rpc) \
+ $(use_enable rpc rpcsetquota) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake ROOTDIR="${D}" install || die
+ rm -r "${D}"/usr/include || die #70938
+
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+
+ dodoc doc/*
+ dodoc README.*
+ dodoc Changelog
+
+ newinitd "${FILESDIR}"/quota.rc6 quota
+ newconfd "${FILESDIR}"/quota.confd quota
+
+ if use rpc ; then
+ newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
+ else
+ rm -f "${D}"/usr/sbin/rpc.rquotad
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ insopts -m0644
+ doins ldap-scripts/quota.schema
+
+ exeinto /usr/share/quota/ldap-scripts
+ doexe ldap-scripts/*.pl
+ doexe ldap-scripts/edquota_editor
+ fi
+}