summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2006-08-03 13:31:46 +0000
committerPatrick McLean <chutzpah@gentoo.org>2006-08-03 13:31:46 +0000
commitbd30ddb149dcb9cae111ba9666e2651b90a9a5e9 (patch)
tree1ccb8fedcd7687798bdcf62012a894afb8d596cf /sys-fs
parentRemove building of test and demos during normal compilation. Speeds things u... (diff)
downloadgentoo-2-bd30ddb149dcb9cae111ba9666e2651b90a9a5e9.tar.gz
gentoo-2-bd30ddb149dcb9cae111ba9666e2651b90a9a5e9.tar.bz2
gentoo-2-bd30ddb149dcb9cae111ba9666e2651b90a9a5e9.zip
Version bump, clean up old version.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g/ChangeLog8
-rw-r--r--sys-fs/ntfs3g/files/digest-ntfs3g-0.1_beta200708033
-rw-r--r--sys-fs/ntfs3g/ntfs3g-0.1_beta20070803.ebuild39
3 files changed, 49 insertions, 1 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 4e6ac9dffc07..b61baa7de289 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.7 2006/08/02 14:05:45 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.8 2006/08/03 13:31:46 chutzpah Exp $
+
+*ntfs3g-0.1_beta20070803 (03 Aug 2006)
+
+ 03 Aug 2006; Patrick McLean <chutzpah@gentoo.org>
+ -ntfs3g-0.1_beta20070714.ebuild, +ntfs3g-0.1_beta20070803.ebuild:
+ Version bump, clean up old version.
*ntfs3g-0.1_beta20070714-r1 (02 Aug 2006)
diff --git a/sys-fs/ntfs3g/files/digest-ntfs3g-0.1_beta20070803 b/sys-fs/ntfs3g/files/digest-ntfs3g-0.1_beta20070803
new file mode 100644
index 000000000000..9239593adbe9
--- /dev/null
+++ b/sys-fs/ntfs3g/files/digest-ntfs3g-0.1_beta20070803
@@ -0,0 +1,3 @@
+MD5 961966d6c82851ee67a6979c85e2f3c0 ntfs-3g-20070803-BETA.tgz 559265
+RMD160 b0958f957312e237e7310184ea0f96455bf9f53a ntfs-3g-20070803-BETA.tgz 559265
+SHA256 e9cb21da04cda48d3fc79e1031aee9bfa3803e4b091f3b555d6aeaed80215460 ntfs-3g-20070803-BETA.tgz 559265
diff --git a/sys-fs/ntfs3g/ntfs3g-0.1_beta20070803.ebuild b/sys-fs/ntfs3g/ntfs3g-0.1_beta20070803.ebuild
new file mode 100644
index 000000000000..2d1ed8283994
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-0.1_beta20070803.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-0.1_beta20070803.ebuild,v 1.1 2006/08/03 13:31:46 chutzpah Exp $
+
+MY_PN="${PN/3g/-3g}"
+MY_PV="${PV#0.1_beta}"
+MY_PV="${MY_PV}-BETA"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://sourceforge.net/mailarchive/forum.php?thread_id=23836054&forum_id=2697"
+SRC_URI="http://mlf.linux.rulez.org/mlf/ezaz/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/fuse-2.5.0"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # default makefile calls ldconfig
+ sed -ie '/ldconfig$/ d' src/Makefile.*
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog CREDITS NEWS README
+
+ # remove uselessly installed headers so we don't collide with
+ # sys-fs/ntfsprogs anymore
+ rm -rf "${D}"/usr/include
+}