summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-10-02 09:56:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-10-02 09:56:42 +0000
commitbb5b2335f5c6ceb4e1339f167f998321b1dcad16 (patch)
tree8ca393621db09c48face85a5bb434559ab912081 /sys-fs
parentstable x86, bug 194439 (diff)
downloadgentoo-2-bb5b2335f5c6ceb4e1339f167f998321b1dcad16.tar.gz
gentoo-2-bb5b2335f5c6ceb4e1339f167f998321b1dcad16.tar.bz2
gentoo-2-bb5b2335f5c6ceb4e1339f167f998321b1dcad16.zip
Version bump of LVM, bug #193297. Support for dmeventd per bug #192174. Major cleanups of the ebuild, USE=nosnapshots/nomirrors are no longer supported due to interactions with dmeventd.
(Portage version: 2.1.3.11)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lvm2/ChangeLog9
-rw-r--r--sys-fs/lvm2/files/digest-lvm2-2.02.283
-rw-r--r--sys-fs/lvm2/lvm2-2.02.28.ebuild113
3 files changed, 124 insertions, 1 deletions
diff --git a/sys-fs/lvm2/ChangeLog b/sys-fs/lvm2/ChangeLog
index 00eeae3ab75e..3cf5f68a483b 100644
--- a/sys-fs/lvm2/ChangeLog
+++ b/sys-fs/lvm2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/lvm2
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.106 2007/07/29 22:42:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.107 2007/10/02 09:56:42 robbat2 Exp $
+
+*lvm2-2.02.28 (02 Oct 2007)
+
+ 02 Oct 2007; Robin H. Johnson <robbat2@gentoo.org> +lvm2-2.02.28.ebuild:
+ Version bump of LVM, bug #193297. Support for dmeventd per bug #192174.
+ Major cleanups of the ebuild, USE=nosnapshots/nomirrors are no longer
+ supported due to interactions with dmeventd.
29 Jul 2007; Robin H. Johnson <robbat2@gentoo.org> metadata.xml:
Update metadata.
diff --git a/sys-fs/lvm2/files/digest-lvm2-2.02.28 b/sys-fs/lvm2/files/digest-lvm2-2.02.28
new file mode 100644
index 000000000000..920c6a9cc962
--- /dev/null
+++ b/sys-fs/lvm2/files/digest-lvm2-2.02.28
@@ -0,0 +1,3 @@
+MD5 940a882a71cae84f6befc8069a260ad1 LVM2.2.02.28.tgz 531905
+RMD160 bf6f25db6e34bf362353ae9557691a7f01962502 LVM2.2.02.28.tgz 531905
+SHA256 2d8d7b123e427d0bfb7471d7c17dfd88890eb98257ca22ea3be5d7307e83aceb LVM2.2.02.28.tgz 531905
diff --git a/sys-fs/lvm2/lvm2-2.02.28.ebuild b/sys-fs/lvm2/lvm2-2.02.28.ebuild
new file mode 100644
index 000000000000..b84348004274
--- /dev/null
+++ b/sys-fs/lvm2/lvm2-2.02.28.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.28.ebuild,v 1.1 2007/10/02 09:56:42 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="User-land utilities for LVM2 (device-mapper) software."
+HOMEPAGE="http://sources.redhat.com/lvm2/"
+SRC_URI="ftp://sources.redhat.com/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+# These no* flags are going to be removed shortly, pending a mail to -dev
+# - robbat2, 2007/10/02
+IUSE="readline nolvmstatic clvm cman gulm nolvm1 selinux"
+
+DEPEND=">=sys-fs/device-mapper-1.02.22-r1
+ clvm? ( >=sys-cluster/dlm-1.01.00
+ cman? ( >=sys-cluster/cman-1.01.00 )
+ gulm? ( >=sys-cluster/gulm-1.00.00 ) )"
+
+RDEPEND="${DEPEND}
+ !sys-fs/lvm-user
+ !sys-fs/clvm"
+
+S="${WORKDIR}/${PN/lvm/LVM}.${PV}"
+
+src_unpack() {
+ unpack ${A}
+ #cd "${S}" || die
+ #epatch ${FILESDIR}/lvm2-2.02.04-vgid.patch
+}
+
+src_compile() {
+ # Static compile of lvm2 so that the install described in the handbook works
+ # http://www.gentoo.org/doc/en/lvm2.xml
+ # fixes http://bugs.gentoo.org/show_bug.cgi?id=84463
+ local myconf
+ local buildmode
+
+ # fsadm is broken, don't include it (2.02.28)
+ myconf="${myconf} --enable-dmeventd --enable-cmdlib"
+
+ # Most of this package does weird stuff.
+ # The build options are tristate, and --without is NOT supported
+ # options: 'none', 'internal', 'shared'
+ if use nolvmstatic ; then
+ buildmode="shared"
+ else
+ myconf="${myconf} --enable-static_link"
+ buildmode="internal"
+ fi
+
+ # dmeventd requires snapshots and mirrors to be built in some form
+ # so we cannot disable them
+ myconf="${myconf} --with-snapshots=${buildmode}"
+ myconf="${myconf} --with-mirrors=${buildmode}"
+
+ if use nolvm1 ; then
+ myconf="${myconf} --with-lvm1=none"
+ else
+ myconf="${myconf} --with-lvm1=${buildmode}"
+ fi
+
+ # disable O_DIRECT support on hppa, breaks pv detection (#99532)
+ use hppa && myconf="${myconf} --disable-o_direct"
+
+ if use clvm; then
+ myconf="${myconf} --with-cluster=${buildmode}"
+ # 4-state!
+ local clvmd="none"
+ use cman && clvmd="cman"
+ use gulm && clvmd="${clvmd}gulm"
+ clvmd="${clvmd/cmangulm/all}"
+ myconf="${myconf} --with-clvmd=${clvmd}"
+ else
+ myconf="${myconf} --with-clvmd=none --with-cluster=none"
+ fi
+
+ myconf="${myconf} --sbindir=/sbin --with-staticdir=/sbin"
+ econf $(use_enable readline) $(use_enable selinux) ${myconf} || die
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ mv -f "${D}"/sbin/lvm.static "${D}"/sbin/lvm
+
+ dodoc README VERSION WHATS_NEW doc/*.{conf,c,txt}
+ insinto /lib/rcscripts/addons
+ newins ${FILESDIR}/lvm2-start.sh lvm-start.sh || die
+ newins ${FILESDIR}/lvm2-stop.sh lvm-stop.sh || die
+ newinitd ${FILESDIR}/lvm.rc lvm || die
+ if use clvm; then
+ newinitd ${FILESDIR}/clvmd.rc clvmd || die
+ fi
+
+ ewarn "use flag nocman is deprecated and replaced"
+ ewarn "with cman and gulm use flags."
+ ewarn ""
+ ewarn "use flags clvm,cman and gulm are masked"
+ ewarn "by default and need to be unmasked to use them"
+ ewarn ""
+ ewarn "Rebuild your genkernel initramfs if you are using lvm"
+}
+
+pkg_postinst() {
+ elog "lvm volumes are no longer automatically created for"
+ elog "baselayout-2 users. If you are using baselayout-2, be sure to"
+ elog "run: # rc-update add lvm boot"
+}