summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-05 20:31:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-05 20:31:04 +0000
commitb73f786802c5d18a4149bd1c9730fe9088ef02b0 (patch)
treeebe11c86a63754ee36d60a5244b4dcbaf3d106ad /sys-fs
parentNew package (Manifest recommit) (diff)
downloadgentoo-2-b73f786802c5d18a4149bd1c9730fe9088ef02b0.tar.gz
gentoo-2-b73f786802c5d18a4149bd1c9730fe9088ef02b0.tar.bz2
gentoo-2-b73f786802c5d18a4149bd1c9730fe9088ef02b0.zip
Version bump to clean up the sources and make sure custom $CFLAGS are applied.
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ext2resize/ChangeLog8
-rw-r--r--sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild43
-rw-r--r--sys-fs/ext2resize/files/digest-ext2resize-1.1.17-r21
3 files changed, 51 insertions, 1 deletions
diff --git a/sys-fs/ext2resize/ChangeLog b/sys-fs/ext2resize/ChangeLog
index 695131ff64c6..0f00ee4e1df8 100644
--- a/sys-fs/ext2resize/ChangeLog
+++ b/sys-fs/ext2resize/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/ext2resize
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ChangeLog,v 1.4 2004/03/20 13:56:31 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ChangeLog,v 1.5 2004/06/05 20:31:04 vapier Exp $
+
+*ext2resize-1.1.17-r2 (05 Jun 2004)
+
+ 05 Jun 2004; Mike Frysinger <vapier@gentoo.org>
+ +ext2resize-1.1.17-r2.ebuild:
+ Version bump to clean up the sources and make sure custom $CFLAGS are applied.
20 Mar 2004; <plasmaroo@gentoo.org> ext2resize-1.1.17-r1.ebuild,
files/ext2resize-1.1.17-gcc3.3.patch:
diff --git a/sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild b/sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild
new file mode 100644
index 000000000000..deec181ab327
--- /dev/null
+++ b/sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild,v 1.1 2004/06/05 20:31:04 vapier Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="EXT2 and EXT3 filesystem resizing utilities"
+HOMEPAGE="http://ext2resize.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha arm amd64"
+IUSE="static"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # stupid packaged source isn't clean
+ make distclean || die "distclean failed"
+ sed -i 's:CFLAGS =:CFLAGS +=:' src/Makefile.in
+
+ # Fix broken source for non-''old'' GCCs
+ sed -e 's/printf(__FUNCTION__ \"\\n\");/printf(\"%s\\n\", __FUNCTION__);/g' -i src/*.c
+ epatch ${FILESDIR}/${P}-gcc3.3.patch
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf --exec-prefix="/" || die "Configure failed"
+ emake LDFLAGS="${LDFLAGS}" || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ dodir /usr/sbin
+ dosym ../../sbin/ext2online /usr/sbin/ext2online
+ dosym ../../sbin/ext2prepare /usr/sbin/ext2prepare
+ dosym ../../sbin/ext2resize /usr/sbin/ext2resize
+}
diff --git a/sys-fs/ext2resize/files/digest-ext2resize-1.1.17-r2 b/sys-fs/ext2resize/files/digest-ext2resize-1.1.17-r2
new file mode 100644
index 000000000000..7672ccffc700
--- /dev/null
+++ b/sys-fs/ext2resize/files/digest-ext2resize-1.1.17-r2
@@ -0,0 +1 @@
+MD5 439bf19d6520194ca42b942f5b7a0703 ext2resize-1.1.17.tar.bz2 110853