summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-07-27 19:39:18 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-07-27 19:39:18 +0000
commita1058d0cb740c8a087f5ccd9b5766e11b0365959 (patch)
tree097a05707227510d33b884c4b817b3b2b420108b /sys-fs
parentFix repoman issues (diff)
downloadgentoo-2-a1058d0cb740c8a087f5ccd9b5766e11b0365959.tar.gz
gentoo-2-a1058d0cb740c8a087f5ccd9b5766e11b0365959.tar.bz2
gentoo-2-a1058d0cb740c8a087f5ccd9b5766e11b0365959.zip
Cleanup old versions.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptsetup/ChangeLog9
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.0.5-r1.ebuild102
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.0.7-r1.ebuild96
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.0.7.ebuild98
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild91
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.1.1.ebuild94
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.1.1_rc1.ebuild93
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.1.1_rc2.ebuild94
8 files changed, 8 insertions, 669 deletions
diff --git a/sys-fs/cryptsetup/ChangeLog b/sys-fs/cryptsetup/ChangeLog
index e395aa7e4480..2bb2a6b663b4 100644
--- a/sys-fs/cryptsetup/ChangeLog
+++ b/sys-fs/cryptsetup/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/cryptsetup
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.89 2010/07/27 18:52:25 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.90 2010/07/27 19:39:18 robbat2 Exp $
+
+ 27 Jul 2010; Robin H. Johnson <robbat2@gentoo.org>
+ -cryptsetup-1.0.5-r1.ebuild, -cryptsetup-1.0.7.ebuild,
+ -cryptsetup-1.0.7-r1.ebuild, -cryptsetup-1.1.0.ebuild,
+ -cryptsetup-1.1.1_rc1.ebuild, -cryptsetup-1.1.1_rc2.ebuild,
+ -cryptsetup-1.1.1.ebuild:
+ Cleanup old versions.
27 Jul 2010; Robin H. Johnson <robbat2@gentoo.org>
cryptsetup-1.1.2.ebuild, cryptsetup-1.1.3.ebuild:
diff --git a/sys-fs/cryptsetup/cryptsetup-1.0.5-r1.ebuild b/sys-fs/cryptsetup/cryptsetup-1.0.5-r1.ebuild
deleted file mode 100644
index c280904bdb92..000000000000
--- a/sys-fs/cryptsetup/cryptsetup-1.0.5-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.0.5-r1.ebuild,v 1.16 2009/04/19 18:41:07 cardoe Exp $
-
-inherit linux-info eutils flag-o-matic multilib
-
-DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
-HOMEPAGE="http://luks.endorphin.org/"
-SRC_URI="http://luks.endorphin.org/source/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="dynamic nls selinux"
-
-DEPEND="|| (
- >=sys-fs/lvm2-2.02.45
- >=sys-fs/device-mapper-1.00.07-r1
- )
- >=dev-libs/libgcrypt-1.1.42
- >=dev-libs/libgpg-error-1.0-r1
- >=dev-libs/popt-1.7
- sys-fs/udev
- || ( >=sys-libs/e2fsprogs-libs-1.41 <sys-fs/e2fsprogs-1.41 )
- selinux? ( sys-libs/libselinux )
- !>=sys-fs/udev-126
- !sys-fs/cryptsetup-luks"
-
-dm-crypt_check() {
- local CONFIG_CHECK="~DM_CRYPT"
- local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
- check_extra_config
-}
-
-crypto_check() {
- local CONFIG_CHECK="~CRYPTO"
- local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
- check_extra_config
-}
-
-cbc_check() {
- local CONFIG_CHECK="~CRYPTO_CBC"
- local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
- check_extra_config
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-}
-
-pkg_setup() {
- dm-crypt_check
- crypto_check
- cbc_check
-}
-
-src_compile() {
- if use dynamic ; then
- ewarn "If you need cryptsetup for an initrd or initramfs then you"
- ewarn "should NOT use the dynamic USE flag"
- epause 5
- fi
-
- econf \
- --sbindir=/sbin \
- $(use_enable !dynamic static) \
- --libdir=/usr/$(get_libdir) \
- $(use_enable nls) \
- $(use_enable selinux) \
- || die
-
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- rmdir "${D}"/usr/$(get_libdir)/cryptsetup
- insinto /lib/rcscripts/addons
- newins "${FILESDIR}"/1.0.5-dm-crypt-start.sh dm-crypt-start.sh || die
- newins "${FILESDIR}"/1.0.5-dm-crypt-stop.sh dm-crypt-stop.sh || die
- newconfd "${FILESDIR}"/1.0.5-dmcrypt.confd dmcrypt || die
- newinitd "${FILESDIR}"/1.0.5-dmcrypt.rc dmcrypt || die
-}
-
-pkg_postinst() {
- ewarn "This ebuild introduces a new set of scripts and configuration"
- ewarn "than the last version. If you are currently using /etc/conf.d/cryptfs"
- ewarn "then you *MUST* copy your old file to:"
- ewarn "/etc/conf.d/dmcrypt"
- ewarn "Or your encrypted partitions will *NOT* work."
- elog "Please see the example for configuring a LUKS mountpoint"
- elog "in /etc/conf.d/dmcrypt"
- elog
- elog "If you are using baselayout-2 then please do:"
- elog "rc-update add dmcrypt boot"
- elog "This version introduces a command line arguement 'key_timeout'."
- elog "If you want the search for the removable key device to timeout"
- elog "after 10 seconds add the following to your bootloader config:"
- elog "key_timeout=10"
- elog "A timeout of 0 will mean it will wait indefinitely."
-}
diff --git a/sys-fs/cryptsetup/cryptsetup-1.0.7-r1.ebuild b/sys-fs/cryptsetup/cryptsetup-1.0.7-r1.ebuild
deleted file mode 100644
index c3105a3cce38..000000000000
--- a/sys-fs/cryptsetup/cryptsetup-1.0.7-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.0.7-r1.ebuild,v 1.1 2009/11/30 00:53:54 robbat2 Exp $
-
-EAPI=2
-
-inherit linux-info eutils flag-o-matic multilib
-
-DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
-HOMEPAGE="http://luks.endorphin.org/ http://code.google.com/p/cryptsetup/"
-SRC_URI="http://cryptsetup.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="dynamic nls selinux"
-
-DEPEND="
- >=sys-fs/lvm2-2.02.56-r1
- >=dev-libs/libgcrypt-1.1.42
- >=dev-libs/libgpg-error-1.0-r1
- >=dev-libs/popt-1.7
- >=sys-fs/udev-124
- || ( >=sys-libs/e2fsprogs-libs-1.41 <sys-fs/e2fsprogs-1.41 )
- selinux? ( sys-libs/libselinux )
- !sys-fs/cryptsetup-luks"
-
-dm-crypt_check() {
- local CONFIG_CHECK="~DM_CRYPT"
- local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
- check_extra_config
-}
-
-crypto_check() {
- local CONFIG_CHECK="~CRYPTO"
- local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
- check_extra_config
-}
-
-cbc_check() {
- local CONFIG_CHECK="~CRYPTO_CBC"
- local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
- check_extra_config
-}
-
-pkg_setup() {
- dm-crypt_check
- crypto_check
- cbc_check
-
- if use dynamic ; then
- ewarn "If you need cryptsetup for an initrd or initramfs then you"
- ewarn "should NOT use the dynamic USE flag"
- epause 5
- fi
-}
-
-src_configure() {
- use selinux || export ac_cv_lib_selinux_is_selinux_enabled=no
- econf \
- --sbindir=/sbin \
- $(use_enable !dynamic static) \
- --enable-libgcrypt \
- --enable-libdevmapper \
- --libdir=/usr/$(get_libdir) \
- $(use_enable nls) \
- || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- rmdir "${D}"/usr/$(get_libdir)/cryptsetup
- insinto /$(get_libdir)/rcscripts/addons
- newins "${FILESDIR}"/1.0.6-r2-dm-crypt-start.sh dm-crypt-start.sh || die
- newins "${FILESDIR}"/1.0.5-dm-crypt-stop.sh dm-crypt-stop.sh || die
- newconfd "${FILESDIR}"/1.0.6-dmcrypt.confd dmcrypt || die
- newinitd "${FILESDIR}"/1.0.5-dmcrypt.rc dmcrypt || die
-}
-
-pkg_postinst() {
- ewarn "This ebuild introduces a new set of scripts and configuration"
- ewarn "than the last version. If you are currently using /etc/conf.d/cryptfs"
- ewarn "then you *MUST* copy your old file to:"
- ewarn "/etc/conf.d/dmcrypt"
- ewarn "Or your encrypted partitions will *NOT* work."
- elog "Please see the example for configuring a LUKS mountpoint"
- elog "in /etc/conf.d/dmcrypt"
- elog
- elog "If you are using baselayout-2 then please do:"
- elog "rc-update add dmcrypt boot"
- elog "This version introduces a command line arguement 'key_timeout'."
- elog "If you want the search for the removable key device to timeout"
- elog "after 10 seconds add the following to your bootloader config:"
- elog "key_timeout=10"
- elog "A timeout of 0 will mean it will wait indefinitely."
-}
diff --git a/sys-fs/cryptsetup/cryptsetup-1.0.7.ebuild b/sys-fs/cryptsetup/cryptsetup-1.0.7.ebuild
deleted file mode 100644
index fa83dbc9429e..000000000000
--- a/sys-fs/cryptsetup/cryptsetup-1.0.7.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.0.7.ebuild,v 1.1 2009/11/28 00:32:54 robbat2 Exp $
-
-EAPI=2
-
-inherit linux-info eutils flag-o-matic multilib
-
-DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
-HOMEPAGE="http://luks.endorphin.org/ http://code.google.com/p/cryptsetup/"
-SRC_URI="http://cryptsetup.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="dynamic nls selinux"
-
-DEPEND="|| (
- >=sys-fs/lvm2-2.02.45
- >=sys-fs/device-mapper-1.00.07-r1
- )
- >=dev-libs/libgcrypt-1.1.42
- >=dev-libs/libgpg-error-1.0-r1
- >=dev-libs/popt-1.7
- >=sys-fs/udev-124
- || ( >=sys-libs/e2fsprogs-libs-1.41 <sys-fs/e2fsprogs-1.41 )
- selinux? ( sys-libs/libselinux )
- !sys-fs/cryptsetup-luks"
-
-dm-crypt_check() {
- local CONFIG_CHECK="~DM_CRYPT"
- local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
- check_extra_config
-}
-
-crypto_check() {
- local CONFIG_CHECK="~CRYPTO"
- local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
- check_extra_config
-}
-
-cbc_check() {
- local CONFIG_CHECK="~CRYPTO_CBC"
- local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
- check_extra_config
-}
-
-pkg_setup() {
- dm-crypt_check
- crypto_check
- cbc_check
-
- if use dynamic ; then
- ewarn "If you need cryptsetup for an initrd or initramfs then you"
- ewarn "should NOT use the dynamic USE flag"
- epause 5
- fi
-}
-
-src_configure() {
- use selinux || export ac_cv_lib_selinux_is_selinux_enabled=no
- econf \
- --sbindir=/sbin \
- $(use_enable !dynamic static) \
- --enable-libgcrypt \
- --enable-libdevmapper \
- --libdir=/usr/$(get_libdir) \
- $(use_enable nls) \
- || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- rmdir "${D}"/usr/$(get_libdir)/cryptsetup
- insinto /$(get_libdir)/rcscripts/addons
- newins "${FILESDIR}"/1.0.6-r2-dm-crypt-start.sh dm-crypt-start.sh || die
- newins "${FILESDIR}"/1.0.5-dm-crypt-stop.sh dm-crypt-stop.sh || die
- newconfd "${FILESDIR}"/1.0.6-dmcrypt.confd dmcrypt || die
- newinitd "${FILESDIR}"/1.0.5-dmcrypt.rc dmcrypt || die
-}
-
-pkg_postinst() {
- ewarn "This ebuild introduces a new set of scripts and configuration"
- ewarn "than the last version. If you are currently using /etc/conf.d/cryptfs"
- ewarn "then you *MUST* copy your old file to:"
- ewarn "/etc/conf.d/dmcrypt"
- ewarn "Or your encrypted partitions will *NOT* work."
- elog "Please see the example for configuring a LUKS mountpoint"
- elog "in /etc/conf.d/dmcrypt"
- elog
- elog "If you are using baselayout-2 then please do:"
- elog "rc-update add dmcrypt boot"
- elog "This version introduces a command line arguement 'key_timeout'."
- elog "If you want the search for the removable key device to timeout"
- elog "after 10 seconds add the following to your bootloader config:"
- elog "key_timeout=10"
- elog "A timeout of 0 will mean it will wait indefinitely."
-}
diff --git a/sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild b/sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild
deleted file mode 100644
index 4744e5b10903..000000000000
--- a/sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild,v 1.2 2010/04/23 19:35:04 robbat2 Exp $
-
-EAPI=2
-
-inherit linux-info eutils flag-o-matic multilib autotools
-
-MY_P=${P/_rc/-rc}
-DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
-HOMEPAGE="http://code.google.com/p/cryptsetup/"
-SRC_URI="http://cryptsetup.googlecode.com/files/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="dynamic nls selinux"
-
-S=${WORKDIR}/${MY_P}
-
-DEPEND=">=sys-fs/lvm2-2.02.56-r1
- >=dev-libs/libgcrypt-1.1.42
- >=dev-libs/libgpg-error-1.0-r1
- >=dev-libs/popt-1.7
- >=sys-fs/udev-124
- || ( >=sys-libs/e2fsprogs-libs-1.41 <sys-fs/e2fsprogs-1.41 )
- selinux? ( sys-libs/libselinux )
- !sys-fs/cryptsetup-luks"
-
-pkg_setup() {
- local CONFIG_CHECK="~DM_CRYPT ~CRYPTO ~CRYPTO_CBC"
- local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
- local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
- local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
- check_extra_config
-
- if use dynamic ; then
- ewarn "If you need cryptsetup for an initrd or initramfs then you"
- ewarn "should NOT use the dynamic USE flag"
- epause 5
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/1.1.0_rc3-static-no-selinux.patch
- epatch "${FILESDIR}"/1.1.0-libudev.patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- --sbindir=/sbin \
- --enable-shared \
- $(use_enable !dynamic static) \
- --libdir=/usr/$(get_libdir) \
- $(use_enable nls) \
- $(use_enable selinux) \
- || die
-}
-
-src_compile() {
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- rmdir "${D}"/usr/$(get_libdir)/cryptsetup
- insinto /$(get_libdir)/rcscripts/addons
- newins "${FILESDIR}"/1.0.6-r2-dm-crypt-start.sh dm-crypt-start.sh || die
- newins "${FILESDIR}"/1.0.5-dm-crypt-stop.sh dm-crypt-stop.sh || die
- newconfd "${FILESDIR}"/1.0.6-dmcrypt.confd dmcrypt || die
- newinitd "${FILESDIR}"/1.0.5-dmcrypt.rc dmcrypt || die
-}
-
-pkg_postinst() {
- ewarn "This ebuild introduces a new set of scripts and configuration"
- ewarn "than the last version. If you are currently using /etc/conf.d/cryptfs"
- ewarn "then you *MUST* copy your old file to:"
- ewarn "/etc/conf.d/dmcrypt"
- ewarn "Or your encrypted partitions will *NOT* work."
- elog "Please see the example for configuring a LUKS mountpoint"
- elog "in /etc/conf.d/dmcrypt"
- elog
- elog "If you are using baselayout-2 then please do:"
- elog "rc-update add dmcrypt boot"
- elog "This version introduces a command line arguement 'key_timeout'."
- elog "If you want the search for the removable key device to timeout"
- elog "after 10 seconds add the following to your bootloader config:"
- elog "key_timeout=10"
- elog "A timeout of 0 will mean it will wait indefinitely."
-}
diff --git a/sys-fs/cryptsetup/cryptsetup-1.1.1.ebuild b/sys-fs/cryptsetup/cryptsetup-1.1.1.ebuild
deleted file mode 100644
index 7063c8ad4afe..000000000000
--- a/sys-fs/cryptsetup/cryptsetup-1.1.1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.1.1.ebuild,v 1.1 2010/05/24 18:34:15 robbat2 Exp $
-
-EAPI=2
-
-inherit linux-info eutils flag-o-matic multilib autotools
-
-MY_P=${P/_rc/-rc}
-DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
-HOMEPAGE="http://code.google.com/p/cryptsetup/"
-SRC_URI="http://cryptsetup.googlecode.com/files/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="dynamic nls selinux"
-
-S=${WORKDIR}/${MY_P}
-
-DEPEND=">=sys-fs/lvm2-2.02.64
- >=dev-libs/libgcrypt-1.1.42
- >=dev-libs/libgpg-error-1.0-r1
- >=dev-libs/popt-1.7
- >=sys-fs/udev-124
- || ( >=sys-libs/e2fsprogs-libs-1.41 <sys-fs/e2fsprogs-1.41 )
- selinux? ( sys-libs/libselinux )
- !sys-fs/cryptsetup-luks"
-
-pkg_setup() {
- local CONFIG_CHECK="~DM_CRYPT ~CRYPTO ~CRYPTO_CBC"
- local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
- local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
- local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
- check_extra_config
-
- if use dynamic ; then
- ewarn "If you need cryptsetup for an initrd or initramfs then you"
- ewarn "should NOT use the dynamic USE flag"
- epause 5
- fi
-}
-
-src_prepare() {
- # Both merged upstream
- #epatch "${FILESDIR}"/1.1.0_rc3-static-no-selinux.patch
- #epatch "${FILESDIR}"/1.1.0-libudev.patch
- eautoreconf
- :
-}
-
-src_configure() {
- econf \
- --sbindir=/sbin \
- --enable-shared \
- $(use_enable !dynamic static) \
- --libdir=/usr/$(get_libdir) \
- $(use_enable nls) \
- $(use_enable selinux) \
- || die
-}
-
-src_compile() {
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- rmdir "${D}"/usr/$(get_libdir)/cryptsetup
- insinto /$(get_libdir)/rcscripts/addons
- newins "${FILESDIR}"/1.0.6-r2-dm-crypt-start.sh dm-crypt-start.sh || die
- newins "${FILESDIR}"/1.0.5-dm-crypt-stop.sh dm-crypt-stop.sh || die
- newconfd "${FILESDIR}"/1.0.6-dmcrypt.confd dmcrypt || die
- newinitd "${FILESDIR}"/1.0.5-dmcrypt.rc dmcrypt || die
- dodoc TODO ChangeLog # README NEWS # last ones are empty
-}
-
-pkg_postinst() {
- ewarn "This ebuild introduces a new set of scripts and configuration"
- ewarn "than the last version. If you are currently using /etc/conf.d/cryptfs"
- ewarn "then you *MUST* copy your old file to:"
- ewarn "/etc/conf.d/dmcrypt"
- ewarn "Or your encrypted partitions will *NOT* work."
- elog "Please see the example for configuring a LUKS mountpoint"
- elog "in /etc/conf.d/dmcrypt"
- elog
- elog "If you are using baselayout-2 then please do:"
- elog "rc-update add dmcrypt boot"
- elog "This version introduces a command line arguement 'key_timeout'."
- elog "If you want the search for the removable key device to timeout"
- elog "after 10 seconds add the following to your bootloader config:"
- elog "key_timeout=10"
- elog "A timeout of 0 will mean it will wait indefinitely."
-}
diff --git a/sys-fs/cryptsetup/cryptsetup-1.1.1_rc1.ebuild b/sys-fs/cryptsetup/cryptsetup-1.1.1_rc1.ebuild
deleted file mode 100644
index ce208fc85c2a..000000000000
--- a/sys-fs/cryptsetup/cryptsetup-1.1.1_rc1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.1.1_rc1.ebuild,v 1.2 2010/05/01 21:59:18 robbat2 Exp $
-
-EAPI=2
-
-inherit linux-info eutils flag-o-matic multilib autotools
-
-MY_P=${P/_rc/-rc}
-DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
-HOMEPAGE="http://code.google.com/p/cryptsetup/"
-SRC_URI="http://cryptsetup.googlecode.com/files/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="dynamic nls selinux"
-
-S=${WORKDIR}/${MY_P}
-
-DEPEND=">=sys-fs/lvm2-2.02.64
- >=dev-libs/libgcrypt-1.1.42
- >=dev-libs/libgpg-error-1.0-r1
- >=dev-libs/popt-1.7
- >=sys-fs/udev-124
- || ( >=sys-libs/e2fsprogs-libs-1.41 <sys-fs/e2fsprogs-1.41 )
- selinux? ( sys-libs/libselinux )
- !sys-fs/cryptsetup-luks"
-
-pkg_setup() {
- local CONFIG_CHECK="~DM_CRYPT ~CRYPTO ~CRYPTO_CBC"
- local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
- local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
- local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
- check_extra_config
-
- if use dynamic ; then
- ewarn "If you need cryptsetup for an initrd or initramfs then you"
- ewarn "should NOT use the dynamic USE flag"
- epause 5
- fi
-}
-
-src_prepare() {
- # Both merged upstream
- #epatch "${FILESDIR}"/1.1.0_rc3-static-no-selinux.patch
- #epatch "${FILESDIR}"/1.1.0-libudev.patch
- eautoreconf
- :
-}
-
-src_configure() {
- econf \
- --sbindir=/sbin \
- --enable-shared \
- $(use_enable !dynamic static) \
- --libdir=/usr/$(get_libdir) \
- $(use_enable nls) \
- $(use_enable selinux) \
- || die
-}
-
-src_compile() {
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- rmdir "${D}"/usr/$(get_libdir)/cryptsetup
- insinto /$(get_libdir)/rcscripts/addons
- newins "${FILESDIR}"/1.0.6-r2-dm-crypt-start.sh dm-crypt-start.sh || die
- newins "${FILESDIR}"/1.0.5-dm-crypt-stop.sh dm-crypt-stop.sh || die
- newconfd "${FILESDIR}"/1.0.6-dmcrypt.confd dmcrypt || die
- newinitd "${FILESDIR}"/1.0.5-dmcrypt.rc dmcrypt || die
-}
-
-pkg_postinst() {
- ewarn "This ebuild introduces a new set of scripts and configuration"
- ewarn "than the last version. If you are currently using /etc/conf.d/cryptfs"
- ewarn "then you *MUST* copy your old file to:"
- ewarn "/etc/conf.d/dmcrypt"
- ewarn "Or your encrypted partitions will *NOT* work."
- elog "Please see the example for configuring a LUKS mountpoint"
- elog "in /etc/conf.d/dmcrypt"
- elog
- elog "If you are using baselayout-2 then please do:"
- elog "rc-update add dmcrypt boot"
- elog "This version introduces a command line arguement 'key_timeout'."
- elog "If you want the search for the removable key device to timeout"
- elog "after 10 seconds add the following to your bootloader config:"
- elog "key_timeout=10"
- elog "A timeout of 0 will mean it will wait indefinitely."
-}
diff --git a/sys-fs/cryptsetup/cryptsetup-1.1.1_rc2.ebuild b/sys-fs/cryptsetup/cryptsetup-1.1.1_rc2.ebuild
deleted file mode 100644
index 63272abcaa7b..000000000000
--- a/sys-fs/cryptsetup/cryptsetup-1.1.1_rc2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.1.1_rc2.ebuild,v 1.1 2010/05/14 08:50:14 robbat2 Exp $
-
-EAPI=2
-
-inherit linux-info eutils flag-o-matic multilib autotools
-
-MY_P=${P/_rc/-rc}
-DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
-HOMEPAGE="http://code.google.com/p/cryptsetup/"
-SRC_URI="http://cryptsetup.googlecode.com/files/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="dynamic nls selinux"
-
-S=${WORKDIR}/${MY_P}
-
-DEPEND=">=sys-fs/lvm2-2.02.64
- >=dev-libs/libgcrypt-1.1.42
- >=dev-libs/libgpg-error-1.0-r1
- >=dev-libs/popt-1.7
- >=sys-fs/udev-124
- || ( >=sys-libs/e2fsprogs-libs-1.41 <sys-fs/e2fsprogs-1.41 )
- selinux? ( sys-libs/libselinux )
- !sys-fs/cryptsetup-luks"
-
-pkg_setup() {
- local CONFIG_CHECK="~DM_CRYPT ~CRYPTO ~CRYPTO_CBC"
- local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
- local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
- local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
- check_extra_config
-
- if use dynamic ; then
- ewarn "If you need cryptsetup for an initrd or initramfs then you"
- ewarn "should NOT use the dynamic USE flag"
- epause 5
- fi
-}
-
-src_prepare() {
- # Both merged upstream
- #epatch "${FILESDIR}"/1.1.0_rc3-static-no-selinux.patch
- #epatch "${FILESDIR}"/1.1.0-libudev.patch
- eautoreconf
- :
-}
-
-src_configure() {
- econf \
- --sbindir=/sbin \
- --enable-shared \
- $(use_enable !dynamic static) \
- --libdir=/usr/$(get_libdir) \
- $(use_enable nls) \
- $(use_enable selinux) \
- || die
-}
-
-src_compile() {
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- rmdir "${D}"/usr/$(get_libdir)/cryptsetup
- insinto /$(get_libdir)/rcscripts/addons
- newins "${FILESDIR}"/1.0.6-r2-dm-crypt-start.sh dm-crypt-start.sh || die
- newins "${FILESDIR}"/1.0.5-dm-crypt-stop.sh dm-crypt-stop.sh || die
- newconfd "${FILESDIR}"/1.0.6-dmcrypt.confd dmcrypt || die
- newinitd "${FILESDIR}"/1.0.5-dmcrypt.rc dmcrypt || die
- dodoc TODO ChangeLog # README NEWS # last ones are empty
-}
-
-pkg_postinst() {
- ewarn "This ebuild introduces a new set of scripts and configuration"
- ewarn "than the last version. If you are currently using /etc/conf.d/cryptfs"
- ewarn "then you *MUST* copy your old file to:"
- ewarn "/etc/conf.d/dmcrypt"
- ewarn "Or your encrypted partitions will *NOT* work."
- elog "Please see the example for configuring a LUKS mountpoint"
- elog "in /etc/conf.d/dmcrypt"
- elog
- elog "If you are using baselayout-2 then please do:"
- elog "rc-update add dmcrypt boot"
- elog "This version introduces a command line arguement 'key_timeout'."
- elog "If you want the search for the removable key device to timeout"
- elog "after 10 seconds add the following to your bootloader config:"
- elog "key_timeout=10"
- elog "A timeout of 0 will mean it will wait indefinitely."
-}