summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2006-08-02 14:05:46 +0000
committerPatrick McLean <chutzpah@gentoo.org>2006-08-02 14:05:46 +0000
commit99c80739cebb890219a0a933989ec7d22c26814c (patch)
tree048555263cd2525e7c5bb37434e379b641497397 /sys-fs
parentStable on sparc wrt security #142248 (diff)
downloadgentoo-2-99c80739cebb890219a0a933989ec7d22c26814c.tar.gz
gentoo-2-99c80739cebb890219a0a933989ec7d22c26814c.tar.bz2
gentoo-2-99c80739cebb890219a0a933989ec7d22c26814c.zip
New revision, don't install the useless headers since anything that needs them deps in ntfsprogs which has basically the same headers. This allows us to remove the block agains sys-fs/ntfsprogs.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g/ChangeLog10
-rw-r--r--sys-fs/ntfs3g/files/digest-ntfs3g-0.1_beta20070714-r13
-rw-r--r--sys-fs/ntfs3g/ntfs3g-0.1_beta20070714-r1.ebuild39
3 files changed, 51 insertions, 1 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 3a67853474d5..4e6ac9dffc07 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.6 2006/07/29 20:25:35 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.7 2006/08/02 14:05:45 chutzpah Exp $
+
+*ntfs3g-0.1_beta20070714-r1 (02 Aug 2006)
+
+ 02 Aug 2006; Patrick McLean <chutzpah@gentoo.org>
+ +ntfs3g-0.1_beta20070714-r1.ebuild:
+ New revision, don't install the useless headers since anything that needs
+ them deps in ntfsprogs which has basically the same headers. This allows us
+ to remove the block agains sys-fs/ntfsprogs.
29 Jul 2006; Patrick McLean <chutzpah@gentoo.org>
ntfs3g-0.1_beta20070714.ebuild:
diff --git a/sys-fs/ntfs3g/files/digest-ntfs3g-0.1_beta20070714-r1 b/sys-fs/ntfs3g/files/digest-ntfs3g-0.1_beta20070714-r1
new file mode 100644
index 000000000000..6426e14fd7c3
--- /dev/null
+++ b/sys-fs/ntfs3g/files/digest-ntfs3g-0.1_beta20070714-r1
@@ -0,0 +1,3 @@
+MD5 00e8f27da72ed51f6c99ebaef0989297 ntfs-3g-20070714-BETA.tgz 654526
+RMD160 5fb090bb35f8af1b2409ea576b9b441730d60717 ntfs-3g-20070714-BETA.tgz 654526
+SHA256 f55e8cb1637aa6940f745f50940b43c060b52350d1004406b6a141658a23ddf3 ntfs-3g-20070714-BETA.tgz 654526
diff --git a/sys-fs/ntfs3g/ntfs3g-0.1_beta20070714-r1.ebuild b/sys-fs/ntfs3g/ntfs3g-0.1_beta20070714-r1.ebuild
new file mode 100644
index 000000000000..6c4aaf16e7f6
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-0.1_beta20070714-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-0.1_beta20070714-r1.ebuild,v 1.1 2006/08/02 14:05:45 chutzpah Exp $
+
+MY_PN="${PN/3g/-3g}"
+MY_PV="${PV#0.1_beta}"
+MY_PV="${MY_PV}-BETA"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://sourceforge.net/mailarchive/forum.php?thread_id=23836054&forum_id=2697"
+SRC_URI="http://mlf.linux.rulez.org/mlf/ezaz/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/fuse-2.5.0"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # default makefile calls ldconfig
+ sed -ie '/ldconfig$/ d' src/Makefile.*
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog CREDITS NEWS README
+
+ # remove uselessly installed headers so we don't collide with
+ # sys-fs/ntfsprogs anymore
+ rm -rf "${D}"/usr/include
+}