summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-30 06:03:49 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-30 06:03:49 +0000
commit966d0a3805e8c4edc32775a980d91c9b63a17e69 (patch)
treef0d4d03ca167c8af102f24b03ea1d1743060d492 /sys-fs
parentCorrected HOMEPAGE, #414051 (diff)
downloadgentoo-2-966d0a3805e8c4edc32775a980d91c9b63a17e69.tar.gz
gentoo-2-966d0a3805e8c4edc32775a980d91c9b63a17e69.tar.bz2
gentoo-2-966d0a3805e8c4edc32775a980d91c9b63a17e69.zip
sys-fs/aufs3: Version Bump
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/aufs3/ChangeLog8
-rw-r--r--sys-fs/aufs3/aufs3-3_p20120430.ebuild144
-rw-r--r--sys-fs/aufs3/files/aufs3-base-x-rcN.patch10
-rw-r--r--sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch16
4 files changed, 164 insertions, 14 deletions
diff --git a/sys-fs/aufs3/ChangeLog b/sys-fs/aufs3/ChangeLog
index c87f8e317c75..c357becee3bb 100644
--- a/sys-fs/aufs3/ChangeLog
+++ b/sys-fs/aufs3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/aufs3
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.11 2012/04/28 06:59:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.12 2012/04/30 06:03:49 jlec Exp $
+
+*aufs3-3_p20120430 (30 Apr 2012)
+
+ 30 Apr 2012; Justin Lecher <jlec@gentoo.org> files/aufs3-base-x-rcN.patch,
+ files/aufs3-standalone-x-rcN.patch, +aufs3-3_p20120430.ebuild:
+ Version Bump
28 Apr 2012; Justin Lecher <jlec@gentoo.org> aufs3-3_p20120402.ebuild,
+files/parallel.patch:
diff --git a/sys-fs/aufs3/aufs3-3_p20120430.ebuild b/sys-fs/aufs3/aufs3-3_p20120430.ebuild
new file mode 100644
index 000000000000..39440de806ed
--- /dev/null
+++ b/sys-fs/aufs3/aufs3-3_p20120430.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20120430.ebuild,v 1.1 2012/04/30 06:03:49 jlec Exp $
+
+EAPI=4
+
+inherit linux-mod multilib toolchain-funcs
+
+AUFS_VERSION="${PV%%_p*}"
+PATCH_MAX_VER="3"
+UTIL_MAX_VER="0"
+
+DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc fuse pax_kernel hfs inotify kernel-patch nfs ramfs"
+
+DEPEND="dev-vcs/git"
+RDEPEND="
+ !sys-fs/aufs
+ !sys-fs/aufs2"
+
+S="${WORKDIR}"/${PN}-standalone
+
+MODULE_NAMES="aufs(misc:${S})"
+
+pkg_setup() {
+ CONFIG_CHECK="${CONFIG_CHECK} ~EXPERIMENTAL"
+ use inotify && CONFIG_CHECK="${CONFIG_CHECK} ~FSNOTIFY"
+ use nfs && CONFIG_CHECK="${CONFIG_CHECK} EXPORTFS"
+ use fuse && CONFIG_CHECK="${CONFIG_CHECK} ~FUSE_FS"
+ use hfs && CONFIG_CHECK="${CONFIG_CHECK} ~HFSPLUS_FS"
+
+ # this is needed so merging a binpkg ${PN} is possible w/out a kernel unpacked on the system
+ [ -n "$PKG_SETUP_HAS_BEEN_RAN" ] && return
+
+ get_version
+ kernel_is lt 3 0 0 && die "kernel too old, Please use sys-fs/aufs2"
+ kernel_is gt 3 4 99 && die "kernel too new"
+
+ linux-mod_pkg_setup
+
+ if [[ "${KV_MINOR}" -gt "${PATCH_MAX_VER}" ]]; then
+ PATCH_BRANCH="x-rcN"
+ else
+ PATCH_BRANCH="${KV_MINOR}"
+ fi
+
+ if [[ "${PATCH_BRANCH}" == "x-rcN" ]]; then
+ UTIL_BRANCH="x-rcN"
+ elif [[ "${KV_MINOR}" -gt "${UTIL_MAX_VER}" ]]; then
+ UTIL_BRANCH="${UTIL_MAX_VER}"
+ else
+ UTIL_BRANCH="${KV_MINOR}"
+ fi
+
+ if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/${PN}-standalone-${PATCH_BRANCH}.patch >/dev/null && \
+ patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/${PN}-base-${PATCH_BRANCH}.patch >/dev/null ); then
+ if use kernel-patch; then
+ cd ${KV_DIR}
+ ewarn "Patching your kernel..."
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/${PN}-standalone-${PATCH_BRANCH}.patch >/dev/null
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/${PN}-base-${PATCH_BRANCH}.patch >/dev/null
+ epatch "${FILESDIR}"/${PN}-{base,standalone}-${PATCH_BRANCH}.patch
+ ewarn "You need to compile your kernel with the applied patch"
+ ewarn "to be able to load and use the aufs kernel module"
+ else
+ eerror "You need to apply a patch to your kernel to compile and run the ${PN} module"
+ eerror "Either enable the kernel-patch useflag to do it with this ebuild"
+ eerror "or apply ${FILESDIR}/${PN}-base-${PATCH_BRANCH}.patch and"
+ eerror "${FILESDIR}/${PN}-standalone-${PATCH_BRANCH}.patch by hand"
+ die "missing kernel patch, please apply it first"
+ fi
+ fi
+ export PKG_SETUP_HAS_BEEN_RAN=1
+}
+
+set_config() {
+ for option in $*; do
+ grep -q "^CONFIG_AUFS_${option} =" config.mk || die "${option} is not a valid config option"
+ sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die
+ done
+}
+
+src_prepare() {
+ local module_branch=origin/${PN}.${PATCH_BRANCH}
+ local util_branch=origin/${PN}.${UTIL_BRANCH}
+
+ einfo "Using for module creation branch ${module_branch}"
+ git checkout -q -b local-gentoo ${module_branch} || die
+
+ # All config options to off
+ sed "s:= y:=:g" -i config.mk || die
+
+ set_config RDU BRANCH_MAX_127 SBILIST
+
+ use debug && set_config DEBUG
+ use fuse && set_config BR_FUSE POLL
+ use hfs && set_config BR_HFSPLUS
+ use inotify && set_config HNOTIFY HFSNOTIFY
+ use nfs && set_config EXPORT
+ use nfs && use amd64 && set_config INO_T_64
+ use ramfs && set_config BR_RAMFS
+
+ use pax_kernel && epatch "${FILESDIR}"/pax.patch
+
+ sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile || die
+ sed -i "s:__user::g" include/linux/aufs_type.h || die
+
+ cd "${WORKDIR}"/${PN/3}-util
+
+ einfo "Using for utils building branch ${util_branch}"
+ git checkout -b local-gentoo ${util_branch} || die
+ sed -i "/LDFLAGS += -static -s/d" Makefile || die
+ sed -i -e "s:m 644 -s:m 644:g" -e "s:/usr/lib:/usr/$(get_libdir):g" libau/Makefile || die
+}
+
+src_compile() {
+ local ARCH=x86
+
+ emake CC=$(tc-getCC) CONFIG_AUFS_FS=m KDIR=${KV_DIR}
+
+ cd "${WORKDIR}"/${PN/3}-util
+ emake CC=$(tc-getCC) AR=$(tc-getAR) KDIR=${KV_DIR} C_INCLUDE_PATH="${S}"/include
+}
+
+src_install() {
+ linux-mod_src_install
+
+ insinto /usr/share/doc/${PF}
+
+ use doc && doins -r Documentation
+
+ dodoc README
+
+ cd "${WORKDIR}"/${PN/3}-util
+ emake DESTDIR="${D}" KDIR=${KV_DIR} install
+
+ newdoc README README-utils
+}
diff --git a/sys-fs/aufs3/files/aufs3-base-x-rcN.patch b/sys-fs/aufs3/files/aufs3-base-x-rcN.patch
index 280d36761285..e7c07fd2b864 100644
--- a/sys-fs/aufs3/files/aufs3-base-x-rcN.patch
+++ b/sys-fs/aufs3/files/aufs3-base-x-rcN.patch
@@ -1,10 +1,10 @@
aufs3.x-rcN base patch
diff --git a/fs/namei.c b/fs/namei.c
-index e615ff3..b9b8b85 100644
+index 0062dd1..80bb0b9 100644
--- a/fs/namei.c
+++ b/fs/namei.c
-@@ -1904,7 +1904,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
+@@ -1831,7 +1831,7 @@ int vfs_path_lookup(struct dentry *dentry, struct vfsmount *mnt,
* needs parent already locked. Doesn't follow mounts.
* SMP-safe.
*/
@@ -14,10 +14,10 @@ index e615ff3..b9b8b85 100644
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
diff --git a/fs/splice.c b/fs/splice.c
-index 5f883de..4f786e3 100644
+index f847684..f871233 100644
--- a/fs/splice.c
+++ b/fs/splice.c
-@@ -1081,8 +1081,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
+@@ -1084,8 +1084,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
/*
* Attempt to initiate a splice from pipe to file.
*/
@@ -28,7 +28,7 @@ index 5f883de..4f786e3 100644
{
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *,
loff_t *, size_t, unsigned int);
-@@ -1109,9 +1109,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+@@ -1112,9 +1112,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
/*
* Attempt to initiate a splice from a file to a pipe.
*/
diff --git a/sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch b/sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch
index 10517f5036fb..70ff1593bf37 100644
--- a/sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch
+++ b/sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch
@@ -26,10 +26,10 @@ index 9f4f5fe..bb0f3ba 100644
/*
* Empty aops. Can be used for the cases where the user does not
diff --git a/fs/namei.c b/fs/namei.c
-index b9b8b85..0fa6752 100644
+index 80bb0b9..3430ad3 100644
--- a/fs/namei.c
+++ b/fs/namei.c
-@@ -1908,6 +1908,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
+@@ -1835,6 +1835,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
{
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
@@ -111,7 +111,7 @@ index f104d56..54f36db 100644
static int fsnotify_mark_destroy(void *ignored)
{
diff --git a/fs/open.c b/fs/open.c
-index 77becc0..f634f02 100644
+index 5720854..ec59242 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -60,6 +60,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
@@ -123,10 +123,10 @@ index 77becc0..f634f02 100644
static long do_sys_truncate(const char __user *pathname, loff_t length)
{
diff --git a/fs/splice.c b/fs/splice.c
-index 4f786e3..84e5c7b 100644
+index f871233..70f5481 100644
--- a/fs/splice.c
+++ b/fs/splice.c
-@@ -1105,6 +1105,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+@@ -1108,6 +1108,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return splice_write(pipe, out, ppos, len, flags);
}
@@ -134,7 +134,7 @@ index 4f786e3..84e5c7b 100644
/*
* Attempt to initiate a splice from a file to a pipe.
-@@ -1131,6 +1132,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
+@@ -1134,6 +1135,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return splice_read(in, ppos, pipe, len, flags);
}
@@ -143,10 +143,10 @@ index 4f786e3..84e5c7b 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/security/commoncap.c b/security/commoncap.c
-index 0cf4b53..6ba43f6 100644
+index 71a166a..5d63aac 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
-@@ -966,3 +966,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
+@@ -972,3 +972,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
}
return ret;
}