summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-09-18 15:12:29 +0000
committerThomas Sachau <tommy@gentoo.org>2009-09-18 15:12:29 +0000
commit7d67fe747615f7a4726a884b6635b0597ea7c2cc (patch)
tree00736facb41ff2535187ea930421a8476235d9b9 /sys-fs
parentMigrate to EAPI 2 in order to remove built_with_use usage. (diff)
downloadgentoo-2-7d67fe747615f7a4726a884b6635b0597ea7c2cc.tar.gz
gentoo-2-7d67fe747615f7a4726a884b6635b0597ea7c2cc.tar.bz2
gentoo-2-7d67fe747615f7a4726a884b6635b0597ea7c2cc.zip
Version bump, switch to tarball as requested in bug 282504
(Portage version: 2.2_rc40-r1/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/aufs2/ChangeLog10
-rw-r--r--sys-fs/aufs2/aufs2-0_p20090916.ebuild86
-rw-r--r--sys-fs/aufs2/files/aufs2-0_p20090916-makefile.patch.bz2bin0 -> 252 bytes
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-28.patch76
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-29.patch76
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-30.patch76
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-31.patch182
7 files changed, 298 insertions, 208 deletions
diff --git a/sys-fs/aufs2/ChangeLog b/sys-fs/aufs2/ChangeLog
index 1cdaf8008b4c..02cae4b373e9 100644
--- a/sys-fs/aufs2/ChangeLog
+++ b/sys-fs/aufs2/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/aufs2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.7 2009/07/28 18:43:26 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.8 2009/09/18 15:12:29 tommy Exp $
+
+*aufs2-0_p20090916 (18 Sep 2009)
+
+ 18 Sep 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +aufs2-0_p20090916.ebuild, +files/aufs2-0_p20090916-makefile.patch.bz2,
+ files/aufs2-standalone-28.patch, files/aufs2-standalone-29.patch,
+ files/aufs2-standalone-30.patch, +files/aufs2-standalone-31.patch:
+ Version bump, switch to tarball as requested in bug 282504
*aufs2-0_p20090727 (28 Jul 2009)
diff --git a/sys-fs/aufs2/aufs2-0_p20090916.ebuild b/sys-fs/aufs2/aufs2-0_p20090916.ebuild
new file mode 100644
index 000000000000..a066bed3cb3d
--- /dev/null
+++ b/sys-fs/aufs2/aufs2-0_p20090916.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20090916.ebuild,v 1.1 2009/09/18 15:12:29 tommy Exp $
+
+EAPI="2"
+
+inherit linux-mod toolchain-funcs
+
+DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
+HOMEPAGE="http://aufs.sourceforge.net"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug inotify kernel-patch ramfs"
+
+DEPEND="dev-util/git"
+RDEPEND="!sys-fs/aufs"
+
+S=${WORKDIR}/${PN}-standalone
+
+MODULE_NAMES="aufs(misc:${S})"
+
+pkg_setup() {
+ get_version
+ kernel_is lt 2 6 27 && die "kernel too old"
+ kernel_is gt 2 6 31 && die "kernel too new"
+
+ if ! patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null; then
+ if use kernel-patch; then
+ cd ${KV_DIR}
+ ewarn "Patching your kernel..."
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null
+ epatch "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch
+ einfo "You need to compile your kernel with the applied patch"
+ einfo "to be able to load and use the aufs kernel module"
+ else
+ eerror "You need to apply a patch to your kernel to compile and run the aufs2 module"
+ eerror "Either enable the kernel-patch useflag to do it with this ebuild"
+ eerror "or apply ${FILESDIR}/aufs2-standalone-${KV_PATCH}.patch by hand"
+ die "missing kernel patch, please apply it first"
+ fi
+ fi
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ local branch=origin/aufs2-${KV_PATCH}
+ if [[ $KV_PATCH == 31 ]] ; then
+ branch=origin/aufs2
+ fi
+ git checkout -q $branch || die
+ if ! use debug; then
+ sed -i "s:DEBUG = y:DEBUG =:g" config.mk || die
+ fi
+ if use inotify; then
+ sed -i "s:HINOTIFY =:HINOTIFY = y:g" config.mk || die
+ fi
+ if use ramfs; then
+ sed -i "s:RAMFS =:RAMFS = y:g" config.mk || die
+ fi
+
+ cd "${WORKDIR}"/${PN}-util
+ sed -i "/LDFLAGS += -static -s/d" Makefile || die
+ epatch "${FILESDIR}"/${P}-makefile.patch.bz2
+}
+
+src_compile() {
+ local ARCH=i386
+ use amd64 && ARCH=x86_64
+ emake CC=$(tc-getCC) CONFIG_AUFS_FS=m KDIR=${KV_DIR} || die
+ cd "${WORKDIR}"/${PN}-util
+ emake CC=$(tc-getCC) AR=$(tc-getAR) KDIR=${KV_DIR} C_INCLUDE_PATH="${S}"/include || die
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README || die
+ docinto design
+ dodoc design/*.txt || die
+ cd "${WORKDIR}"/${PN}-util
+ emake DESTDIR="${D}" install || die
+ docinto
+ newdoc README README-utils || die
+}
diff --git a/sys-fs/aufs2/files/aufs2-0_p20090916-makefile.patch.bz2 b/sys-fs/aufs2/files/aufs2-0_p20090916-makefile.patch.bz2
new file mode 100644
index 000000000000..6d9be72b5b5e
--- /dev/null
+++ b/sys-fs/aufs2/files/aufs2-0_p20090916-makefile.patch.bz2
Binary files differ
diff --git a/sys-fs/aufs2/files/aufs2-standalone-28.patch b/sys-fs/aufs2/files/aufs2-standalone-28.patch
index 3cb3ad21a1ab..5ce4bc016778 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-28.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-28.patch
@@ -1,7 +1,7 @@
aufs2 standalone patch for linux-2.6.28
diff --git a/fs/namei.c b/fs/namei.c
-index d34e0f9..2779304 100644
+index 3791609..2779304 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -341,6 +341,7 @@ int deny_write_access(struct file * file)
@@ -12,27 +12,15 @@ index d34e0f9..2779304 100644
/**
* path_get - get a reference to a path
-@@ -1212,7 +1213,7 @@ out:
- * needs parent already locked. Doesn't follow mounts.
- * SMP-safe.
- */
--static struct dentry *lookup_hash(struct nameidata *nd)
-+struct dentry *lookup_hash(struct nameidata *nd)
- {
- int err;
-
-@@ -1221,8 +1222,9 @@ static struct dentry *lookup_hash(struct nameidata *nd)
+@@ -1221,6 +1222,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
return ERR_PTR(err);
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
+EXPORT_SYMBOL(lookup_hash);
--static int __lookup_one_len(const char *name, struct qstr *this,
-+int __lookup_one_len(const char *name, struct qstr *this,
+ int __lookup_one_len(const char *name, struct qstr *this,
struct dentry *base, int len)
- {
- unsigned long hash;
-@@ -1243,6 +1245,7 @@ static int __lookup_one_len(const char *name, struct qstr *this,
+@@ -1243,6 +1245,7 @@ int __lookup_one_len(const char *name, struct qstr *this,
this->hash = end_name_hash(hash);
return 0;
}
@@ -65,21 +53,10 @@ index 83cdb9d..bb43dab 100644
static long do_sys_truncate(const char __user *pathname, loff_t length)
{
diff --git a/fs/splice.c b/fs/splice.c
-index 1abab5c..7b7d65e 100644
+index 678100b..7b7d65e 100644
--- a/fs/splice.c
+++ b/fs/splice.c
-@@ -887,8 +887,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
- /*
- * Attempt to initiate a splice from pipe to file.
- */
--static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
-- loff_t *ppos, size_t len, unsigned int flags)
-+long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
-+ loff_t *ppos, size_t len, unsigned int flags)
- {
- int ret;
-
-@@ -907,13 +907,14 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+@@ -907,6 +907,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return out->f_op->splice_write(pipe, out, ppos, len, flags);
}
@@ -87,17 +64,7 @@ index 1abab5c..7b7d65e 100644
/*
* Attempt to initiate a splice from a file to a pipe.
- */
--static long do_splice_to(struct file *in, loff_t *ppos,
-- struct pipe_inode_info *pipe, size_t len,
-- unsigned int flags)
-+long do_splice_to(struct file *in, loff_t *ppos,
-+ struct pipe_inode_info *pipe, size_t len,
-+ unsigned int flags)
- {
- int ret;
-
-@@ -929,6 +930,7 @@ static long do_splice_to(struct file *in, loff_t *ppos,
+@@ -929,6 +930,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return in->f_op->splice_read(in, ppos, pipe, len, flags);
}
@@ -129,35 +96,6 @@ index 2967562..34040d6 100644
static long __do_fsync(unsigned int fd, int datasync)
{
-diff --git a/include/linux/namei.h b/include/linux/namei.h
-index 99eb803..f6cdf1c 100644
---- a/include/linux/namei.h
-+++ b/include/linux/namei.h
-@@ -75,6 +75,9 @@ extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry
- extern struct file *nameidata_to_filp(struct nameidata *nd, int flags);
- extern void release_open_intent(struct nameidata *);
-
-+extern struct dentry *lookup_hash(struct nameidata *nd);
-+extern int __lookup_one_len(const char *name, struct qstr *this,
-+ struct dentry *base, int len);
- extern struct dentry *lookup_one_len(const char *, struct dentry *, int);
- extern struct dentry *lookup_one_noperm(const char *, struct dentry *);
-
-diff --git a/include/linux/splice.h b/include/linux/splice.h
-index 528dcb9..5123bc6 100644
---- a/include/linux/splice.h
-+++ b/include/linux/splice.h
-@@ -71,4 +71,10 @@ extern ssize_t splice_to_pipe(struct pipe_inode_info *,
- extern ssize_t splice_direct_to_actor(struct file *, struct splice_desc *,
- splice_direct_actor *);
-
-+extern long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
-+ loff_t *ppos, size_t len, unsigned int flags);
-+extern long do_splice_to(struct file *in, loff_t *ppos,
-+ struct pipe_inode_info *pipe, size_t len,
-+ unsigned int flags);
-+
- #endif
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 5ba7870..8f880c2 100644
--- a/security/device_cgroup.c
diff --git a/sys-fs/aufs2/files/aufs2-standalone-29.patch b/sys-fs/aufs2/files/aufs2-standalone-29.patch
index fbe1c7ecdb02..4ea6675ac92e 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-29.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-29.patch
@@ -1,7 +1,7 @@
aufs2 standalone patch for linux-2.6.29
diff --git a/fs/namei.c b/fs/namei.c
-index bbc15c2..e54d1b2 100644
+index db581b4..e54d1b2 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -335,6 +335,7 @@ int deny_write_access(struct file * file)
@@ -12,27 +12,15 @@ index bbc15c2..e54d1b2 100644
/**
* path_get - get a reference to a path
-@@ -1196,7 +1197,7 @@ out:
- * needs parent already locked. Doesn't follow mounts.
- * SMP-safe.
- */
--static struct dentry *lookup_hash(struct nameidata *nd)
-+struct dentry *lookup_hash(struct nameidata *nd)
- {
- int err;
-
-@@ -1205,8 +1206,9 @@ static struct dentry *lookup_hash(struct nameidata *nd)
+@@ -1205,6 +1206,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
return ERR_PTR(err);
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
+EXPORT_SYMBOL(lookup_hash);
--static int __lookup_one_len(const char *name, struct qstr *this,
-+int __lookup_one_len(const char *name, struct qstr *this,
+ int __lookup_one_len(const char *name, struct qstr *this,
struct dentry *base, int len)
- {
- unsigned long hash;
-@@ -1227,6 +1229,7 @@ static int __lookup_one_len(const char *name, struct qstr *this,
+@@ -1227,6 +1229,7 @@ int __lookup_one_len(const char *name, struct qstr *this,
this->hash = end_name_hash(hash);
return 0;
}
@@ -65,21 +53,10 @@ index a3a78ce..d2f61c7 100644
static long do_sys_truncate(const char __user *pathname, loff_t length)
{
diff --git a/fs/splice.c b/fs/splice.c
-index 4ed0ba4..57cce07 100644
+index 2fb3d17..57cce07 100644
--- a/fs/splice.c
+++ b/fs/splice.c
-@@ -888,8 +888,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
- /*
- * Attempt to initiate a splice from pipe to file.
- */
--static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
-- loff_t *ppos, size_t len, unsigned int flags)
-+long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
-+ loff_t *ppos, size_t len, unsigned int flags)
- {
- int ret;
-
-@@ -908,13 +908,14 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+@@ -908,6 +908,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return out->f_op->splice_write(pipe, out, ppos, len, flags);
}
@@ -87,17 +64,7 @@ index 4ed0ba4..57cce07 100644
/*
* Attempt to initiate a splice from a file to a pipe.
- */
--static long do_splice_to(struct file *in, loff_t *ppos,
-- struct pipe_inode_info *pipe, size_t len,
-- unsigned int flags)
-+long do_splice_to(struct file *in, loff_t *ppos,
-+ struct pipe_inode_info *pipe, size_t len,
-+ unsigned int flags)
- {
- int ret;
-
-@@ -930,6 +931,7 @@ static long do_splice_to(struct file *in, loff_t *ppos,
+@@ -930,6 +931,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return in->f_op->splice_read(in, ppos, pipe, len, flags);
}
@@ -117,35 +84,6 @@ index 6ce5014..af66b69 100644
/**
* generic_shutdown_super - common helper for ->kill_sb()
-diff --git a/include/linux/namei.h b/include/linux/namei.h
-index fc2e035..182d43b 100644
---- a/include/linux/namei.h
-+++ b/include/linux/namei.h
-@@ -75,6 +75,9 @@ extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry
- extern struct file *nameidata_to_filp(struct nameidata *nd, int flags);
- extern void release_open_intent(struct nameidata *);
-
-+extern struct dentry *lookup_hash(struct nameidata *nd);
-+extern int __lookup_one_len(const char *name, struct qstr *this,
-+ struct dentry *base, int len);
- extern struct dentry *lookup_one_len(const char *, struct dentry *, int);
- extern struct dentry *lookup_one_noperm(const char *, struct dentry *);
-
-diff --git a/include/linux/splice.h b/include/linux/splice.h
-index 528dcb9..5123bc6 100644
---- a/include/linux/splice.h
-+++ b/include/linux/splice.h
-@@ -71,4 +71,10 @@ extern ssize_t splice_to_pipe(struct pipe_inode_info *,
- extern ssize_t splice_direct_to_actor(struct file *, struct splice_desc *,
- splice_direct_actor *);
-
-+extern long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
-+ loff_t *ppos, size_t len, unsigned int flags);
-+extern long do_splice_to(struct file *in, loff_t *ppos,
-+ struct pipe_inode_info *pipe, size_t len,
-+ unsigned int flags);
-+
- #endif
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 3aacd0f..b900dc3 100644
--- a/security/device_cgroup.c
diff --git a/sys-fs/aufs2/files/aufs2-standalone-30.patch b/sys-fs/aufs2/files/aufs2-standalone-30.patch
index 1702e1fb909d..f14058dc455e 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-30.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-30.patch
@@ -1,7 +1,7 @@
aufs2 standalone patch for linux-2.6.30
diff --git a/fs/namei.c b/fs/namei.c
-index 967c3db..64a5060 100644
+index 60c01b1..64a5060 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -337,6 +337,7 @@ int deny_write_access(struct file * file)
@@ -12,27 +12,15 @@ index 967c3db..64a5060 100644
/**
* path_get - get a reference to a path
-@@ -1200,7 +1201,7 @@ out:
- * needs parent already locked. Doesn't follow mounts.
- * SMP-safe.
- */
--static struct dentry *lookup_hash(struct nameidata *nd)
-+struct dentry *lookup_hash(struct nameidata *nd)
- {
- int err;
-
-@@ -1209,8 +1210,9 @@ static struct dentry *lookup_hash(struct nameidata *nd)
+@@ -1209,6 +1210,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
return ERR_PTR(err);
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
+EXPORT_SYMBOL(lookup_hash);
--static int __lookup_one_len(const char *name, struct qstr *this,
-+int __lookup_one_len(const char *name, struct qstr *this,
+ int __lookup_one_len(const char *name, struct qstr *this,
struct dentry *base, int len)
- {
- unsigned long hash;
-@@ -1231,6 +1233,7 @@ static int __lookup_one_len(const char *name, struct qstr *this,
+@@ -1231,6 +1233,7 @@ int __lookup_one_len(const char *name, struct qstr *this,
this->hash = end_name_hash(hash);
return 0;
}
@@ -65,21 +53,10 @@ index bdfbf03..81c39b3 100644
static long do_sys_truncate(const char __user *pathname, loff_t length)
{
diff --git a/fs/splice.c b/fs/splice.c
-index 666953d..fbc3f77 100644
+index 35beccd..fbc3f77 100644
--- a/fs/splice.c
+++ b/fs/splice.c
-@@ -905,8 +905,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
- /*
- * Attempt to initiate a splice from pipe to file.
- */
--static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
-- loff_t *ppos, size_t len, unsigned int flags)
-+long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
-+ loff_t *ppos, size_t len, unsigned int flags)
- {
- int ret;
-
-@@ -925,13 +925,14 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+@@ -925,6 +925,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return out->f_op->splice_write(pipe, out, ppos, len, flags);
}
@@ -87,17 +64,7 @@ index 666953d..fbc3f77 100644
/*
* Attempt to initiate a splice from a file to a pipe.
- */
--static long do_splice_to(struct file *in, loff_t *ppos,
-- struct pipe_inode_info *pipe, size_t len,
-- unsigned int flags)
-+long do_splice_to(struct file *in, loff_t *ppos,
-+ struct pipe_inode_info *pipe, size_t len,
-+ unsigned int flags)
- {
- int ret;
-
-@@ -947,6 +948,7 @@ static long do_splice_to(struct file *in, loff_t *ppos,
+@@ -947,6 +948,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return in->f_op->splice_read(in, ppos, pipe, len, flags);
}
@@ -105,35 +72,6 @@ index 666953d..fbc3f77 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
-diff --git a/include/linux/namei.h b/include/linux/namei.h
-index 518098f..42a5279 100644
---- a/include/linux/namei.h
-+++ b/include/linux/namei.h
-@@ -74,6 +74,9 @@ extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry
- extern struct file *nameidata_to_filp(struct nameidata *nd, int flags);
- extern void release_open_intent(struct nameidata *);
-
-+extern struct dentry *lookup_hash(struct nameidata *nd);
-+extern int __lookup_one_len(const char *name, struct qstr *this,
-+ struct dentry *base, int len);
- extern struct dentry *lookup_one_len(const char *, struct dentry *, int);
- extern struct dentry *lookup_one_noperm(const char *, struct dentry *);
-
-diff --git a/include/linux/splice.h b/include/linux/splice.h
-index 5f3faa9..d2f8660 100644
---- a/include/linux/splice.h
-+++ b/include/linux/splice.h
-@@ -83,4 +83,10 @@ extern ssize_t splice_to_pipe(struct pipe_inode_info *,
- extern ssize_t splice_direct_to_actor(struct file *, struct splice_desc *,
- splice_direct_actor *);
-
-+extern long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
-+ loff_t *ppos, size_t len, unsigned int flags);
-+extern long do_splice_to(struct file *in, loff_t *ppos,
-+ struct pipe_inode_info *pipe, size_t len,
-+ unsigned int flags);
-+
- #endif
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 5fda7df..440e476 100644
--- a/security/device_cgroup.c
diff --git a/sys-fs/aufs2/files/aufs2-standalone-31.patch b/sys-fs/aufs2/files/aufs2-standalone-31.patch
new file mode 100644
index 000000000000..946177513b1b
--- /dev/null
+++ b/sys-fs/aufs2/files/aufs2-standalone-31.patch
@@ -0,0 +1,182 @@
+aufs2 standalone patch for linux-2.6.
+
+diff --git a/fs/namei.c b/fs/namei.c
+index dcedad1..728a39b 100644
+--- a/fs/namei.c
++++ b/fs/namei.c
+@@ -337,6 +337,7 @@ int deny_write_access(struct file * file)
+
+ return 0;
+ }
++EXPORT_SYMBOL(deny_write_access);
+
+ /**
+ * path_get - get a reference to a path
+@@ -1228,6 +1229,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
+ return ERR_PTR(err);
+ return __lookup_hash(&nd->last, nd->path.dentry, nd);
+ }
++EXPORT_SYMBOL(lookup_hash);
+
+ int __lookup_one_len(const char *name, struct qstr *this,
+ struct dentry *base, int len)
+@@ -1250,6 +1252,7 @@ int __lookup_one_len(const char *name, struct qstr *this,
+ this->hash = end_name_hash(hash);
+ return 0;
+ }
++EXPORT_SYMBOL(__lookup_one_len);
+
+ /**
+ * lookup_one_len - filesystem helper to lookup single pathname component
+diff --git a/fs/namespace.c b/fs/namespace.c
+index 7230787..8269b66 100644
+--- a/fs/namespace.c
++++ b/fs/namespace.c
+@@ -39,6 +39,7 @@
+
+ /* spinlock for vfsmount related operations, inplace of dcache_lock */
+ __cacheline_aligned_in_smp DEFINE_SPINLOCK(vfsmount_lock);
++EXPORT_SYMBOL(vfsmount_lock);
+
+ static int event;
+ static DEFINE_IDA(mnt_id_ida);
+diff --git a/fs/open.c b/fs/open.c
+index dd98e80..04b9aad 100644
+--- a/fs/open.c
++++ b/fs/open.c
+@@ -221,6 +221,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
+ mutex_unlock(&dentry->d_inode->i_mutex);
+ return err;
+ }
++EXPORT_SYMBOL(do_truncate);
+
+ static long do_sys_truncate(const char __user *pathname, loff_t length)
+ {
+diff --git a/fs/splice.c b/fs/splice.c
+index 0cb8873..0e7b0b9 100644
+--- a/fs/splice.c
++++ b/fs/splice.c
+@@ -1080,6 +1080,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+
+ return splice_write(pipe, out, ppos, len, flags);
+ }
++EXPORT_SYMBOL(do_splice_from);
+
+ /*
+ * Attempt to initiate a splice from a file to a pipe.
+@@ -1105,6 +1106,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
+
+ return splice_read(in, ppos, pipe, len, flags);
+ }
++EXPORT_SYMBOL(do_splice_to);
+
+ /**
+ * splice_direct_to_actor - splices data directly between two non-pipes
+diff --git a/security/device_cgroup.c b/security/device_cgroup.c
+index b8186ba..42208d8 100644
+--- a/security/device_cgroup.c
++++ b/security/device_cgroup.c
+@@ -513,6 +513,7 @@ found:
+
+ return -EPERM;
+ }
++EXPORT_SYMBOL(devcgroup_inode_permission);
+
+ int devcgroup_inode_mknod(int mode, dev_t dev)
+ {
+diff --git a/security/integrity/ima/ima_main.c b/security/integrity/ima/ima_main.c
+index 4732f5e..6fa13dd 100644
+--- a/security/integrity/ima/ima_main.c
++++ b/security/integrity/ima/ima_main.c
+@@ -320,6 +320,7 @@ int ima_file_mmap(struct file *file, unsigned long prot)
+ MAY_EXEC, FILE_MMAP);
+ return 0;
+ }
++EXPORT_SYMBOL(ima_file_mmap);
+
+ /**
+ * ima_bprm_check - based on policy, collect/store measurement.
+diff --git a/security/security.c b/security/security.c
+index dc7674f..b309f88 100644
+--- a/security/security.c
++++ b/security/security.c
+@@ -386,6 +386,7 @@ int security_path_mkdir(struct path *path, struct dentry *dentry, int mode)
+ return 0;
+ return security_ops->path_mkdir(path, dentry, mode);
+ }
++EXPORT_SYMBOL(security_path_mkdir);
+
+ int security_path_rmdir(struct path *path, struct dentry *dentry)
+ {
+@@ -393,6 +394,7 @@ int security_path_rmdir(struct path *path, struct dentry *dentry)
+ return 0;
+ return security_ops->path_rmdir(path, dentry);
+ }
++EXPORT_SYMBOL(security_path_rmdir);
+
+ int security_path_unlink(struct path *path, struct dentry *dentry)
+ {
+@@ -400,6 +402,7 @@ int security_path_unlink(struct path *path, struct dentry *dentry)
+ return 0;
+ return security_ops->path_unlink(path, dentry);
+ }
++EXPORT_SYMBOL(security_path_unlink);
+
+ int security_path_symlink(struct path *path, struct dentry *dentry,
+ const char *old_name)
+@@ -408,6 +411,7 @@ int security_path_symlink(struct path *path, struct dentry *dentry,
+ return 0;
+ return security_ops->path_symlink(path, dentry, old_name);
+ }
++EXPORT_SYMBOL(security_path_symlink);
+
+ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
+ struct dentry *new_dentry)
+@@ -416,6 +420,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
+ return 0;
+ return security_ops->path_link(old_dentry, new_dir, new_dentry);
+ }
++EXPORT_SYMBOL(security_path_link);
+
+ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
+ struct path *new_dir, struct dentry *new_dentry)
+@@ -426,6 +431,7 @@ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
+ return security_ops->path_rename(old_dir, old_dentry, new_dir,
+ new_dentry);
+ }
++EXPORT_SYMBOL(security_path_rename);
+
+ int security_path_truncate(struct path *path, loff_t length,
+ unsigned int time_attrs)
+@@ -434,6 +440,7 @@ int security_path_truncate(struct path *path, loff_t length,
+ return 0;
+ return security_ops->path_truncate(path, length, time_attrs);
+ }
++EXPORT_SYMBOL(security_path_truncate);
+ #endif
+
+ int security_inode_create(struct inode *dir, struct dentry *dentry, int mode)
+@@ -505,6 +512,7 @@ int security_inode_readlink(struct dentry *dentry)
+ return 0;
+ return security_ops->inode_readlink(dentry);
+ }
++EXPORT_SYMBOL(security_inode_readlink);
+
+ int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
+ {
+@@ -519,6 +527,7 @@ int security_inode_permission(struct inode *inode, int mask)
+ return 0;
+ return security_ops->inode_permission(inode, mask);
+ }
++EXPORT_SYMBOL(security_inode_permission);
+
+ int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
+ {
+@@ -619,6 +628,7 @@ int security_file_permission(struct file *file, int mask)
+ {
+ return security_ops->file_permission(file, mask);
+ }
++EXPORT_SYMBOL(security_file_permission);
+
+ int security_file_alloc(struct file *file)
+ {