summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-08-08 19:47:52 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-08-08 19:47:52 +0000
commit5d67333fec88b8bd7638b988ec995ef1ebcd3497 (patch)
treefc9a389f7803a1ff7ee96262e5c83d36cea53e98 /sys-fs
parentversion bump; also fixes bug #402313 (diff)
downloadgentoo-2-5d67333fec88b8bd7638b988ec995ef1ebcd3497.tar.gz
gentoo-2-5d67333fec88b8bd7638b988ec995ef1ebcd3497.tar.bz2
gentoo-2-5d67333fec88b8bd7638b988ec995ef1ebcd3497.zip
fixed configure options for non-native abi, bug 480288
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/eudev/ChangeLog6
-rw-r--r--sys-fs/eudev/eudev-1.2-r1.ebuild38
-rw-r--r--sys-fs/eudev/eudev-9999.ebuild38
3 files changed, 57 insertions, 25 deletions
diff --git a/sys-fs/eudev/ChangeLog b/sys-fs/eudev/ChangeLog
index e6ceb614c97b..54947fb6340a 100644
--- a/sys-fs/eudev/ChangeLog
+++ b/sys-fs/eudev/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/eudev
# Copyright 1999- Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/ChangeLog,v 1.60 2013/08/08 15:19:47 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/ChangeLog,v 1.61 2013/08/08 19:47:52 axs Exp $
+
+ 08 Aug 2013; Ian Stakenvicius <axs@gentoo.org> eudev-1.2-r1.ebuild,
+ eudev-9999.ebuild:
+ fixed configure options for non-native abi, bug 480288
08 Aug 2013; Ian Stakenvicius <axs@gentoo.org>
+files/eudev-selinux-timespan.patch, -files/eudev-fix-selinux.patch,
diff --git a/sys-fs/eudev/eudev-1.2-r1.ebuild b/sys-fs/eudev/eudev-1.2-r1.ebuild
index 415a8c75a9cb..b776187b3376 100644
--- a/sys-fs/eudev/eudev-1.2-r1.ebuild
+++ b/sys-fs/eudev/eudev-1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-1.2-r1.ebuild,v 1.3 2013/08/08 15:19:47 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-1.2-r1.ebuild,v 1.4 2013/08/08 19:47:52 axs Exp $
EAPI="5"
@@ -134,30 +134,44 @@ multilib_src_configure()
--with-html-dir="/usr/share/doc/${PF}/html"
--enable-split-usr
--exec-prefix=/
- $(use_enable doc gtk-doc)
- $(use_enable keymap)
- $(use_enable kmod libkmod)
- $(use_enable modutils modules)
- $(use_enable selinux)
- $(use_enable rule-generator)
)
- # only install libs to /lib and build gudev for native abi
- # also non-native-abi only need dynamic libs, so skip static
+ # Only build libudev for non-native_abi, and only install it to libdir,
+ # that means all options only apply to native_abi
if multilib_is_native_abi; then econf_args+=(
--with-rootlibdir=/$(get_libdir)
+ $(use_enable doc gtk-doc)
$(use_enable gudev)
$(use_enable introspection)
+ $(use_enable keymap)
+ $(use_enable kmod libkmod)
+ $(use_enable modutils modules)
$(use_enable static-libs static)
+ $(use_enable selinux)
+ $(use_enable rule-generator)
)
else econf_args+=(
- --disable-gudev
- --disable-introspection
- --disable-static
+ $(echo --disable-{gtk-doc,gudev,introspection,keymap,libkmod,modules,static,selinux,rule-generator})
)
fi
ECONF_SOURCE="${S}" econf "${econf_args[@]}"
}
+multilib_src_compile()
+{
+ if ! multilib_is_native_abi; then
+ cd src/libudev || die "Could not change directory"
+ fi
+ emake
+}
+
+multilib_src_install()
+{
+ if ! multilib_is_native_abi; then
+ cd src/libudev || die "Could not change directory"
+ fi
+ emake DESTDIR="${D}" install
+}
+
multilib_src_test()
{
# make sandbox get out of the way
diff --git a/sys-fs/eudev/eudev-9999.ebuild b/sys-fs/eudev/eudev-9999.ebuild
index 38dbf6c5b652..c35ca9350661 100644
--- a/sys-fs/eudev/eudev-9999.ebuild
+++ b/sys-fs/eudev/eudev-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-9999.ebuild,v 1.36 2013/08/08 12:54:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-9999.ebuild,v 1.37 2013/08/08 19:47:52 axs Exp $
EAPI="5"
@@ -136,30 +136,44 @@ multilib_src_configure()
--with-html-dir="/usr/share/doc/${PF}/html"
--enable-split-usr
--exec-prefix=/
- $(use_enable doc gtk-doc)
- $(use_enable keymap)
- $(use_enable kmod libkmod)
- $(use_enable modutils modules)
- $(use_enable selinux)
- $(use_enable rule-generator)
)
- # only install libs to /lib and build gudev for native abi
- # also non-native-abi only need dynamic libs, so skip static
+ # Only build libudev for non-native_abi, and only install it to libdir,
+ # that means all options only apply to native_abi
if multilib_is_native_abi; then econf_args+=(
--with-rootlibdir=/$(get_libdir)
+ $(use_enable doc gtk-doc)
$(use_enable gudev)
$(use_enable introspection)
+ $(use_enable keymap)
+ $(use_enable kmod libkmod)
+ $(use_enable modutils modules)
$(use_enable static-libs static)
+ $(use_enable selinux)
+ $(use_enable rule-generator)
)
else econf_args+=(
- --disable-gudev
- --disable-introspection
- --disable-static
+ $(echo --disable-{gtk-doc,gudev,introspection,keymap,libkmod,modules,static,selinux,rule-generator})
)
fi
ECONF_SOURCE="${S}" econf "${econf_args[@]}"
}
+multilib_src_compile()
+{
+ if ! multilib_is_native_abi; then
+ cd src/libudev || die "Could not change directory"
+ fi
+ emake
+}
+
+multilib_src_install()
+{
+ if ! multilib_is_native_abi; then
+ cd src/libudev || die "Could not change directory"
+ fi
+ emake DESTDIR="${D}" install
+}
+
multilib_src_test()
{
# make sandbox get out of the way