summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-06-28 22:52:54 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-06-28 22:52:54 +0000
commit4ae481caa03d14ece8f65ac2919ce9d873e668f9 (patch)
tree203c7785ee5b07b11f4b2120e693ecf0f4dafca5 /sys-fs
parentCleanup insecure and buggy versions. (diff)
downloadgentoo-2-4ae481caa03d14ece8f65ac2919ce9d873e668f9.tar.gz
gentoo-2-4ae481caa03d14ece8f65ac2919ce9d873e668f9.tar.bz2
gentoo-2-4ae481caa03d14ece8f65ac2919ce9d873e668f9.zip
Add missing <sys/wait.h>. Bug #550310.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ncdu/ChangeLog6
-rw-r--r--sys-fs/ncdu/files/ncdu-1.11-missing-header.patch22
-rw-r--r--sys-fs/ncdu/ncdu-1.11.ebuild8
3 files changed, 34 insertions, 2 deletions
diff --git a/sys-fs/ncdu/ChangeLog b/sys-fs/ncdu/ChangeLog
index 8dd783b153d6..3d4652cbe866 100644
--- a/sys-fs/ncdu/ChangeLog
+++ b/sys-fs/ncdu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/ncdu
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ncdu/ChangeLog,v 1.55 2015/05/27 11:13:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ncdu/ChangeLog,v 1.56 2015/06/28 22:52:54 blueness Exp $
+
+ 28 Jun 2015; Anthony G. Basile <blueness@gentoo.org>
+ +files/ncdu-1.11-missing-header.patch, ncdu-1.11.ebuild:
+ Add missing <sys/wait.h>. Bug #550310.
27 May 2015; Agostino Sarubbo <ago@gentoo.org> ncdu-1.11.ebuild:
Stable for x86, wrt bug #549522
diff --git a/sys-fs/ncdu/files/ncdu-1.11-missing-header.patch b/sys-fs/ncdu/files/ncdu-1.11-missing-header.patch
new file mode 100644
index 000000000000..4c79139f7b06
--- /dev/null
+++ b/sys-fs/ncdu/files/ncdu-1.11-missing-header.patch
@@ -0,0 +1,22 @@
+From 29f347c19cb7ad17c4b401e1d984fce8eafaaafa Mon Sep 17 00:00:00 2001
+From: Yorhel <git@yorhel.nl>
+Date: Tue, 7 Apr 2015 10:39:46 +0200
+Subject: shell.c: Include sys/wait.h
+
+Required for the W* macros on OpenBSD. Reported by Brian Callahan.
+
+diff --git a/src/shell.c b/src/shell.c
+index d601b5a..eb275cd 100644
+--- a/src/shell.c
++++ b/src/shell.c
+@@ -32,6 +32,7 @@
+ #include <ncurses.h>
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <sys/wait.h>
+
+ void shell_draw() {
+ char *full_path;
+--
+cgit v0.10.1
+
diff --git a/sys-fs/ncdu/ncdu-1.11.ebuild b/sys-fs/ncdu/ncdu-1.11.ebuild
index 16d5fc2ecd0e..9db6eb9d81a3 100644
--- a/sys-fs/ncdu/ncdu-1.11.ebuild
+++ b/sys-fs/ncdu/ncdu-1.11.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ncdu/ncdu-1.11.ebuild,v 1.5 2015/05/27 11:13:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ncdu/ncdu-1.11.ebuild,v 1.6 2015/06/28 22:52:54 blueness Exp $
EAPI=5
+inherit eutils
+
DESCRIPTION="NCurses Disk Usage"
HOMEPAGE="http://dev.yorhel.nl/ncdu/"
SRC_URI="http://dev.yorhel.nl/download/${P}.tar.gz"
@@ -15,3 +17,7 @@ KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos"
RDEPEND="sys-libs/ncurses[unicode]"
DEPEND="${RDEPEND}
virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-missing-header.patch
+}