summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorBenjamin Smee <strerror@gentoo.org>2005-07-11 09:02:54 +0000
committerBenjamin Smee <strerror@gentoo.org>2005-07-11 09:02:54 +0000
commit1f1253ef276d16893082afdf79e07ae3e4496b70 (patch)
treead169bb564b2eac6f41d54b48b13403bc4869967 /sys-fs
parentPull Hardened-PHP patch for PHP 4.4.0RC2. (diff)
downloadgentoo-2-1f1253ef276d16893082afdf79e07ae3e4496b70.tar.gz
gentoo-2-1f1253ef276d16893082afdf79e07ae3e4496b70.tar.bz2
gentoo-2-1f1253ef276d16893082afdf79e07ae3e4496b70.zip
Version bump.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptsetup-luks/ChangeLog8
-rw-r--r--sys-fs/cryptsetup-luks/Manifest20
-rw-r--r--sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.1.ebuild79
-rw-r--r--sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.11
4 files changed, 93 insertions, 15 deletions
diff --git a/sys-fs/cryptsetup-luks/ChangeLog b/sys-fs/cryptsetup-luks/ChangeLog
index c669d593864a..755327230dce 100644
--- a/sys-fs/cryptsetup-luks/ChangeLog
+++ b/sys-fs/cryptsetup-luks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/cryptsetup-luks
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/ChangeLog,v 1.4 2005/06/16 08:28:53 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/ChangeLog,v 1.5 2005/07/11 09:02:54 strerror Exp $
+
+*cryptsetup-luks-1.0.1 (11 Jul 2005)
+
+ 11 Jul 2005; Benjamin Smee <strerror@gentoo.org>
+ +cryptsetup-luks-1.0.1.ebuild:
+ Version bump.
16 Jun 2005; David Holm <dholm@gentoo.org> cryptsetup-luks-1.0-r1.ebuild:
Added to ~ppc.
diff --git a/sys-fs/cryptsetup-luks/Manifest b/sys-fs/cryptsetup-luks/Manifest
index 6ef23b08162f..6906478f0f94 100644
--- a/sys-fs/cryptsetup-luks/Manifest
+++ b/sys-fs/cryptsetup-luks/Manifest
@@ -1,19 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 24ac40a026fb21d203a0c82f378d3b03 ChangeLog 958
+MD5 66c1f7dfa9c09e11c9e248dd7ec07a5e cryptsetup-luks-1.0.1.ebuild 2126
MD5 66c1f7dfa9c09e11c9e248dd7ec07a5e cryptsetup-luks-1.0-r1.ebuild 2126
+MD5 3370b5714fe9e390b228969c44b59e72 ChangeLog 1097
MD5 3caa86ef66126cc858551801beb4b6d0 cryptsetup-luks-1.0.ebuild 2004
+MD5 6c788beeca78bd11e5cd6e759e52fadc metadata.xml 228
+MD5 c653a0b4ace27569ccc659b7cb43b4a9 files/dm-crypt-start.sh 4306
MD5 6d86b15e07cd0cdf96d8a363b1d778cd files/cryptfs.confd 1548
MD5 f254479b9a12868d43ab10e4658fab51 files/digest-cryptsetup-luks-1.0 72
-MD5 f254479b9a12868d43ab10e4658fab51 files/digest-cryptsetup-luks-1.0-r1 72
-MD5 c653a0b4ace27569ccc659b7cb43b4a9 files/dm-crypt-start.sh 4306
MD5 a3bb6598f67c8922ccb6576ff256ced0 files/dm-crypt-stop.sh 1297
-MD5 6c788beeca78bd11e5cd6e759e52fadc metadata.xml 228
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCvWYwI1lqEGTUzyQRAl4LAJ91ed46Hs0BHnrabehjN0060wfILgCeMILT
-eZ4AvRHHyTou/qrP9hwZo+0=
-=NExs
------END PGP SIGNATURE-----
+MD5 6d83c52472ad8d3b12ec5dbc4e056ed7 files/digest-cryptsetup-luks-1.0.1 74
+MD5 f254479b9a12868d43ab10e4658fab51 files/digest-cryptsetup-luks-1.0-r1 72
diff --git a/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.1.ebuild b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.1.ebuild
new file mode 100644
index 000000000000..3a4a5383eae8
--- /dev/null
+++ b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.1.ebuild,v 1.1 2005/07/11 09:02:54 strerror Exp $
+
+inherit linux-info eutils multilib flag-o-matic
+
+DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
+HOMEPAGE="http://clemens.endorphin.org/LUKS/"
+SRC_URI="http://luks.endorphin.org/source/${PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+
+DEPEND=">=sys-fs/device-mapper-1.00.07-r1
+ >=dev-libs/libgcrypt-1.1.42
+ >=dev-libs/libgpg-error-1.0-r1
+ !sys-fs/cryptsetup"
+
+IUSE="static"
+
+dm-crypt_check() {
+ ebegin "Checking for dm-crypt support"
+ linux_chkconfig_present DM_CRYPT
+ eend $?
+
+ if [[ $? -ne 0 ]] ; then
+ ewarn "cryptsetup requires dm-crypt support!"
+ ewarn "Please enable dm-crypt support in your kernel config, found at:"
+ ewarn "(for 2.6 kernels)"
+ ewarn
+ ewarn " Device Drivers"
+ ewarn " Multi-Device Support"
+ ewarn " Device mapper support"
+ ewarn " [*] Crypt Target Support"
+ ewarn
+ ewarn "and recompile your kernel if you want this package to work with this kernel"
+ epause 5
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ dm-crypt_check;
+}
+
+src_compile() {
+ cd ${S}
+
+ if use static ; then
+ append-ldflags -static
+ econf --sbindir=/bin --enable-static --disable-nls || die
+ else
+ ewarn "If you need cryptsetup for an initrd or initramfs then you"
+ ewarn "should emerge cryptsetup-luks with USE="static""
+ epause 5
+ econf --sbindir=/bin --disable-static --disable-nls || die
+
+ sed -i \
+ -e "s|-lgcrypt|/usr/$(get_libdir)/libgcrypt.a|" \
+ -e "s|-lgpg-error|/usr/$(get_libdir)/libgpg-error.a|" \
+ Makefile src/Makefile
+ sed -i -e "s|-lpopt|/usr/$(get_libdir)/libpopt.a|" src/Makefile
+ fi
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ insinto /lib/rcscripts/addons
+ newconfd ${FILESDIR}/cryptfs.confd cryptfs
+ doins "${FILESDIR}"/dm-crypt-{start,stop}.sh
+}
+
+pkg_postinst() {
+ einfo "Please see the example for configuring a LUKS mountpoint"
+ einfo "in /etc/conf.d/cryptfs"
+}
diff --git a/sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.1 b/sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.1
new file mode 100644
index 000000000000..61c102c0130b
--- /dev/null
+++ b/sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.1
@@ -0,0 +1 @@
+MD5 b2415f67ceed3ad2c7dd2e878cf7787d cryptsetup-luks-1.0.1.tar.bz2 286161