summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-08 14:00:42 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-08 14:00:42 +0000
commit2b86cc8fa5c6ac2c65a11f7740722a3bc43d0450 (patch)
treee6bce4ea52824f9e4783bf617faa69e51bbf2496 /sys-fs/xfsdump/xfsdump-2.2.24.ebuild
parentuse net instead of need net in init.d script (Manifest recommit) (diff)
downloadgentoo-2-2b86cc8fa5c6ac2c65a11f7740722a3bc43d0450.tar.gz
gentoo-2-2b86cc8fa5c6ac2c65a11f7740722a3bc43d0450.tar.bz2
gentoo-2-2b86cc8fa5c6ac2c65a11f7740722a3bc43d0450.zip
ver bump bump buuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuump
Diffstat (limited to 'sys-fs/xfsdump/xfsdump-2.2.24.ebuild')
-rw-r--r--sys-fs/xfsdump/xfsdump-2.2.24.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-fs/xfsdump/xfsdump-2.2.24.ebuild b/sys-fs/xfsdump/xfsdump-2.2.24.ebuild
new file mode 100644
index 000000000000..be444f71811d
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-2.2.24.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.24.ebuild,v 1.1 2004/10/08 14:00:42 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc -sparc ~x86"
+IUSE="debug static"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-fs/xfsprogs
+ sys-apps/dmapi
+ sys-apps/attr"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ -e '/^GCFLAGS/s:-O1::' \
+ -e '/^PKG_[A-Z]*_DIR/s:= := $(DESTDIR):' \
+ include/builddefs.in \
+ || die
+}
+
+src_compile() {
+ if use debug; then
+ export DEBUG=-DDEBUG
+ else
+ export DEBUG=-DNDEBUG
+ fi
+ export OPTIMIZER="${CFLAGS}"
+
+ # Some archs need the PLATFORM var unset
+ unset PLATFORM
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dosym ../../sbin/xfsrestore /usr/bin/xfsrestore
+ dosym ../../sbin/xfsdump /usr/bin/xfsdump
+}