summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-06 02:54:21 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-06 02:54:21 +0000
commite017e56df8569bba16ba0cba9c6764aaa6d33ee7 (patch)
tree0df75afb3916a7111c58d4aec1abf5e179305ac8 /sys-fs/ntfsprogs/files
parentEnchanced 50po-mode-gentoo.el to support the detection of coding system via P... (diff)
downloadgentoo-2-e017e56df8569bba16ba0cba9c6764aaa6d33ee7.tar.gz
gentoo-2-e017e56df8569bba16ba0cba9c6764aaa6d33ee7.tar.bz2
gentoo-2-e017e56df8569bba16ba0cba9c6764aaa6d33ee7.zip
Fix fuse detection when gnome support is disabled #124919 by Konstantin Sobolev. Also add support for USE=crypt.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'sys-fs/ntfsprogs/files')
-rw-r--r--sys-fs/ntfsprogs/files/ntfsprogs-1.13.0-pkg-config.patch119
1 files changed, 119 insertions, 0 deletions
diff --git a/sys-fs/ntfsprogs/files/ntfsprogs-1.13.0-pkg-config.patch b/sys-fs/ntfsprogs/files/ntfsprogs-1.13.0-pkg-config.patch
new file mode 100644
index 000000000000..6a3ca40a3bd4
--- /dev/null
+++ b/sys-fs/ntfsprogs/files/ntfsprogs-1.13.0-pkg-config.patch
@@ -0,0 +1,119 @@
+configure fails when using --disable-gnome-vfs --enable-fuse-module because
+the configure.ac script doesn't explicitly call PKG_PROG_PKG_CONFIG.
+
+http://bugs.gentoo.org/124919
+
+--- configure
++++ configure
+@@ -2184,6 +2184,111 @@
+ fi;
+
+
++
++if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
++ if test -n "$ac_tool_prefix"; then
++ # Extract the first word of "${ac_tool_prefix}pkg-config", so it can be a program name with args.
++set dummy ${ac_tool_prefix}pkg-config; ac_word=$2
++echo "$as_me:$LINENO: checking for $ac_word" >&5
++echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
++if test "${ac_cv_path_PKG_CONFIG+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ case $PKG_CONFIG in
++ [\\/]* | ?:[\\/]*)
++ ac_cv_path_PKG_CONFIG="$PKG_CONFIG" # Let the user override the test with a path.
++ ;;
++ *)
++ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++for as_dir in $PATH
++do
++ IFS=$as_save_IFS
++ test -z "$as_dir" && as_dir=.
++ for ac_exec_ext in '' $ac_executable_extensions; do
++ if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
++ ac_cv_path_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
++ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
++ break 2
++ fi
++done
++done
++
++ ;;
++esac
++fi
++PKG_CONFIG=$ac_cv_path_PKG_CONFIG
++
++if test -n "$PKG_CONFIG"; then
++ echo "$as_me:$LINENO: result: $PKG_CONFIG" >&5
++echo "${ECHO_T}$PKG_CONFIG" >&6
++else
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++fi
++
++fi
++if test -z "$ac_cv_path_PKG_CONFIG"; then
++ ac_pt_PKG_CONFIG=$PKG_CONFIG
++ # Extract the first word of "pkg-config", so it can be a program name with args.
++set dummy pkg-config; ac_word=$2
++echo "$as_me:$LINENO: checking for $ac_word" >&5
++echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
++if test "${ac_cv_path_ac_pt_PKG_CONFIG+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ case $ac_pt_PKG_CONFIG in
++ [\\/]* | ?:[\\/]*)
++ ac_cv_path_ac_pt_PKG_CONFIG="$ac_pt_PKG_CONFIG" # Let the user override the test with a path.
++ ;;
++ *)
++ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++for as_dir in $PATH
++do
++ IFS=$as_save_IFS
++ test -z "$as_dir" && as_dir=.
++ for ac_exec_ext in '' $ac_executable_extensions; do
++ if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
++ ac_cv_path_ac_pt_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
++ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
++ break 2
++ fi
++done
++done
++
++ ;;
++esac
++fi
++ac_pt_PKG_CONFIG=$ac_cv_path_ac_pt_PKG_CONFIG
++
++if test -n "$ac_pt_PKG_CONFIG"; then
++ echo "$as_me:$LINENO: result: $ac_pt_PKG_CONFIG" >&5
++echo "${ECHO_T}$ac_pt_PKG_CONFIG" >&6
++else
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++fi
++
++ PKG_CONFIG=$ac_pt_PKG_CONFIG
++else
++ PKG_CONFIG="$ac_cv_path_PKG_CONFIG"
++fi
++
++fi
++if test -n "$PKG_CONFIG"; then
++ _pkg_min_version=0.9.0
++ echo "$as_me:$LINENO: checking pkg-config is at least version $_pkg_min_version" >&5
++echo $ECHO_N "checking pkg-config is at least version $_pkg_min_version... $ECHO_C" >&6
++ if $PKG_CONFIG --atleast-pkgconfig-version $_pkg_min_version; then
++ echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6
++ else
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++ PKG_CONFIG=""
++ fi
++
++fi
++
+ # This is required to get past a stupid configure bug when making the rpm.
+ # Basically it is broken to specify the host as a command line argument to
+ # configure on its own, i.e. without giving --host=. It is supposed to work