summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-10-09 22:20:15 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-10-09 22:20:15 +0000
commit72a782e6e5a010cd487fbb3cbfee9a6776ed9a7c (patch)
tree9cc9180e8c1b50438bff37afd07f20c431df1e46 /sys-fs/fuse
parentStable for SPARC (bug #195255). (diff)
downloadgentoo-2-72a782e6e5a010cd487fbb3cbfee9a6776ed9a7c.tar.gz
gentoo-2-72a782e6e5a010cd487fbb3cbfee9a6776ed9a7c.tar.bz2
gentoo-2-72a782e6e5a010cd487fbb3cbfee9a6776ed9a7c.zip
Make 2.6.23 support actually work for Sven <skoehler@upb.de> in bug 195300
(Portage version: 2.1.3.12)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/ChangeLog6
-rw-r--r--sys-fs/fuse/fuse-2.6.4-r1.ebuild13
-rw-r--r--sys-fs/fuse/fuse-2.7.0.ebuild13
3 files changed, 19 insertions, 13 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index e0804fb02f24..6ae6681fad24 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.105 2007/10/05 17:22:28 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.106 2007/10/09 22:20:15 genstef Exp $
+
+ 09 Oct 2007; Stefan Schweizer <genstef@gentoo.org> fuse-2.6.4-r1.ebuild,
+ fuse-2.7.0.ebuild:
+ Make 2.6.23 support actually work for Sven <skoehler@upb.de> in bug 195300
05 Oct 2007; Ferris McCormick <fmccor@gentoo.org> fuse-2.7.0.ebuild:
Sparc stable --- Bug #193329 --- thanks to ezod.
diff --git a/sys-fs/fuse/fuse-2.6.4-r1.ebuild b/sys-fs/fuse/fuse-2.6.4-r1.ebuild
index 2598776c3204..8f8ad3491a98 100644
--- a/sys-fs/fuse/fuse-2.6.4-r1.ebuild
+++ b/sys-fs/fuse/fuse-2.6.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.4-r1.ebuild,v 1.10 2007/10/02 18:17:47 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.4-r1.ebuild,v 1.11 2007/10/09 22:20:15 genstef Exp $
inherit linux-mod eutils libtool
@@ -16,14 +16,15 @@ PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
pkg_setup() {
if use kernel_linux ; then
- MODULE_NAMES="fuse(fs:${S}/kernel)"
- CONFIG_CHECK="@FUSE_FS:fuse"
- FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
- We will continue, but we wont build the module this time."
-
if kernel_is ge 2 6 23; then
CONFIG_CHECK="FUSE_FS"
FUSE_FS_ERROR="You need to build the FUSE module from the kernel source, because your kernel is too new"
+ else
+ MODULE_NAMES="fuse(fs:${S}/kernel)"
+ CONFIG_CHECK="@FUSE_FS:fuse"
+ FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+ We will continue, but we wont build the module this time."
+
fi
linux-mod_pkg_setup
kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
diff --git a/sys-fs/fuse/fuse-2.7.0.ebuild b/sys-fs/fuse/fuse-2.7.0.ebuild
index e9b5a02675ed..0c06fac91d76 100644
--- a/sys-fs/fuse/fuse-2.7.0.ebuild
+++ b/sys-fs/fuse/fuse-2.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.0.ebuild,v 1.7 2007/10/05 17:22:28 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.0.ebuild,v 1.8 2007/10/09 22:20:15 genstef Exp $
inherit linux-mod eutils libtool
@@ -16,14 +16,15 @@ PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
pkg_setup() {
if use kernel_linux ; then
- MODULE_NAMES="fuse(fs:${S}/kernel)"
- CONFIG_CHECK="@FUSE_FS:fuse"
- FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
- We will continue, but we wont build the module this time."
-
if kernel_is ge 2 6 23; then
CONFIG_CHECK="FUSE_FS"
FUSE_FS_ERROR="You need to build the FUSE module from the kernel source, because your kernel is too new"
+ else
+ MODULE_NAMES="fuse(fs:${S}/kernel)"
+ CONFIG_CHECK="@FUSE_FS:fuse"
+ FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+ We will continue, but we wont build the module this time."
+
fi
linux-mod_pkg_setup
kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an