summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-12-10 21:40:07 +0000
committerTim Harder <radhermit@gentoo.org>2010-12-10 21:40:07 +0000
commit453304c2e7310f9694d461c0c0a508bb763b4b16 (patch)
tree260b85d52f3516b6ebd1c47a67ccd5fd66c7a71d /sys-fs/fuse
parentMarking perl-CGI-3.50 ppc64 for bug 345845 (diff)
downloadgentoo-2-453304c2e7310f9694d461c0c0a508bb763b4b16.tar.gz
gentoo-2-453304c2e7310f9694d461c0c0a508bb763b4b16.tar.bz2
gentoo-2-453304c2e7310f9694d461c0c0a508bb763b4b16.zip
Remove old versions with security issues (bug #308073).
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/ChangeLog7
-rw-r--r--sys-fs/fuse/files/fuse-fix-lazy-binding.patch11
-rw-r--r--sys-fs/fuse/fuse-2.7.0.ebuild85
-rw-r--r--sys-fs/fuse/fuse-2.7.3.ebuild98
-rw-r--r--sys-fs/fuse/fuse-2.7.4-r1.ebuild101
-rw-r--r--sys-fs/fuse/fuse-2.7.4.ebuild98
-rw-r--r--sys-fs/fuse/fuse-2.8.1.ebuild77
7 files changed, 6 insertions, 471 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 0ea60b455f1c..e75d8430c575 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.141 2010/12/10 19:37:48 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.142 2010/12/10 21:40:06 radhermit Exp $
+
+ 10 Dec 2010; Tim Harder <radhermit@gentoo.org> -fuse-2.7.0.ebuild,
+ -fuse-2.7.3.ebuild, -fuse-2.7.4.ebuild, -fuse-2.7.4-r1.ebuild,
+ -fuse-2.8.1.ebuild, -files/fuse-fix-lazy-binding.patch:
+ Remove old versions with security issues (bug #308073).
10 Dec 2010; Brent Baude <ranger@gentoo.org> fuse-2.8.5.ebuild:
Marking fuse-2.8.5 ppc64 for bug 308073
diff --git a/sys-fs/fuse/files/fuse-fix-lazy-binding.patch b/sys-fs/fuse/files/fuse-fix-lazy-binding.patch
deleted file mode 100644
index 2583d1a15e8e..000000000000
--- a/sys-fs/fuse/files/fuse-fix-lazy-binding.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -pur fuse-1.4.orig/util/Makefile.in fuse-1.4/util/Makefile.in
---- fuse-1.4.orig/util/Makefile.in 2005-01-02 21:09:09.000000000 +0100
-+++ fuse-1.4/util/Makefile.in 2005-01-03 08:49:25.333258992 +0100
-@@ -36,6 +36,7 @@ NORMAL_UNINSTALL = :
- PRE_UNINSTALL = :
- POST_UNINSTALL = :
- ACLOCAL = @ACLOCAL@
-+AM_CFLAGS=-Wl,-z,now
- AMDEP_FALSE = @AMDEP_FALSE@
- AMDEP_TRUE = @AMDEP_TRUE@
- AMTAR = @AMTAR@
diff --git a/sys-fs/fuse/fuse-2.7.0.ebuild b/sys-fs/fuse/fuse-2.7.0.ebuild
deleted file mode 100644
index 61c5f094f849..000000000000
--- a/sys-fs/fuse/fuse-2.7.0.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.0.ebuild,v 1.11 2008/07/04 16:02:09 armin76 Exp $
-
-inherit linux-mod eutils libtool
-
-MY_P=${P/_/-}
-DESCRIPTION="An interface for filesystems implemented in userspace."
-HOMEPAGE="http://fuse.sourceforge.net"
-SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="kernel_linux kernel_FreeBSD"
-S=${WORKDIR}/${MY_P}
-PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
-
-pkg_setup() {
- if use kernel_linux ; then
- if kernel_is ge 2 6 23; then
- CONFIG_CHECK="FUSE_FS"
- FUSE_FS_ERROR="You need to build the FUSE module from the kernel source, because your kernel is too new"
- else
- MODULE_NAMES="fuse(fs:${S}/kernel)"
- CONFIG_CHECK="@FUSE_FS:fuse"
- FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
- We will continue, but we wont build the module this time."
-
- fi
- linux-mod_pkg_setup
- kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
- older version from viewcvs"
-
- BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR} \
- fusemoduledir=\"${ROOT}\"/lib/modules/${KV_FULL/\ }/fs"
- BUILD_TARGETS="all"
- ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/fuse-fix-lazy-binding.patch
- elibtoolize
-}
-
-src_compile() {
- econf \
- --disable-kernel-module \
- --disable-example \
- || die "econf failed for fuse userland"
- emake || die "emake failed"
-
- if use kernel_linux ; then
- cd "${S}"
- sed -i -e 's/.*depmod.*//g' kernel/Makefile.in
- convert_to_m kernel/Makefile.in
- linux-mod_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog Filesystems README \
- README.NFS NEWS doc/how-fuse-works \
- doc/kernel.txt FAQ
- docinto example
- dodoc example/*
-
- if use kernel_linux ; then
- linux-mod_src_install
- newinitd ${FILESDIR}/fuse.init fuse
- else
- insinto /usr/include/fuse
- doins include/fuse_kernel.h
- newinitd ${FILESDIR}/fuse-fbsd.init fuse
- fi
-
- rm -rf "${D}/dev"
-}
-
-pkg_postinst() {
- use kernel_linux && linux-mod_pkg_postinst
-}
diff --git a/sys-fs/fuse/fuse-2.7.3.ebuild b/sys-fs/fuse/fuse-2.7.3.ebuild
deleted file mode 100644
index aee89f2f19ab..000000000000
--- a/sys-fs/fuse/fuse-2.7.3.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.3.ebuild,v 1.2 2008/09/08 05:07:34 jer Exp $
-
-inherit linux-mod eutils libtool
-
-MY_P=${P/_/-}
-DESCRIPTION="An interface for filesystems implemented in userspace."
-HOMEPAGE="http://fuse.sourceforge.net"
-SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="kernel_linux kernel_FreeBSD"
-S=${WORKDIR}/${MY_P}
-PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
-
-pkg_setup() {
- if use kernel_linux ; then
- if kernel_is ge 2 6 25; then
- CONFIG_CHECK="FUSE_FS"
- FUSE_FS_ERROR="You need to build the FUSE module from the kernel source, because your kernel is too new"
- else
- MODULE_NAMES="fuse(fs:${S}/kernel)"
- CONFIG_CHECK="@FUSE_FS:fuse"
- FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
- We will continue, but we wont build the module this time."
-
- fi
- linux-mod_pkg_setup
- kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
- older version from viewcvs"
-
- BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR} \
- fusemoduledir=\"${ROOT}\"/lib/modules/${KV_FULL/\ }/fs"
- BUILD_TARGETS="all"
- ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/fuse-fix-lazy-binding.patch
- elibtoolize
-}
-
-src_compile() {
- econf \
- --disable-kernel-module \
- --disable-example \
- || die "econf failed for fuse userland"
- emake || die "emake failed"
-
- if use kernel_linux ; then
- cd "${S}"
- sed -i -e 's/.*depmod.*//g' kernel/Makefile.in
- convert_to_m kernel/Makefile.in
- linux-mod_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog Filesystems README \
- README.NFS NEWS doc/how-fuse-works \
- doc/kernel.txt FAQ
- docinto example
- dodoc example/*
-
- if use kernel_linux ; then
- linux-mod_src_install
- newinitd ${FILESDIR}/fuse.init fuse
- else
- insinto /usr/include/fuse
- doins include/fuse_kernel.h
- newinitd ${FILESDIR}/fuse-fbsd.init fuse
- fi
-
- rm -rf "${D}/dev"
-
- dodir /etc
- cat > ${D}/etc/fuse.conf <<EOF
-# Set the maximum number of FUSE mounts allowed to non-root users.
-# The default is 1000.
-#
-#mount_max = 1000
-
-# Allow non-root users to specify the 'allow_other' or 'allow_root'
-# mount options.
-#
-#user_allow_other
-EOF
-}
-
-pkg_postinst() {
- use kernel_linux && linux-mod_pkg_postinst
-}
diff --git a/sys-fs/fuse/fuse-2.7.4-r1.ebuild b/sys-fs/fuse/fuse-2.7.4-r1.ebuild
deleted file mode 100644
index 65c0c63f64ef..000000000000
--- a/sys-fs/fuse/fuse-2.7.4-r1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.4-r1.ebuild,v 1.2 2009/10/28 04:16:34 robbat2 Exp $
-
-inherit linux-mod eutils libtool
-
-MY_P=${P/_/-}
-
-DESCRIPTION="An interface for filesystems implemented in userspace."
-HOMEPAGE="http://fuse.sourceforge.net"
-SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="kernel_linux kernel_FreeBSD modules"
-
-PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- if use modules && use kernel_linux ; then
- if kernel_is ge 2 6 25; then
- CONFIG_CHECK="FUSE_FS"
- FUSE_FS_ERROR="You need to build the FUSE module from the kernel source, because your kernel is too new"
- else
- MODULE_NAMES="fuse(fs:${S}/kernel)"
- CONFIG_CHECK="@FUSE_FS:fuse"
- FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
- We will continue, but we wont build the module this time."
-
- fi
- linux-mod_pkg_setup
- kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
- older version from viewcvs"
-
- BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR} \
- fusemoduledir=\"${ROOT}\"/lib/modules/${KV_FULL/\ }/fs"
- BUILD_TARGETS="all"
- ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- elibtoolize
-}
-
-src_compile() {
- econf \
- --disable-kernel-module \
- --disable-example \
- || die "econf failed for fuse userland"
- emake || die "emake failed"
-
- if use modules && use kernel_linux ; then
- cd "${S}"
- sed -i -e 's/.*depmod.*//g' kernel/Makefile.in
- convert_to_m kernel/Makefile.in
- linux-mod_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog Filesystems README \
- README.NFS NEWS doc/how-fuse-works \
- doc/kernel.txt FAQ
- docinto example
- dodoc example/*
-
- if use modules && use kernel_linux ; then
- linux-mod_src_install
- newinitd "${FILESDIR}"/fuse.init fuse
- else
- insinto /usr/include/fuse
- doins include/fuse_kernel.h
- newinitd "${FILESDIR}"/fuse-fbsd.init fuse
- fi
-
- rm -rf "${D}/dev"
-
- dodir /etc
- cat > ${D}/etc/fuse.conf <<EOF
-# Set the maximum number of FUSE mounts allowed to non-root users.
-# The default is 1000.
-#
-#mount_max = 1000
-
-# Allow non-root users to specify the 'allow_other' or 'allow_root'
-# mount options.
-#
-#user_allow_other
-EOF
-}
-
-pkg_postinst() {
- use modules && use kernel_linux && linux-mod_pkg_postinst
-}
diff --git a/sys-fs/fuse/fuse-2.7.4.ebuild b/sys-fs/fuse/fuse-2.7.4.ebuild
deleted file mode 100644
index e0b494a97bea..000000000000
--- a/sys-fs/fuse/fuse-2.7.4.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.4.ebuild,v 1.7 2009/05/18 14:08:43 jer Exp $
-
-inherit linux-mod eutils libtool
-
-MY_P=${P/_/-}
-DESCRIPTION="An interface for filesystems implemented in userspace."
-HOMEPAGE="http://fuse.sourceforge.net"
-SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="kernel_linux kernel_FreeBSD"
-S=${WORKDIR}/${MY_P}
-PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
-
-pkg_setup() {
- if use kernel_linux ; then
- if kernel_is ge 2 6 25; then
- CONFIG_CHECK="FUSE_FS"
- FUSE_FS_ERROR="You need to build the FUSE module from the kernel source, because your kernel is too new"
- else
- MODULE_NAMES="fuse(fs:${S}/kernel)"
- CONFIG_CHECK="@FUSE_FS:fuse"
- FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
- We will continue, but we wont build the module this time."
-
- fi
- linux-mod_pkg_setup
- kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
- older version from viewcvs"
-
- BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR} \
- fusemoduledir=\"${ROOT}\"/lib/modules/${KV_FULL/\ }/fs"
- BUILD_TARGETS="all"
- ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/fuse-fix-lazy-binding.patch
- elibtoolize
-}
-
-src_compile() {
- econf \
- --disable-kernel-module \
- --disable-example \
- || die "econf failed for fuse userland"
- emake || die "emake failed"
-
- if use kernel_linux ; then
- cd "${S}"
- sed -i -e 's/.*depmod.*//g' kernel/Makefile.in
- convert_to_m kernel/Makefile.in
- linux-mod_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog Filesystems README \
- README.NFS NEWS doc/how-fuse-works \
- doc/kernel.txt FAQ
- docinto example
- dodoc example/*
-
- if use kernel_linux ; then
- linux-mod_src_install
- newinitd ${FILESDIR}/fuse.init fuse
- else
- insinto /usr/include/fuse
- doins include/fuse_kernel.h
- newinitd ${FILESDIR}/fuse-fbsd.init fuse
- fi
-
- rm -rf "${D}/dev"
-
- dodir /etc
- cat > ${D}/etc/fuse.conf <<EOF
-# Set the maximum number of FUSE mounts allowed to non-root users.
-# The default is 1000.
-#
-#mount_max = 1000
-
-# Allow non-root users to specify the 'allow_other' or 'allow_root'
-# mount options.
-#
-#user_allow_other
-EOF
-}
-
-pkg_postinst() {
- use kernel_linux && linux-mod_pkg_postinst
-}
diff --git a/sys-fs/fuse/fuse-2.8.1.ebuild b/sys-fs/fuse/fuse-2.8.1.ebuild
deleted file mode 100644
index 0c57daaec5c4..000000000000
--- a/sys-fs/fuse/fuse-2.8.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.8.1.ebuild,v 1.9 2010/11/27 22:22:15 xmw Exp $
-
-EAPI=2
-inherit eutils libtool linux-info
-
-MY_P=${P/_/-}
-DESCRIPTION="An interface for filesystems implemented in userspace."
-HOMEPAGE="http://fuse.sourceforge.net"
-SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="kernel_linux kernel_FreeBSD"
-S=${WORKDIR}/${MY_P}
-PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
-
-pkg_setup() {
- if use kernel_linux ; then
- if kernel_is lt 2 6 9; then
- die "Your kernel is too old."
- fi
- CONFIG_CHECK="~FUSE_FS"
- FUSE_FS_WARNING="You need to have FUSE module built to use user-mode utils"
- linux-info_pkg_setup
- fi
-}
-
-src_prepare() {
- elibtoolize
-}
-
-src_configure() {
- econf \
- --disable-example \
- || die "econf failed for fuse userland"
-}
-
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog Filesystems README \
- README.NFS NEWS doc/how-fuse-works \
- doc/kernel.txt FAQ
- docinto example
- dodoc example/*
-
- if use kernel_linux ; then
- newinitd "${FILESDIR}"/fuse.init fuse
- elif use kernel_FreeBSD ; then
- insinto /usr/include/fuse
- doins include/fuse_kernel.h
- newinitd "${FILESDIR}"/fuse-fbsd.init fuse
- else
- die "We don't know what init code install for your kernel, please file a bug."
- fi
-
- rm -rf "${D}/dev"
-
- dodir /etc
- cat >"${D}"/etc/fuse.conf <<-EOF
- # Set the maximum number of FUSE mounts allowed to non-root users.
- # The default is 1000.
- #
- #mount_max = 1000
-
- # Allow non-root users to specify the 'allow_other' or 'allow_root'
- # mount options.
- #
- #user_allow_other
- EOF
-}