summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-08 06:26:44 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-08 06:26:44 +0000
commit8a3956c50308227652a3443b1b28c33ee596a9e2 (patch)
treeb6191c9f58b67d7af0d9784092b951638bd1210d /sys-fs/ext2resize
parentnot needed anymore (diff)
downloadgentoo-2-8a3956c50308227652a3443b1b28c33ee596a9e2.tar.gz
gentoo-2-8a3956c50308227652a3443b1b28c33ee596a9e2.tar.bz2
gentoo-2-8a3956c50308227652a3443b1b28c33ee596a9e2.zip
Cleanup autotools to fix building with 2.4 headers #114858.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-fs/ext2resize')
-rw-r--r--sys-fs/ext2resize/ChangeLog6
-rw-r--r--sys-fs/ext2resize/ext2resize-1.1.19.ebuild7
-rw-r--r--sys-fs/ext2resize/files/ext2resize-1.1.19-build.patch20
3 files changed, 29 insertions, 4 deletions
diff --git a/sys-fs/ext2resize/ChangeLog b/sys-fs/ext2resize/ChangeLog
index 9064561a261f..9ee2c76586ca 100644
--- a/sys-fs/ext2resize/ChangeLog
+++ b/sys-fs/ext2resize/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/ext2resize
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ChangeLog,v 1.14 2006/01/09 18:14:28 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ChangeLog,v 1.15 2006/02/08 06:26:44 vapier Exp $
+
+ 08 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/ext2resize-1.1.19-build.patch, ext2resize-1.1.19.ebuild:
+ Cleanup autotools to fix building with 2.4 headers #114858.
09 Jan 2006; Gustavo Zacarias <gustavoz@gentoo.org>
ext2resize-1.1.17-r2.ebuild, ext2resize-1.1.19.ebuild:
diff --git a/sys-fs/ext2resize/ext2resize-1.1.19.ebuild b/sys-fs/ext2resize/ext2resize-1.1.19.ebuild
index 2cf928804fa9..711281e41090 100644
--- a/sys-fs/ext2resize/ext2resize-1.1.19.ebuild
+++ b/sys-fs/ext2resize/ext2resize-1.1.19.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ext2resize-1.1.19.ebuild,v 1.8 2006/01/09 18:14:28 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ext2resize-1.1.19.ebuild,v 1.9 2006/02/08 06:26:44 vapier Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils autotools
DESCRIPTION="EXT2 and EXT3 filesystem resizing utilities"
HOMEPAGE="http://ext2resize.sourceforge.net/"
@@ -23,7 +23,8 @@ src_unpack() {
make -k distclean >& /dev/null
sed -i '/^CFLAGS/d' src/Makefile.in
- epatch ${FILESDIR}/${P}-linux26.patch
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf || die
}
src_compile() {
diff --git a/sys-fs/ext2resize/files/ext2resize-1.1.19-build.patch b/sys-fs/ext2resize/files/ext2resize-1.1.19-build.patch
new file mode 100644
index 000000000000..c613f616f047
--- /dev/null
+++ b/sys-fs/ext2resize/files/ext2resize-1.1.19-build.patch
@@ -0,0 +1,20 @@
+Fixup autotool stuff
+
+--- configure.in
++++ configure.in
+@@ -25,6 +25,7 @@
+ AC_CHECK_TYPE(__u16, u_int16_t)
+ AC_CHECK_TYPE(__s32, int32_t)
+ AC_CHECK_TYPE(__u32, u_int32_t)
++AC_CHECK_TYPE(__u64, u_int64_t)
+ AC_CHECK_TYPE(loff_t, unsigned)
+
+ dnl Checks for library functions.
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -27,4 +27,4 @@
+
+ LIBS = @LIBS@
+
+-CFLAGS += -Wall -g
++AM_CFLAGS = -Wall