summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2008-03-17 19:15:53 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2008-03-17 19:15:53 +0000
commitd97f5238eb1a805bdbd3fad783005e2fd02ce22a (patch)
tree824560a038b268d1f2eee6d002dbae3ea29f3588 /sys-fs/clvm/clvm-2.02.33.ebuild
parente2fsprogs-1.40.4 also needs tls disabled on uClibc. (diff)
downloadgentoo-2-d97f5238eb1a805bdbd3fad783005e2fd02ce22a.tar.gz
gentoo-2-d97f5238eb1a805bdbd3fad783005e2fd02ce22a.tar.bz2
gentoo-2-d97f5238eb1a805bdbd3fad783005e2fd02ce22a.zip
Version bump, clvm-2.02.33 will be the starting point to merge clvm in lvm, everything before 2.02.33 will be removed soon.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-fs/clvm/clvm-2.02.33.ebuild')
-rw-r--r--sys-fs/clvm/clvm-2.02.33.ebuild117
1 files changed, 117 insertions, 0 deletions
diff --git a/sys-fs/clvm/clvm-2.02.33.ebuild b/sys-fs/clvm/clvm-2.02.33.ebuild
new file mode 100644
index 000000000000..cc323f67ff5b
--- /dev/null
+++ b/sys-fs/clvm/clvm-2.02.33.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/clvm/clvm-2.02.33.ebuild,v 1.1 2008/03/17 19:15:52 xmerlin Exp $
+
+inherit eutils multilib
+
+MY_P="${PN/clvm/LVM2}.${PV}"
+
+DESCRIPTION="User-land utilities for LVM2 (device-mapper) software."
+HOMEPAGE="http://sources.redhat.com/lvm2/"
+SRC_URI="ftp://sources.redhat.com/pub/lvm2/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="readline static selinux"
+
+DEPEND=">=sys-fs/device-mapper-1.02.24
+ =sys-cluster/dlm-2*
+ =sys-cluster/cman-2*
+ "
+
+RDEPEND="${DEPEND}
+ !sys-fs/lvm-user
+ !sys-fs/lvm2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/lvm.conf-2.02.33.patch || die
+}
+
+src_compile() {
+ # Static compile of lvm2 so that the install described in the handbook works
+ # http://www.gentoo.org/doc/en/lvm2.xml
+ # fixes http://bugs.gentoo.org/show_bug.cgi?id=84463
+ local myconf
+ local buildmode
+
+ # fsadm is broken, don't include it (2.02.28)
+ myconf="${myconf} --enable-dmeventd --enable-cmdlib"
+
+ # Most of this package does weird stuff.
+ # The build options are tristate, and --without is NOT supported
+ # options: 'none', 'internal', 'shared'
+ if use static ; then
+ einfo "Building static LVM, for usage inside genkernel"
+ myconf="${myconf} --enable-static_link"
+ buildmode="internal"
+ else
+ ewarn "Building shared LVM, it will not work inside genkernel!"
+ buildmode="shared"
+ fi
+
+ # dmeventd requires mirrors to be internal, and snapshot available
+ # so we cannot disable them
+ myconf="${myconf} --with-mirrors=internal"
+ myconf="${myconf} --with-snapshots=internal"
+
+ myconf="${myconf} --with-lvm1=none"
+
+ # disable O_DIRECT support on hppa, breaks pv detection (#99532)
+ use hppa && myconf="${myconf} --disable-o_direct"
+
+ myconf="${myconf} --with-cluster=${buildmode}"
+ # 4-state!
+ myconf="${myconf} --with-clvmd=cman"
+ myconf="${myconf} --with-pool=${buildmode}"
+
+ myconf="${myconf} --sbindir=/sbin --with-staticdir=/sbin"
+ econf $(use_enable readline) \
+ $(use_enable selinux) \
+ --libdir=/usr/$(get_libdir) \
+ ${myconf} \
+ CLDFLAGS="${LDFLAGS}" || die
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ # TODO: At some point in the future, we need to stop installing the static
+ # as the /sbin/lvm name, and have both variants seperate.
+ if use static; then
+ cp -f "${D}"/sbin/lvm.static "${D}"/sbin/lvm \
+ || die "Failed to copy lvm.static"
+ fi
+
+ dodir /$(get_libdir)
+ # Put these in root so we can reach before /usr is up
+ for i in libdevmapper-event-lvm2mirror liblvm2{format1,snapshot} ; do
+ b="${D}"/usr/$(get_libdir)/${i}
+ if [ -f "${b}".so ]; then
+ mv -f "${b}".so* "${D}"/$(get_libdir) || die
+ fi
+ done
+
+ dodoc README VERSION WHATS_NEW doc/*.{conf,c,txt}
+ insinto /lib/rcscripts/addons
+ newins "${FILESDIR}"/lvm2-start.sh-2.02.33-xm lvm-start.sh || die
+ newins "${FILESDIR}"/lvm2-stop.sh-2.02.33-xm lvm-stop.sh || die
+ newinitd "${FILESDIR}"/lvm.rc-2.02.28-r2 lvm || die
+ newconfd "${FILESDIR}"/lvm.confd-2.02.28-r2 lvm || die
+ newinitd "${FILESDIR}"/clvmd.rc-2.02.33-xm clvmd || die
+
+ elog ""
+ elog "Rebuild your genkernel initramfs if you are using lvm"
+ use nolvmstatic && \
+ elog "USE=nolvmstatic has changed to USE=static via package.use"
+}
+
+pkg_postinst() {
+ elog "lvm volumes are no longer automatically created for"
+ elog "baselayout-2 users. If you are using baselayout-2, be sure to"
+ elog "run: # rc-update add lvm boot"
+}