summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-09 14:50:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-09 14:50:35 +0000
commitf2cb07ac4cd60d6790976be6e947a8c6c019abb9 (patch)
tree5c2f3e130802761df3901b0e3b95ba7113e5cbb6 /sys-freebsd/freebsd-sources/freebsd-sources-9.1-r2.ebuild
parentdepend on the same version of mk-defs, bug #476646 by Yuta SATOH (diff)
downloadgentoo-2-f2cb07ac4cd60d6790976be6e947a8c6c019abb9.tar.gz
gentoo-2-f2cb07ac4cd60d6790976be6e947a8c6c019abb9.tar.bz2
gentoo-2-f2cb07ac4cd60d6790976be6e947a8c6c019abb9.zip
remove old
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd/freebsd-sources/freebsd-sources-9.1-r2.ebuild')
-rw-r--r--sys-freebsd/freebsd-sources/freebsd-sources-9.1-r2.ebuild83
1 files changed, 0 insertions, 83 deletions
diff --git a/sys-freebsd/freebsd-sources/freebsd-sources-9.1-r2.ebuild b/sys-freebsd/freebsd-sources/freebsd-sources-9.1-r2.ebuild
deleted file mode 100644
index 117856744e46..000000000000
--- a/sys-freebsd/freebsd-sources/freebsd-sources-9.1-r2.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-9.1-r2.ebuild,v 1.1 2013/06/19 02:09:24 aballier Exp $
-
-inherit bsdmk freebsd flag-o-matic
-
-DESCRIPTION="FreeBSD kernel sources"
-SLOT="${RV}"
-KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-
-IUSE="symlink"
-
-SRC_URI="mirror://gentoo/${SYS}.tar.bz2"
-
-RDEPEND=">=sys-freebsd/freebsd-mk-defs-8.0"
-DEPEND=""
-
-RESTRICT="strip binchecks"
-
-S="${WORKDIR}/sys"
-
-PATCHES=( "${FILESDIR}/${PN}-9.0-disable-optimization.patch"
- "${FILESDIR}/${PN}-9.1-gentoo.patch"
- "${FILESDIR}/${PN}-6.0-flex-2.5.31.patch"
- "${FILESDIR}/${PN}-6.1-ntfs.patch"
- "${FILESDIR}/${PN}-7.1-types.h-fix.patch"
- "${FILESDIR}/${PN}-8.0-subnet-route-pr40133.patch"
- "${FILESDIR}/${PN}-7.1-includes.patch"
- "${FILESDIR}/${PN}-9.0-sysctluint.patch"
- "${FILESDIR}/${PN}-7.0-tmpfs_whiteout_stub.patch"
- "${FILESDIR}/${PN}-9.1-cve-2013-3266.patch"
- "${FILESDIR}/${PN}-9.1-mmap.patch" )
-
-src_unpack() {
- freebsd_src_unpack
-
- # This replaces the gentoover patch, it doesn't need reapply every time.
- sed -i -e 's:^REVISION=.*:REVISION="'${PVR}'":' \
- -e 's:^BRANCH=.*:BRANCH="Gentoo":' \
- -e 's:^VERSION=.*:VERSION="${TYPE} ${BRANCH} ${REVISION}":' \
- "${S}/conf/newvers.sh"
-
- # __FreeBSD_cc_version comes from FreeBSD's gcc.
- # on 9.0-RELEASE it's 900001.
- sed -e "s:-D_KERNEL:-D_KERNEL -D__FreeBSD_cc_version=900001:g" \
- -i "${S}/conf/kern.pre.mk" \
- -i "${S}/conf/kmod.mk" || die "Couldn't set __FreeBSD_cc_version"
-
- # Remove -Werror
- sed -e "s:-Werror:-Wno-error:g" \
- -i "${S}/conf/kern.pre.mk" \
- -i "${S}/conf/kmod.mk" || die
-}
-
-src_compile() {
- einfo "Nothing to compile.."
-}
-
-src_install() {
- insinto "/usr/src/sys-${RV}"
- doins -r "${S}/"*
-}
-
-pkg_postinst() {
- if [[ ! -L "${ROOT}/usr/src/sys" ]]; then
- einfo "/usr/src/sys symlink doesn't exist; creating symlink to sys-${RV}..."
- ln -sf "sys-${RV}" "${ROOT}/usr/src/sys" || \
- eerror "Couldn't create ${ROOT}/usr/src/sys symlink."
- elif use symlink; then
- einfo "Updating /usr/src/sys symlink to sys-${MY_PVR}..."
- rm "${ROOT}/usr/src/sys" || \
- eerror "Couldn't remove previous symlinks, please fix manually."
- ln -sf "sys-${RV}" "${ROOT}/usr/src/sys" || \
- eerror "Couldn't create ${ROOT}/usr/src/sys symlink."
- fi
-
- if use sparc-fbsd ; then
- ewarn "WARNING: kldload currently causes kernel panics"
- ewarn "on sparc64. This is probably a gcc-4.1 issue, but"
- ewarn "we need gcc-4.1 to compile the kernel correctly :/"
- ewarn "Please compile all modules you need into the kernel"
- fi
-}