summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-03-12 14:50:52 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-03-12 14:50:52 +0000
commit360d7653daf0457ce9e17f80c61478fba5b45b3a (patch)
treeab372caeb76f4861d2e899ca8aaa1f929cfed6e9 /sys-firmware
parentrewrite to be -p1 patch (diff)
downloadgentoo-2-360d7653daf0457ce9e17f80c61478fba5b45b3a.tar.gz
gentoo-2-360d7653daf0457ce9e17f80c61478fba5b45b3a.tar.bz2
gentoo-2-360d7653daf0457ce9e17f80c61478fba5b45b3a.zip
Add a clear warning for people not using USE=binary.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/seabios/ChangeLog6
-rw-r--r--sys-firmware/seabios/seabios-1.6.3.ebuild17
-rw-r--r--sys-firmware/seabios/seabios-1.7.0.ebuild17
-rw-r--r--sys-firmware/seabios/seabios-1.7.1.ebuild15
-rw-r--r--sys-firmware/seabios/seabios-1.7.2.ebuild19
5 files changed, 66 insertions, 8 deletions
diff --git a/sys-firmware/seabios/ChangeLog b/sys-firmware/seabios/ChangeLog
index f2bf07b43cf1..78dd7b94dd52 100644
--- a/sys-firmware/seabios/ChangeLog
+++ b/sys-firmware/seabios/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-firmware/seabios
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/ChangeLog,v 1.10 2013/01/24 22:10:19 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/ChangeLog,v 1.11 2013/03/12 14:50:52 cardoe Exp $
+
+ 12 Mar 2013; Doug Goldstein <cardoe@gentoo.org> seabios-1.6.3.ebuild,
+ seabios-1.7.0.ebuild, seabios-1.7.1.ebuild, seabios-1.7.2.ebuild:
+ Add a clear warning for people not using USE=binary.
24 Jan 2013; Agostino Sarubbo <ago@gentoo.org> seabios-1.7.1.ebuild:
Stable for x86, wrt bug #453282
diff --git a/sys-firmware/seabios/seabios-1.6.3.ebuild b/sys-firmware/seabios/seabios-1.6.3.ebuild
index 56a57d91d172..8e84afad7ee3 100644
--- a/sys-firmware/seabios/seabios-1.6.3.ebuild
+++ b/sys-firmware/seabios/seabios-1.6.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/seabios-1.6.3.ebuild,v 1.2 2012/10/09 20:25:02 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/seabios-1.6.3.ebuild,v 1.3 2013/03/12 14:50:52 cardoe Exp $
EAPI=4
@@ -33,6 +33,19 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
+pkg_pretend() {
+ if ! use binary; then
+ ewarn "You have decided to compile your own SeaBIOS. This is not"
+ ewarn "supported by upstream unless you use their recommended"
+ ewarn "toolchain (which you are not)."
+ elog
+ ewarn "If you are intending to use this build with QEMU, realize"
+ ewarn "you will not receive any support if you have compiled your"
+ ewarn "own SeaBIOS. Virtual machines subtly fail based on changes"
+ ewarn "in SeaBIOS."
+ fi
+}
+
pkg_setup() {
python_set_active_version 2
}
diff --git a/sys-firmware/seabios/seabios-1.7.0.ebuild b/sys-firmware/seabios/seabios-1.7.0.ebuild
index 6dd5df3c9711..84f0da1c27ad 100644
--- a/sys-firmware/seabios/seabios-1.7.0.ebuild
+++ b/sys-firmware/seabios/seabios-1.7.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/seabios-1.7.0.ebuild,v 1.5 2012/10/17 03:39:28 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/seabios-1.7.0.ebuild,v 1.6 2013/03/12 14:50:52 cardoe Exp $
EAPI=4
@@ -32,6 +32,19 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
+pkg_pretend() {
+ if ! use binary; then
+ ewarn "You have decided to compile your own SeaBIOS. This is not"
+ ewarn "supported by upstream unless you use their recommended"
+ ewarn "toolchain (which you are not)."
+ elog
+ ewarn "If you are intending to use this build with QEMU, realize"
+ ewarn "you will not receive any support if you have compiled your"
+ ewarn "own SeaBIOS. Virtual machines subtly fail based on changes"
+ ewarn "in SeaBIOS."
+ fi
+}
+
pkg_setup() {
python_set_active_version 2
}
diff --git a/sys-firmware/seabios/seabios-1.7.1.ebuild b/sys-firmware/seabios/seabios-1.7.1.ebuild
index 1042244a033e..4dca7e8cdbf6 100644
--- a/sys-firmware/seabios/seabios-1.7.1.ebuild
+++ b/sys-firmware/seabios/seabios-1.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/seabios-1.7.1.ebuild,v 1.4 2013/01/24 22:10:19 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/seabios-1.7.1.ebuild,v 1.5 2013/03/12 14:50:52 cardoe Exp $
EAPI=4
@@ -35,6 +35,19 @@ REQUIRED_USE="ppc? ( binary )
DEPEND="!binary? ( sys-power/iasl )"
RDEPEND=""
+pkg_pretend() {
+ if ! use binary; then
+ ewarn "You have decided to compile your own SeaBIOS. This is not"
+ ewarn "supported by upstream unless you use their recommended"
+ ewarn "toolchain (which you are not)."
+ elog
+ ewarn "If you are intending to use this build with QEMU, realize"
+ ewarn "you will not receive any support if you have compiled your"
+ ewarn "own SeaBIOS. Virtual machines subtly fail based on changes"
+ ewarn "in SeaBIOS."
+ fi
+}
+
pkg_setup() {
python_set_active_version 2
}
diff --git a/sys-firmware/seabios/seabios-1.7.2.ebuild b/sys-firmware/seabios/seabios-1.7.2.ebuild
index 1982a517c14e..b75c0746eb55 100644
--- a/sys-firmware/seabios/seabios-1.7.2.ebuild
+++ b/sys-firmware/seabios/seabios-1.7.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/seabios-1.7.2.ebuild,v 1.1 2013/01/23 21:21:40 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/seabios-1.7.2.ebuild,v 1.2 2013/03/12 14:50:52 cardoe Exp $
EAPI=5
PYTHON_DEPEND="2"
-inherit python
+inherit python user
#BACKPORTS=1
@@ -35,6 +35,19 @@ REQUIRED_USE="ppc? ( binary )
DEPEND="!binary? ( sys-power/iasl )"
RDEPEND=""
+pkg_pretend() {
+ if ! use binary; then
+ ewarn "You have decided to compile your own SeaBIOS. This is not"
+ ewarn "supported by upstream unless you use their recommended"
+ ewarn "toolchain (which you are not)."
+ elog
+ ewarn "If you are intending to use this build with QEMU, realize"
+ ewarn "you will not receive any support if you have compiled your"
+ ewarn "own SeaBIOS. Virtual machines subtly fail based on changes"
+ ewarn "in SeaBIOS."
+ fi
+}
+
pkg_setup() {
python_set_active_version 2
}
@@ -47,6 +60,8 @@ src_prepare() {
sed -e "s/VERSION=.*/VERSION=${PV}_pre${EGIT_COMMIT}/" \
-i "${S}/Makefile"
fi
+
+ epatch_user
}
src_configure() {