summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-04 00:08:25 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-04 00:08:25 +0000
commitffda9c91625af1fbc4dfc58425e7ae4e486a7d4d (patch)
tree84b1bb367eb8ed00c91aa6be7a903a3e3524bfbe /sys-devel
parentbash style updates (diff)
downloadgentoo-2-ffda9c91625af1fbc4dfc58425e7ae4e486a7d4d.tar.gz
gentoo-2-ffda9c91625af1fbc4dfc58425e7ae4e486a7d4d.tar.bz2
gentoo-2-ffda9c91625af1fbc4dfc58425e7ae4e486a7d4d.zip
install the info pages #79411
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/automake/automake-1.7.9-r1.ebuild6
-rw-r--r--sys-devel/automake/automake-1.8.5-r3.ebuild10
-rw-r--r--sys-devel/automake/automake-1.9.4.ebuild10
3 files changed, 9 insertions, 17 deletions
diff --git a/sys-devel/automake/automake-1.7.9-r1.ebuild b/sys-devel/automake/automake-1.7.9-r1.ebuild
index 4843bce763a6..074ea946c7a2 100644
--- a/sys-devel/automake/automake-1.7.9-r1.ebuild
+++ b/sys-devel/automake/automake-1.7.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.7.9-r1.ebuild,v 1.5 2005/01/31 15:21:34 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.7.9-r1.ebuild,v 1.6 2005/02/04 00:08:25 vapier Exp $
inherit eutils gnuconfig
@@ -25,7 +25,7 @@ src_unpack() {
-e "/^@setfilename/s|automake|automake${SLOT}|" \
-e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
-e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
- automake.texi || die "sed failed"
+ automake.texi || die "sed texi failed"
epatch ${FILESDIR}/${P}-infopage-namechange.patch
gnuconfig_update
export WANT_AUTOCONF=2.5
@@ -36,7 +36,7 @@ src_install() {
rm -f "${D}"/usr/bin/{aclocal,automake}
dodoc NEWS README THANKS TODO AUTHORS ChangeLog
- mv "${D}"/usr/share/info/automake{,${SLOT}}.info
+ doinfo automake${SLOT}.info
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
diff --git a/sys-devel/automake/automake-1.8.5-r3.ebuild b/sys-devel/automake/automake-1.8.5-r3.ebuild
index c81301fc2b6f..55cc1fad820e 100644
--- a/sys-devel/automake/automake-1.8.5-r3.ebuild
+++ b/sys-devel/automake/automake-1.8.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.8.5-r3.ebuild,v 1.5 2005/01/31 15:21:34 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.8.5-r3.ebuild,v 1.6 2005/02/04 00:08:25 vapier Exp $
inherit eutils gnuconfig
@@ -36,15 +36,11 @@ src_install() {
rm -f "${D}"/usr/bin/{aclocal,automake}
dodoc NEWS README THANKS TODO AUTHORS ChangeLog
-
- local x=
- cd "${D}"/usr/share/info
- for x in * ; do
- mv ${x} ${x/${PN}/${PN}${SLOT}}
- done
+ doinfo doc/*.info*
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
+ local x=
for x in guess sub ; do
dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
done
diff --git a/sys-devel/automake/automake-1.9.4.ebuild b/sys-devel/automake/automake-1.9.4.ebuild
index a359c3062d80..9f5e64134da6 100644
--- a/sys-devel/automake/automake-1.9.4.ebuild
+++ b/sys-devel/automake/automake-1.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.9.4.ebuild,v 1.7 2005/01/31 15:21:34 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.9.4.ebuild,v 1.8 2005/02/04 00:08:25 vapier Exp $
inherit eutils gnuconfig
@@ -37,15 +37,11 @@ src_install() {
rm -f "${D}"/usr/bin/{aclocal,automake}
dodoc NEWS README THANKS TODO AUTHORS ChangeLog
-
- local x=
- cd "${D}"/usr/share/info
- for x in * ; do
- mv ${x} ${x/${PN}/${PN}${SLOT}}
- done
+ doinfo doc/*.info*
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
+ local x=
for x in guess sub ; do
dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
done