summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-04-22 06:07:29 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-04-22 06:07:29 +0000
commitfa25815740cea29ceabe318a2d95896d847e2806 (patch)
tree09b73c730edda5a38adcec691ee2fb2e3bec4f7a /sys-devel
parentzlib USE flag back as it should be fixed now, bug #311241. (diff)
downloadgentoo-2-fa25815740cea29ceabe318a2d95896d847e2806.tar.gz
gentoo-2-fa25815740cea29ceabe318a2d95896d847e2806.tar.bz2
gentoo-2-fa25815740cea29ceabe318a2d95896d847e2806.zip
Add patch from upstream to fix testsuite w/ gcc-4.5.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bison/ChangeLog6
-rw-r--r--sys-devel/bison/bison-2.4.2.ebuild3
-rw-r--r--sys-devel/bison/files/bison-2.4.2-gcc45_testsuite.patch15
3 files changed, 22 insertions, 2 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 546523f076f7..6983c97e30ee 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/bison
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.84 2010/04/16 13:43:38 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.85 2010/04/22 06:07:29 dirtyepic Exp $
+
+ 22 Apr 2010; Ryan Hill <dirtyepic@gentoo.org> bison-2.4.2.ebuild,
+ +files/bison-2.4.2-gcc45_testsuite.patch:
+ Add patch from upstream to fix testsuite w/ gcc-4.5.
16 Apr 2010; Brent Baude <ranger@gentoo.org> bison-2.4.1.ebuild:
stable ppc, bug 311867
diff --git a/sys-devel/bison/bison-2.4.2.ebuild b/sys-devel/bison/bison-2.4.2.ebuild
index 981214b7b271..aae4bdac0b12 100644
--- a/sys-devel/bison/bison-2.4.2.ebuild
+++ b/sys-devel/bison/bison-2.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.4.2.ebuild,v 1.2 2010/04/04 20:01:31 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.4.2.ebuild,v 1.3 2010/04/22 06:07:29 dirtyepic Exp $
inherit toolchain-funcs flag-o-matic
@@ -20,6 +20,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-2.4.2-gnulib_spawn.patch # 312697
+ epatch "${FILESDIR}"/${PN}-2.4.2-gcc45_testsuite.patch
}
src_compile() {
diff --git a/sys-devel/bison/files/bison-2.4.2-gcc45_testsuite.patch b/sys-devel/bison/files/bison-2.4.2-gcc45_testsuite.patch
new file mode 100644
index 000000000000..d0fbd8147650
--- /dev/null
+++ b/sys-devel/bison/files/bison-2.4.2-gcc45_testsuite.patch
@@ -0,0 +1,15 @@
+http://git.savannah.gnu.org/cgit/bison.git/commit/?id=4ad3921d3be296de6a2b3c5fe0e18136d53ba06d
+
+--- a/tests/synclines.at
++++ b/tests/synclines.at
+@@ -71,7 +71,9 @@ AT_CHECK([[test "`cat stdout`" = 'syncline.c:1: @%:@error "1"' || exit 77]])
+ AT_DATA([[input.y]], [$2])
+ AT_BISON_CHECK([-o input.c input.y])
+ AT_SYNCLINES_COMPILE([input.c])
+-AT_CHECK([cat stdout], 0, [$3])
++# GCC 4.5 tells you the function within which #error appears, but
++# previous versions of gcc do not.
++AT_CHECK([grep -v ': In function ' stdout], 0, [$3])
+ AT_CLEANUP
+ ])
+