summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-11-10 07:24:09 +0000
committerMike Frysinger <vapier@gentoo.org>2007-11-10 07:24:09 +0000
commitf7e71e58ac0d9a6e67381df0321b953f5e64098e (patch)
tree7214744f81437fd226c5cfa610096402e3230937 /sys-devel
parentStable on amd64 wrt #198596. (diff)
downloadgentoo-2-f7e71e58ac0d9a6e67381df0321b953f5e64098e.tar.gz
gentoo-2-f7e71e58ac0d9a6e67381df0321b953f5e64098e.tar.bz2
gentoo-2-f7e71e58ac0d9a6e67381df0321b953f5e64098e.zip
Version bump.
(Portage version: 2.1.3.19)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gettext/ChangeLog7
-rw-r--r--sys-devel/gettext/files/digest-gettext-0.173
-rw-r--r--sys-devel/gettext/gettext-0.17.ebuild107
3 files changed, 116 insertions, 1 deletions
diff --git a/sys-devel/gettext/ChangeLog b/sys-devel/gettext/ChangeLog
index 78af0b0f472b..99ca1693c950 100644
--- a/sys-devel/gettext/ChangeLog
+++ b/sys-devel/gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gettext
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.154 2007/10/06 07:29:48 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.155 2007/11/10 07:24:09 vapier Exp $
+
+*gettext-0.17 (10 Nov 2007)
+
+ 10 Nov 2007; Mike Frysinger <vapier@gentoo.org> +gettext-0.17.ebuild:
+ Version bump.
06 Oct 2007; Ulrich Mueller <ulm@gentoo.org> -files/50po-mode-gentoo.el,
-gettext-0.16.1.ebuild:
diff --git a/sys-devel/gettext/files/digest-gettext-0.17 b/sys-devel/gettext/files/digest-gettext-0.17
new file mode 100644
index 000000000000..877fff7cb9d2
--- /dev/null
+++ b/sys-devel/gettext/files/digest-gettext-0.17
@@ -0,0 +1,3 @@
+MD5 58a2bc6d39c0ba57823034d55d65d606 gettext-0.17.tar.gz 11640890
+RMD160 36df9d4ad2848ec26729781e0d7e25b419e7d261 gettext-0.17.tar.gz 11640890
+SHA256 209638bb8e162f22c281145a34e220c66f1f6e9ff5e4c50c6f2ef2ded59537ba gettext-0.17.tar.gz 11640890
diff --git a/sys-devel/gettext/gettext-0.17.ebuild b/sys-devel/gettext/gettext-0.17.ebuild
new file mode 100644
index 000000000000..f51462dd1715
--- /dev/null
+++ b/sys-devel/gettext/gettext-0.17.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.17.ebuild,v 1.1 2007/11/10 07:24:09 vapier Exp $
+
+inherit flag-o-matic eutils multilib toolchain-funcs mono libtool
+
+DESCRIPTION="GNU locale utilities"
+HOMEPAGE="http://www.gnu.org/software/gettext/gettext.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="emacs nls doc nocxx"
+
+DEPEND="virtual/libiconv
+ dev-libs/expat"
+PDEPEND="emacs? ( app-emacs/po-mode )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epunt_cxx
+
+ epatch "${FILESDIR}"/${PN}-0.14.1-lib-path-tests.patch #81628
+ epatch "${FILESDIR}"/${PN}-0.14.2-fix-race.patch #85054
+ epatch "${FILESDIR}"/${PN}-0.15-expat-no-dlopen.patch #146211
+
+ # bundled libtool seems to be broken so skip certain rpath tests
+ # http://lists.gnu.org/archive/html/bug-libtool/2005-03/msg00070.html
+ sed -i \
+ -e '2iexit 77' \
+ autoconf-lib-link/tests/rpath-3*[ef] || die "sed tests"
+
+ # sanity check for Bug 105304
+ if [[ -z ${USERLAND} ]] ; then
+ eerror "You just hit Bug 105304, please post your 'emerge info' here:"
+ eerror "http://bugs.gentoo.org/105304"
+ die "Aborting to prevent screwing your system"
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ # Build with --without-included-gettext (on glibc systems)
+ if use elibc_glibc ; then
+ myconf="${myconf} --without-included-gettext $(use_enable nls)"
+ else
+ myconf="${myconf} --with-included-gettext --enable-nls"
+ fi
+ use nocxx && export CXX=$(tc-getCC)
+
+ # Emacs support is now in a separate package, so configure --without-emacs
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --without-emacs \
+ --disable-java \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failed"
+ use nls || rm -r "${D}"/usr/share/locale
+ dosym msgfmt /usr/bin/gmsgfmt #43435
+ dobin gettext-tools/misc/gettextize || die "gettextize"
+
+ # remove stuff that glibc handles
+ if use elibc_glibc ; then
+ rm -f "${D}"/usr/include/libintl.h
+ rm -f "${D}"/usr/$(get_libdir)/libintl.*
+ fi
+ rm -f "${D}"/usr/share/locale/locale.alias "${D}"/usr/lib/charset.alias
+
+ if [[ ${USERLAND} == "BSD" ]] ; then
+ libname="libintl$(get_libname 8)"
+ # Move dynamic libs and creates ldscripts into /usr/lib
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/${libname}* "${D}"/$(get_libdir)/
+ gen_usr_ldscript ${libname}
+ fi
+
+ if use doc ; then
+ dohtml "${D}"/usr/share/doc/${PF}/*.html
+ else
+ rm -rf "${D}"/usr/share/doc/${PF}/{csharpdoc,examples,javadoc2,javadoc1}
+ fi
+ rm -f "${D}"/usr/share/doc/${PF}/*.html
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}
+
+pkg_preinst() {
+ # older gettext's sometimes installed libintl ...
+ # need to keep the linked version or the system
+ # could die (things like sed link against it :/)
+ preserve_old_lib /{,usr/}$(get_libdir)/libintl$(get_libname 7)
+}
+
+pkg_postinst() {
+ ewarn "Any package that linked against the previous version"
+ ewarn "of gettext will have to be rebuilt."
+ ewarn "Please 'emerge gentoolkit' and run:"
+ ewarn "revdep-rebuild --library libintl.so.7"
+}