summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-10-06 22:25:17 +0000
committerTravis Tilley <lv@gentoo.org>2004-10-06 22:25:17 +0000
commitb6d10f2b02538831b9b0a87355c2c49271077ed9 (patch)
tree3ba7d367fd74ded18c229814840c4c0a3e8a5748 /sys-devel
parentfix those annoying QA messages about awk, part 2 (Manifest recommit) (diff)
downloadgentoo-2-b6d10f2b02538831b9b0a87355c2c49271077ed9.tar.gz
gentoo-2-b6d10f2b02538831b9b0a87355c2c49271077ed9.tar.bz2
gentoo-2-b6d10f2b02538831b9b0a87355c2c49271077ed9.zip
...fix those annoying QA messages about awk, part 3
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r8.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-devel/gcc/gcc-2.95.3-r8.ebuild b/sys-devel/gcc/gcc-2.95.3-r8.ebuild
index 156d82975bb9..edb2aadfa93e 100644
--- a/sys-devel/gcc/gcc-2.95.3-r8.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r8.ebuild,v 1.32 2004/08/25 13:55:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r8.ebuild,v 1.33 2004/10/06 22:25:17 lv Exp $
-inherit eutils flag-o-matic gcc
+inherit eutils flag-o-matic gcc versionator
# The next command strips most flags from CFLAGS/CXXFLAGS. If you do
# not like it, comment it out, but do not file bugreports if you run into
@@ -25,8 +25,10 @@ do_filter_flags() {
[ ! -n "${CCHOST}" ] && export CCHOST="${CHOST}"
LOC="/usr"
-MY_PV="`echo ${PV} | awk -F. '{ gsub(/_pre.*|_alpha.*/, ""); print $1 "." $2 }'`"
-MY_PV_FULL="`echo ${PV} | awk '{ gsub(/_pre.*|_alpha.*/, ""); print $0 }'`"
+#MY_PV="`echo ${PV} | awk -F. '{ gsub(/_pre.*|_alpha.*/, ""); print $1 "." $2 }'`"
+#MY_PV_FULL="`echo ${PV} | awk '{ gsub(/_pre.*|_alpha.*/, ""); print $0 }'`"
+MY_PV="$(get_version_component_range 1-2)"
+MY_PV_FULL="$(get_version_component_range 1-3)"
LIBPATH="${LOC}/lib/gcc-lib/${CCHOST}/${MY_PV_FULL}"
BINPATH="${LOC}/${CCHOST}/gcc-bin/${MY_PV}"