summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-12-05 18:39:36 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-12-05 18:39:36 +0000
commit5f79a821e901e33fa4859b4f80edc241fd2cda19 (patch)
treee5ddd1bd5d4e774c5e623b27e4e73c84bbc1d73a /sys-devel
parentVersion bump. (diff)
downloadgentoo-2-5f79a821e901e33fa4859b4f80edc241fd2cda19.tar.gz
gentoo-2-5f79a821e901e33fa4859b4f80edc241fd2cda19.tar.bz2
gentoo-2-5f79a821e901e33fa4859b4f80edc241fd2cda19.zip
Fix ocaml bindings installation, thanks everyone in bug #393023
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/files/llvm-3.0-ocaml_install.patch16
-rw-r--r--sys-devel/llvm/llvm-3.0.ebuild3
3 files changed, 23 insertions, 2 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 3a820cebdaaf..9bc8b8668760 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.56 2011/12/05 11:05:18 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.57 2011/12/05 18:39:36 voyageur Exp $
+
+ 05 Dec 2011; Bernard Cafarelli <voyageur@gentoo.org> llvm-3.0.ebuild,
+ +files/llvm-3.0-ocaml_install.patch:
+ Fix ocaml bindings installation, thanks everyone in bug #393023
02 Dec 2011; Bernard Cafarelli <voyageur@gentoo.org> llvm-9999.ebuild:
Drop llvm-config sed in live ebuild, bug #392715. Also add USE=gold handling
diff --git a/sys-devel/llvm/files/llvm-3.0-ocaml_install.patch b/sys-devel/llvm/files/llvm-3.0-ocaml_install.patch
new file mode 100644
index 000000000000..18f5cf6c373c
--- /dev/null
+++ b/sys-devel/llvm/files/llvm-3.0-ocaml_install.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/show_bug.cgi?id=393023
+http://llvm.org/bugs/show_bug.cgi?id=11177
+
+Index: llvm-3.0-3.0/bindings/ocaml/llvm/Makefile
+===================================================================
+--- llvm-3.0-3.0.orig/bindings/ocaml/llvm/Makefile 2011-11-15 12:17:02.785987852 +0100
++++ llvm-3.0-3.0/bindings/ocaml/llvm/Makefile 2011-11-15 12:20:12.661983615 +0100
+@@ -30,7 +30,7 @@
+ $(OcamlDir)/META.llvm: META.llvm
+ $(Verb) $(CP) -f $< $@
+
+-install-meta:: $(ObjDir)/META.llvm
++install-meta:: $(ObjDir)/../META.llvm
+ $(Echo) "Install $(BuildMode) $(DestMETA)"
+ $(Verb) $(MKDIR) $(PROJ_libocamldir)
+ $(Verb) $(DataInstall) META.llvm "$(DestMETA)"
diff --git a/sys-devel/llvm/llvm-3.0.ebuild b/sys-devel/llvm/llvm-3.0.ebuild
index 2f1018075c49..91fe09ea5866 100644
--- a/sys-devel/llvm/llvm-3.0.ebuild
+++ b/sys-devel/llvm/llvm-3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.0.ebuild,v 1.1 2011/12/02 13:20:14 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.0.ebuild,v 1.2 2011/12/05 18:39:36 voyageur Exp $
EAPI="3"
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -88,6 +88,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-2.6-commandguide-nops.patch
epatch "${FILESDIR}"/${PN}-2.9-nodoctargz.patch
+ epatch "${FILESDIR}"/${P}-ocaml_install.patch
}
src_configure() {