summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2013-08-14 19:50:28 +0000
committerFabian Groffen <grobian@gentoo.org>2013-08-14 19:50:28 +0000
commit56a6a0a8c264ab09b183206aebb0167d4c64a753 (patch)
tree555c054242183dfc38e6ddbd51c4f496e2a65c6a /sys-devel
parentVersion bump (released in 2011!), avoid building test programs in src_compile... (diff)
downloadgentoo-2-56a6a0a8c264ab09b183206aebb0167d4c64a753.tar.gz
gentoo-2-56a6a0a8c264ab09b183206aebb0167d4c64a753.tar.bz2
gentoo-2-56a6a0a8c264ab09b183206aebb0167d4c64a753.zip
Don't depend on/try to use chrpath on Darwin, bug #479568
(Portage version: 2.2.01.22288-prefix/cvs/Darwin i386, RepoMan options: --force, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/llvm-3.3-r1.ebuild14
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild12
3 files changed, 20 insertions, 12 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 40615434b4a9..ede29d78ebc9 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.131 2013/08/14 12:59:43 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.132 2013/08/14 19:50:28 grobian Exp $
+
+ 14 Aug 2013; Fabian Groffen <grobian@gentoo.org> llvm-3.3-r1.ebuild,
+ llvm-9999.ebuild:
+ Don't depend on/try to use chrpath on Darwin, bug #479568
14 Aug 2013; Michał Górny <mgorny@gentoo.org> llvm-3.2.ebuild,
llvm-3.3-r1.ebuild, llvm-3.3.ebuild, llvm-9999.ebuild:
diff --git a/sys-devel/llvm/llvm-3.3-r1.ebuild b/sys-devel/llvm/llvm-3.3-r1.ebuild
index 18fc086e53b9..0051cd5076aa 100644
--- a/sys-devel/llvm/llvm-3.3-r1.ebuild
+++ b/sys-devel/llvm/llvm-3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.3-r1.ebuild,v 1.10 2013/08/14 12:59:43 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.3-r1.ebuild,v 1.11 2013/08/14 19:50:28 grobian Exp $
EAPI=5
@@ -19,10 +19,10 @@ SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.gz
LICENSE="UoI-NCSA"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="clang debug doc gold kernel_FreeBSD +libffi multitarget ocaml python
- +static-analyzer test udis86 video_cards_radeon"
+IUSE="clang debug doc gold kernel_Darwin kernel_FreeBSD +libffi multitarget
+ ocaml python +static-analyzer test udis86 video_cards_radeon"
-DEPEND="app-admin/chrpath
+DEPEND="!kernel_Darwin? ( app-admin/chrpath )
dev-lang/perl
>=sys-devel/make-3.79
>=sys-devel/flex-2.5.4
@@ -296,8 +296,10 @@ multilib_src_install() {
emake DESTDIR="${D}" GENTOO_LIBDIR=$(get_libdir) install
# Fix rpaths.
- chrpath -r "${EPREFIX}"/usr/$(get_libdir)/llvm \
- "${ED}"/usr/bin/* || die
+ if use !kernel_Darwin ; then
+ chrpath -r "${EPREFIX}"/usr/$(get_libdir)/llvm \
+ "${ED}"/usr/bin/* || die
+ fi
if multilib_is_native_abi; then
# Move files back.
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index e4eb2032170c..983ab8c7fa8f 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.49 2013/08/14 12:59:43 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.50 2013/08/14 19:50:28 grobian Exp $
EAPI=5
@@ -18,9 +18,9 @@ LICENSE="UoI-NCSA"
SLOT="0/${PV}"
KEYWORDS=""
IUSE="clang debug doc gold +libffi multitarget ocaml python
- +static-analyzer test udis86 video_cards_radeon"
+ +static-analyzer test udis86 video_cards_radeon kernel_Darwin"
-DEPEND="app-admin/chrpath
+DEPEND="!kernel_Darwin? ( app-admin/chrpath )
dev-lang/perl
dev-python/sphinx
>=sys-devel/make-3.79
@@ -273,8 +273,10 @@ multilib_src_install() {
emake DESTDIR="${D}" GENTOO_LIBDIR=$(get_libdir) install
# Fix rpaths.
- chrpath -r "${EPREFIX}"/usr/$(get_libdir)/llvm \
- "${ED}"/usr/bin/* || die
+ if use !kernel_Darwin ; then
+ chrpath -r "${EPREFIX}"/usr/$(get_libdir)/llvm \
+ "${ED}"/usr/bin/* || die
+ fi
if multilib_is_native_abi; then
# Move files back.