summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-10-03 13:36:01 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-10-03 13:36:01 +0000
commit2cd823c71c220655bbf7ac479950dcb4be287b8b (patch)
tree46af803625bce66daabbe289b32a80c9850d60cf /sys-devel
parentUpdate tarball, repacked by upstream. Manage all configure switches. (diff)
downloadgentoo-2-2cd823c71c220655bbf7ac479950dcb4be287b8b.tar.gz
gentoo-2-2cd823c71c220655bbf7ac479950dcb4be287b8b.tar.bz2
gentoo-2-2cd823c71c220655bbf7ac479950dcb4be287b8b.zip
Rename alltargets USE flag to multitarget, bug #382307
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog8
-rw-r--r--sys-devel/llvm/llvm-2.8-r1.ebuild180
-rw-r--r--sys-devel/llvm/llvm-2.8-r2.ebuild10
-rw-r--r--sys-devel/llvm/llvm-2.8-r4.ebuild10
-rw-r--r--sys-devel/llvm/llvm-2.9-r1.ebuild181
-rw-r--r--sys-devel/llvm/llvm-2.9-r2.ebuild10
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild10
-rw-r--r--sys-devel/llvm/metadata.xml2
8 files changed, 24 insertions, 387 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index ddef3a42285a..ed2686fde2ca 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.45 2011/09/28 10:56:06 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.46 2011/10/03 13:36:01 voyageur Exp $
+
+ 03 Oct 2011; Bernard Cafarelli <voyageur@gentoo.org> -llvm-2.8-r1.ebuild,
+ llvm-2.8-r2.ebuild, llvm-2.8-r4.ebuild, -llvm-2.9-r1.ebuild,
+ llvm-2.9-r2.ebuild, llvm-9999.ebuild, metadata.xml:
+ Rename alltargets USE flag to multitarget, bug #382307. Clean bison
+ dependency, depending only on new enough one. Drop some versions
28 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> metadata.xml:
USE="libffi" is now global USE flag.
diff --git a/sys-devel/llvm/llvm-2.8-r1.ebuild b/sys-devel/llvm/llvm-2.8-r1.ebuild
deleted file mode 100644
index 0848fa049c41..000000000000
--- a/sys-devel/llvm/llvm-2.8-r1.ebuild
+++ /dev/null
@@ -1,180 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.8-r1.ebuild,v 1.6 2011/02/14 11:19:33 xarthisius Exp $
-
-EAPI="3"
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="Low Level Virtual Machine"
-HOMEPAGE="http://llvm.org/"
-# Upstream silently re-released the tarball...
-# drop the -> in 2.9
-SRC_URI="http://llvm.org/releases/${PV}/${P}.tgz -> ${P}-r1.tgz"
-
-LICENSE="UoI-NCSA"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~ppc-macos"
-IUSE="alltargets debug +libffi llvm-gcc ocaml test udis86"
-
-DEPEND="dev-lang/perl
- >=sys-devel/make-3.79
- >=sys-devel/flex-2.5.4
- >=sys-devel/bison-1.28
- !~sys-devel/bison-1.85
- !~sys-devel/bison-1.875
- || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 )
- || ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-3.2.3 )
- libffi? ( virtual/libffi )
- ocaml? ( dev-lang/ocaml )
- udis86? ( amd64? ( dev-libs/udis86[pic] )
- !amd64? ( dev-libs/udis86 ) )"
-RDEPEND="dev-lang/perl"
-
-S=${WORKDIR}/${PN}-${PV/_pre*}
-
-pkg_setup() {
- # need to check if the active compiler is ok
-
- broken_gcc=" 3.2.2 3.2.3 3.3.2 4.1.1 "
- broken_gcc_x86=" 3.4.0 3.4.2 "
- broken_gcc_amd64=" 3.4.6 "
-
- gcc_vers=$(gcc-fullversion)
-
- if [[ ${broken_gcc} == *" ${version} "* ]] ; then
- elog "Your version of gcc is known to miscompile llvm."
- elog "Check http://www.llvm.org/docs/GettingStarted.html for"
- elog "possible solutions."
- die "Your currently active version of gcc is known to miscompile llvm"
- fi
-
- if [[ ${CHOST} == i*86-* && ${broken_gcc_x86} == *" ${version} "* ]] ; then
- elog "Your version of gcc is known to miscompile llvm on x86"
- elog "architectures. Check"
- elog "http://www.llvm.org/docs/GettingStarted.html for possible"
- elog "solutions."
- die "Your currently active version of gcc is known to miscompile llvm"
- fi
-
- if [[ ${CHOST} == x86_64-* && ${broken_gcc_amd64} == *" ${version} "* ]];
- then
- elog "Your version of gcc is known to miscompile llvm in amd64"
- elog "architectures. Check"
- elog "http://www.llvm.org/docs/GettingStarted.html for possible"
- elog "solutions."
- die "Your currently active version of gcc is known to miscompile llvm"
- fi
-}
-
-src_prepare() {
- # unfortunately ./configure won't listen to --mandir and the-like, so take
- # care of this.
- einfo "Fixing install dirs"
- sed -e 's,^PROJ_docsdir.*,PROJ_docsdir := $(PROJ_prefix)/share/doc/'${PF}, \
- -e 's,^PROJ_etcdir.*,PROJ_etcdir := '"${EPREFIX}"'/etc/llvm,' \
- -e 's,^PROJ_libdir.*,PROJ_libdir := $(PROJ_prefix)/'$(get_libdir)/${PN}, \
- -i Makefile.config.in || die "Makefile.config sed failed"
- sed -e 's,$ABS_RUN_DIR/lib,'"${EPREFIX}"/usr/$(get_libdir)/${PN}, \
- -i tools/llvm-config/llvm-config.in.in || die "llvm-config sed failed"
-
- einfo "Fixing rpath"
- sed -e 's,\$(RPATH) -Wl\,\$(\(ToolDir\|LibDir\)),$(RPATH) -Wl\,'"${EPREFIX}"/usr/$(get_libdir)/${PN}, \
- -i Makefile.rules || die "rpath sed failed"
-
- epatch "${FILESDIR}"/${PN}-2.7-nodoctargz.patch
- epatch "${FILESDIR}"/${PN}-2.6-commandguide-nops.patch
- epatch "${FILESDIR}"/${PN}-2.8-darwin8.patch
-}
-
-src_configure() {
- local CONF_FLAGS="--enable-shared"
-
- if use debug; then
- CONF_FLAGS="${CONF_FLAGS} --disable-optimized"
- einfo "Note: Compiling LLVM in debug mode will create huge and slow binaries"
- # ...and you probably shouldn't use tmpfs, unless it can hold 900MB
- else
- CONF_FLAGS="${CONF_FLAGS} \
- --enable-optimized \
- --disable-assertions \
- --disable-expensive-checks"
- fi
-
- if use alltargets; then
- CONF_FLAGS="${CONF_FLAGS} --enable-targets=all"
- else
- CONF_FLAGS="${CONF_FLAGS} --enable-targets=host-only"
- fi
-
- if use amd64; then
- CONF_FLAGS="${CONF_FLAGS} --enable-pic"
- fi
-
- # things would be built differently depending on whether llvm-gcc is
- # used or not.
- local LLVM_GCC_DIR=/dev/null
- local LLVM_GCC_DRIVER=nope ; local LLVM_GPP_DRIVER=nope
- if use llvm-gcc ; then
- if has_version sys-devel/llvm-gcc; then
- LLVM_GCC_DIR=$(ls -d ${EROOT}/usr/$(get_libdir)/llvm-gcc* 2> /dev/null)
- LLVM_GCC_DRIVER=$(find ${LLVM_GCC_DIR} -name 'llvm*-gcc' 2> /dev/null)
- if [[ -z ${LLVM_GCC_DRIVER} ]] ; then
- die "failed to find installed llvm-gcc, LLVM_GCC_DIR=${LLVM_GCC_DIR}"
- fi
- einfo "Using $LLVM_GCC_DRIVER"
- LLVM_GPP_DRIVER=${LLVM_GCC_DRIVER/%-gcc/-g++}
- else
- eerror "llvm-gcc USE flag enabled, but sys-devel/llvm-gcc was not found"
- eerror "Building with standard gcc, re-merge this package after installing"
- eerror "llvm-gcc to build with it"
- eerror "This is normal behavior on first LLVM merge"
- fi
- fi
-
- CONF_FLAGS="${CONF_FLAGS} \
- --with-llvmgccdir=${LLVM_GCC_DIR} \
- --with-llvmgcc=${LLVM_GCC_DRIVER} \
- --with-llvmgxx=${LLVM_GPP_DRIVER}"
-
- if use ocaml; then
- CONF_FLAGS="${CONF_FLAGS} --enable-bindings=ocaml"
- else
- CONF_FLAGS="${CONF_FLAGS} --enable-bindings=none"
- fi
-
- if use udis86; then
- CONF_FLAGS="${CONF_FLAGS} --with-udis86"
- fi
- CONF_FLAGS="${CONF_FLAGS} $(use_enable libffi)"
- econf ${CONF_FLAGS} || die "econf failed"
-}
-
-src_compile() {
- emake VERBOSE=1 KEEP_SYMBOLS=1 REQUIRES_RTTI=1 || die "emake failed"
-}
-
-src_install() {
- emake KEEP_SYMBOLS=1 DESTDIR="${D}" install || die "install failed"
-
- # Fix install_names on Darwin. The build system is too complicated
- # to just fix this, so we correct it post-install
- if [[ ${CHOST} == *-darwin* ]] ; then
- for lib in lib{EnhancedDisassembly,LLVM-${PV},BugpointPasses,LLVMHello,LTO,profile_rt}.dylib ; do
- # libEnhancedDisassembly is Darwin10 only, so non-fatal
- [[ -f ${ED}/usr/lib/${PN}/${lib} ]] || continue
- ebegin "fixing install_name of $lib"
- install_name_tool \
- -id "${EPREFIX}"/usr/lib/${PN}/${lib} \
- "${ED}"/usr/lib/${PN}/${lib}
- eend $?
- done
- for f in "${ED}"/usr/bin/* "${ED}"/usr/lib/${PN}/libLTO.dylib ; do
- ebegin "fixing install_name reference to libLLVM-${PV}.dylib of ${f##*/}"
- install_name_tool \
- -change "${S}"/Release/lib/libLLVM-${PV}.dylib \
- "${EPREFIX}"/usr/lib/${PN}/libLLVM-${PV}.dylib \
- "${f}"
- eend $?
- done
- fi
-}
diff --git a/sys-devel/llvm/llvm-2.8-r2.ebuild b/sys-devel/llvm/llvm-2.8-r2.ebuild
index 8286189cf8b3..d8c60e42ba86 100644
--- a/sys-devel/llvm/llvm-2.8-r2.ebuild
+++ b/sys-devel/llvm/llvm-2.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.8-r2.ebuild,v 1.5 2011/07/15 09:54:56 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.8-r2.ebuild,v 1.6 2011/10/03 13:36:01 voyageur Exp $
EAPI="3"
inherit eutils multilib toolchain-funcs
@@ -14,14 +14,12 @@ SRC_URI="http://llvm.org/releases/${PV}/${P}.tgz -> ${P}-r1.tgz"
LICENSE="UoI-NCSA"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="alltargets debug +libffi llvm-gcc ocaml test udis86"
+IUSE="debug +libffi llvm-gcc multitarget ocaml test udis86"
DEPEND="dev-lang/perl
>=sys-devel/make-3.79
>=sys-devel/flex-2.5.4
- >=sys-devel/bison-1.28
- !~sys-devel/bison-1.85
- !~sys-devel/bison-1.875
+ >=sys-devel/bison-1.875d
|| ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 )
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-3.2.3 )
libffi? ( virtual/libffi )
@@ -102,7 +100,7 @@ src_configure() {
--disable-expensive-checks"
fi
- if use alltargets; then
+ if use multitarget; then
CONF_FLAGS="${CONF_FLAGS} --enable-targets=all"
else
CONF_FLAGS="${CONF_FLAGS} --enable-targets=host-only"
diff --git a/sys-devel/llvm/llvm-2.8-r4.ebuild b/sys-devel/llvm/llvm-2.8-r4.ebuild
index 22e9e5e23a62..21e02dff7c48 100644
--- a/sys-devel/llvm/llvm-2.8-r4.ebuild
+++ b/sys-devel/llvm/llvm-2.8-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.8-r4.ebuild,v 1.1 2011/04/15 17:28:55 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.8-r4.ebuild,v 1.2 2011/10/03 13:36:01 voyageur Exp $
EAPI="3"
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -14,14 +14,12 @@ SRC_URI="http://llvm.org/releases/${PV}/${P}.tgz -> ${P}-r1.tgz"
LICENSE="UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="alltargets debug +libffi llvm-gcc ocaml test udis86 vim-syntax"
+IUSE="debug +libffi llvm-gcc multitarget ocaml test udis86 vim-syntax"
DEPEND="dev-lang/perl
>=sys-devel/make-3.79
>=sys-devel/flex-2.5.4
- >=sys-devel/bison-1.28
- !~sys-devel/bison-1.85
- !~sys-devel/bison-1.875
+ >=sys-devel/bison-1.875d
|| ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 )
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-3.2.3 )
libffi? ( dev-util/pkgconfig
@@ -97,7 +95,7 @@ src_configure() {
$(use_enable debug assertions)
$(use_enable debug expensive-checks)"
- if use alltargets; then
+ if use multitarget; then
CONF_FLAGS="${CONF_FLAGS} --enable-targets=all"
else
CONF_FLAGS="${CONF_FLAGS} --enable-targets=host-only"
diff --git a/sys-devel/llvm/llvm-2.9-r1.ebuild b/sys-devel/llvm/llvm-2.9-r1.ebuild
deleted file mode 100644
index 018eb7dddd2a..000000000000
--- a/sys-devel/llvm/llvm-2.9-r1.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.9-r1.ebuild,v 1.3 2011/04/21 09:24:25 grobian Exp $
-
-EAPI="3"
-inherit eutils flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="Low Level Virtual Machine"
-HOMEPAGE="http://llvm.org/"
-SRC_URI="http://llvm.org/releases/${PV}/${P}.tgz"
-
-LICENSE="UoI-NCSA"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="alltargets debug +libffi llvm-gcc ocaml test udis86 vim-syntax"
-
-DEPEND="dev-lang/perl
- >=sys-devel/make-3.79
- >=sys-devel/flex-2.5.4
- >=sys-devel/bison-1.28
- !~sys-devel/bison-1.85
- !~sys-devel/bison-1.875
- || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 )
- || ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-3.2.3 )
- libffi? ( dev-util/pkgconfig
- virtual/libffi )
- ocaml? ( dev-lang/ocaml )
- udis86? ( amd64? ( dev-libs/udis86[pic] )
- !amd64? ( dev-libs/udis86 ) )"
-RDEPEND="dev-lang/perl
- libffi? ( virtual/libffi )
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
-
-S=${WORKDIR}/${PN}-${PV/_pre*}
-
-pkg_setup() {
- # need to check if the active compiler is ok
-
- broken_gcc=" 3.2.2 3.2.3 3.3.2 4.1.1 "
- broken_gcc_x86=" 3.4.0 3.4.2 "
- broken_gcc_amd64=" 3.4.6 "
-
- gcc_vers=$(gcc-fullversion)
-
- if [[ ${broken_gcc} == *" ${version} "* ]] ; then
- elog "Your version of gcc is known to miscompile llvm."
- elog "Check http://www.llvm.org/docs/GettingStarted.html for"
- elog "possible solutions."
- die "Your currently active version of gcc is known to miscompile llvm"
- fi
-
- if [[ ${CHOST} == i*86-* && ${broken_gcc_x86} == *" ${version} "* ]] ; then
- elog "Your version of gcc is known to miscompile llvm on x86"
- elog "architectures. Check"
- elog "http://www.llvm.org/docs/GettingStarted.html for possible"
- elog "solutions."
- die "Your currently active version of gcc is known to miscompile llvm"
- fi
-
- if [[ ${CHOST} == x86_64-* && ${broken_gcc_amd64} == *" ${version} "* ]];
- then
- elog "Your version of gcc is known to miscompile llvm in amd64"
- elog "architectures. Check"
- elog "http://www.llvm.org/docs/GettingStarted.html for possible"
- elog "solutions."
- die "Your currently active version of gcc is known to miscompile llvm"
- fi
-}
-
-src_prepare() {
- # unfortunately ./configure won't listen to --mandir and the-like, so take
- # care of this.
- einfo "Fixing install dirs"
- sed -e 's,^PROJ_docsdir.*,PROJ_docsdir := $(PROJ_prefix)/share/doc/'${PF}, \
- -e 's,^PROJ_etcdir.*,PROJ_etcdir := '"${EPREFIX}"'/etc/llvm,' \
- -e 's,^PROJ_libdir.*,PROJ_libdir := $(PROJ_prefix)/'$(get_libdir)/${PN}, \
- -i Makefile.config.in || die "Makefile.config sed failed"
- sed -e 's,$ABS_RUN_DIR/lib,'"${EPREFIX}"/usr/$(get_libdir)/${PN}, \
- -i tools/llvm-config/llvm-config.in.in || die "llvm-config sed failed"
-
- einfo "Fixing rpath"
- sed -e 's,\$(RPATH) -Wl\,\$(\(ToolDir\|LibDir\)),$(RPATH) -Wl\,'"${EPREFIX}"/usr/$(get_libdir)/${PN}, \
- -i Makefile.rules || die "rpath sed failed"
-
- epatch "${FILESDIR}"/${PN}-2.6-commandguide-nops.patch
- epatch "${FILESDIR}"/${PN}-2.9-nodoctargz.patch
-}
-
-src_configure() {
- local CONF_FLAGS="--enable-shared
- $(use_enable !debug optimized)
- $(use_enable debug assertions)
- $(use_enable debug expensive-checks)"
-
- if use alltargets; then
- CONF_FLAGS="${CONF_FLAGS} --enable-targets=all"
- else
- CONF_FLAGS="${CONF_FLAGS} --enable-targets=host-only"
- fi
-
- if use amd64; then
- CONF_FLAGS="${CONF_FLAGS} --enable-pic"
- fi
-
- # things would be built differently depending on whether llvm-gcc is
- # used or not.
- local LLVM_GCC_DIR=/dev/null
- local LLVM_GCC_DRIVER=nope ; local LLVM_GPP_DRIVER=nope
- if use llvm-gcc ; then
- if has_version sys-devel/llvm-gcc; then
- LLVM_GCC_DIR=$(ls -d ${EROOT}/usr/$(get_libdir)/llvm-gcc* 2> /dev/null)
- LLVM_GCC_DRIVER=$(find ${LLVM_GCC_DIR} -name 'llvm*-gcc' 2> /dev/null)
- if [[ -z ${LLVM_GCC_DRIVER} ]] ; then
- die "failed to find installed llvm-gcc, LLVM_GCC_DIR=${LLVM_GCC_DIR}"
- fi
- einfo "Using $LLVM_GCC_DRIVER"
- LLVM_GPP_DRIVER=${LLVM_GCC_DRIVER/%-gcc/-g++}
- else
- eerror "llvm-gcc USE flag enabled, but sys-devel/llvm-gcc was not found"
- eerror "Building with standard gcc, re-merge this package after installing"
- eerror "llvm-gcc to build with it"
- eerror "This is normal behavior on first LLVM merge"
- fi
- fi
-
- CONF_FLAGS="${CONF_FLAGS} \
- --with-llvmgccdir=${LLVM_GCC_DIR} \
- --with-llvmgcc=${LLVM_GCC_DRIVER} \
- --with-llvmgxx=${LLVM_GPP_DRIVER}"
-
- if use ocaml; then
- CONF_FLAGS="${CONF_FLAGS} --enable-bindings=ocaml"
- else
- CONF_FLAGS="${CONF_FLAGS} --enable-bindings=none"
- fi
-
- if use udis86; then
- CONF_FLAGS="${CONF_FLAGS} --with-udis86"
- fi
-
- if use libffi; then
- append-cppflags "$(pkg-config --cflags libffi)"
- fi
- CONF_FLAGS="${CONF_FLAGS} $(use_enable libffi)"
- econf ${CONF_FLAGS} || die "econf failed"
-}
-
-src_compile() {
- emake VERBOSE=1 KEEP_SYMBOLS=1 REQUIRES_RTTI=1 || die "emake failed"
-}
-
-src_install() {
- emake KEEP_SYMBOLS=1 DESTDIR="${D}" install || die "install failed"
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins utils/vim/*.vim
- fi
-
- # Fix install_names on Darwin. The build system is too complicated
- # to just fix this, so we correct it post-install
- if [[ ${CHOST} == *-darwin* ]] ; then
- for lib in lib{EnhancedDisassembly,LLVM-${PV},LTO}.dylib {BugpointPasses,LLVMHello,profile_rt}.dylib ; do
- # libEnhancedDisassembly is Darwin10 only, so non-fatal
- [[ -f ${ED}/usr/lib/${PN}/${lib} ]] || continue
- ebegin "fixing install_name of $lib"
- install_name_tool \
- -id "${EPREFIX}"/usr/lib/${PN}/${lib} \
- "${ED}"/usr/lib/${PN}/${lib}
- eend $?
- done
- for f in "${ED}"/usr/bin/* "${ED}"/usr/lib/${PN}/libLTO.dylib ; do
- ebegin "fixing install_name reference to libLLVM-${PV}.dylib of ${f##*/}"
- install_name_tool \
- -change "@executable_path/../lib/libLLVM-${PV}.dylib" \
- "${EPREFIX}"/usr/lib/${PN}/libLLVM-${PV}.dylib \
- "${f}"
- eend $?
- done
- fi
-}
diff --git a/sys-devel/llvm/llvm-2.9-r2.ebuild b/sys-devel/llvm/llvm-2.9-r2.ebuild
index b2837b3d4b5b..27543d5cd22b 100644
--- a/sys-devel/llvm/llvm-2.9-r2.ebuild
+++ b/sys-devel/llvm/llvm-2.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.9-r2.ebuild,v 1.1 2011/05/23 11:43:47 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.9-r2.ebuild,v 1.2 2011/10/03 13:36:01 voyageur Exp $
EAPI="3"
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -12,14 +12,12 @@ SRC_URI="http://llvm.org/releases/${PV}/${P}.tgz"
LICENSE="UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="alltargets debug +libffi llvm-gcc ocaml test udis86 vim-syntax"
+IUSE="debug +libffi llvm-gcc multitarget ocaml test udis86 vim-syntax"
DEPEND="dev-lang/perl
>=sys-devel/make-3.79
>=sys-devel/flex-2.5.4
- >=sys-devel/bison-1.28
- !~sys-devel/bison-1.85
- !~sys-devel/bison-1.875
+ >=sys-devel/bison-1.875d
|| ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 )
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-3.2.3 )
libffi? ( dev-util/pkgconfig
@@ -95,7 +93,7 @@ src_configure() {
$(use_enable debug assertions)
$(use_enable debug expensive-checks)"
- if use alltargets; then
+ if use multitarget; then
CONF_FLAGS="${CONF_FLAGS} --enable-targets=all"
else
CONF_FLAGS="${CONF_FLAGS} --enable-targets=host-only"
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index fa2e230c5eb3..34232e6de259 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.13 2011/06/06 19:34:32 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.14 2011/10/03 13:36:01 voyageur Exp $
EAPI="3"
inherit subversion eutils flag-o-matic multilib toolchain-funcs
@@ -13,14 +13,12 @@ ESVN_REPO_URI="http://llvm.org/svn/llvm-project/llvm/trunk"
LICENSE="UoI-NCSA"
SLOT="0"
KEYWORDS=""
-IUSE="alltargets debug +libffi llvm-gcc ocaml test udis86 vim-syntax"
+IUSE="debug +libffi llvm-gcc multitarget ocaml test udis86 vim-syntax"
DEPEND="dev-lang/perl
>=sys-devel/make-3.79
>=sys-devel/flex-2.5.4
- >=sys-devel/bison-1.28
- !~sys-devel/bison-1.85
- !~sys-devel/bison-1.875
+ >=sys-devel/bison-1.875d
|| ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 )
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-3.2.3 )
libffi? ( dev-util/pkgconfig
@@ -93,7 +91,7 @@ src_configure() {
$(use_enable debug assertions)
$(use_enable debug expensive-checks)"
- if use alltargets; then
+ if use multitarget; then
CONF_FLAGS="${CONF_FLAGS} --enable-targets=all"
else
CONF_FLAGS="${CONF_FLAGS} --enable-targets=host-only"
diff --git a/sys-devel/llvm/metadata.xml b/sys-devel/llvm/metadata.xml
index 994d006656f3..d1e724f140cc 100644
--- a/sys-devel/llvm/metadata.xml
+++ b/sys-devel/llvm/metadata.xml
@@ -11,8 +11,8 @@
3. A compiler infrastructure - LLVM is also a collection of source code that implements the language and compilation strategy. The primary components of the LLVM infrastructure are a GCC-based C and C++ front-end, a link-time optimization framework with a growing set of global and interprocedural analyses and transformations, static back-ends for many popular (and some obscure) architectures, a back-end which emits portable C code, and a Just-In-Time compilers for several architectures.
4. LLVM does not imply things that you would expect from a high-level virtual machine. It does not require garbage collection or run-time code generation (In fact, LLVM makes a great static compiler!). Note that optional LLVM components can be used to build high-level virtual machines and other systems that need these services.</longdescription>
<use>
- <flag name='alltargets'>Build all host targets (default: host only)</flag>
<flag name='llvm-gcc'>Build LLVM with <pkg>sys-devel/llvm-gcc</pkg></flag>
+ <flag name='multitarget'>Build all host targets (default: host only)</flag>
<flag name='udis86'>Enable support for <pkg>dev-libs/udis86</pkg> disassembler library</flag>
</use>
</pkgmetadata>