summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-06-24 13:42:48 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-06-24 13:42:48 +0000
commit2af0a0aaaaf6d8c2b1f3c75385d8cb89a5f3ffac (patch)
tree7f89c658191974463760e0ea0c2bd22b174752c6 /sys-devel
parentUpdate HOMEPAGE. (diff)
downloadgentoo-2-2af0a0aaaaf6d8c2b1f3c75385d8cb89a5f3ffac.tar.gz
gentoo-2-2af0a0aaaaf6d8c2b1f3c75385d8cb89a5f3ffac.tar.bz2
gentoo-2-2af0a0aaaaf6d8c2b1f3c75385d8cb89a5f3ffac.zip
Version bump. Bug #553144.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog7
-rw-r--r--sys-devel/gcc/gcc-4.8.5.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 9872901a2913..db5abc7debcf 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.1080 2015/06/14 17:58:37 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.1081 2015/06/24 13:42:48 blueness Exp $
+
+*gcc-4.8.5 (24 Jun 2015)
+
+ 24 Jun 2015; Anthony G. Basile <blueness@gentoo.org> +gcc-4.8.5.ebuild:
+ Version bump. Bug #553144.
14 Jun 2015; Michał Górny <mgorny@gentoo.org> gcc-4.9.2.ebuild:
Keyword ~amd64-fbsd ~x86-fbsd, https://github.com/gentoo/gentoo-portage-rsync-
diff --git a/sys-devel/gcc/gcc-4.8.5.ebuild b/sys-devel/gcc/gcc-4.8.5.ebuild
new file mode 100644
index 000000000000..94a9dcf613c1
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.8.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.8.5.ebuild,v 1.1 2015/06/24 13:42:48 blueness Exp $
+
+EAPI="4"
+
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.6.1"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 mips ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 mips ppc ppc64"
+SSP_STABLE="amd64 x86 mips ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 mips ppc ppc64 arm"
+#end Hardened stuff
+
+inherit eutils toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_prepare() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
+ toolchain_src_prepare
+
+ use vanilla && return 0
+ #Use -r1 for newer piepatchet that use DRIVER_SELF_SPECS for the hardened specs.
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env-r1.patch
+}