summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-09-13 22:50:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-09-13 22:50:01 +0000
commit0d58279d3c7ae017c4eeb98744d9b5957c6c9dd8 (patch)
treed1de1008031083e6e25bc1afc4a15578f679acac /sys-devel
parentRemove virtual/libc deps (diff)
downloadgentoo-2-0d58279d3c7ae017c4eeb98744d9b5957c6c9dd8.tar.gz
gentoo-2-0d58279d3c7ae017c4eeb98744d9b5957c6c9dd8.tar.bz2
gentoo-2-0d58279d3c7ae017c4eeb98744d9b5957c6c9dd8.zip
Use -Wl,--no-as-needed with binutils older than 2.20 betas to avoid failure of tests #63. Thanks to Dustin Polke, Roberto Sigalotti and Christian Ruppert for helping me track down the issue.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libtool/ChangeLog8
-rw-r--r--sys-devel/libtool/libtool-2.2.6a.ebuild16
2 files changed, 20 insertions, 4 deletions
diff --git a/sys-devel/libtool/ChangeLog b/sys-devel/libtool/ChangeLog
index 8ce66d1ac866..89c5439b2d57 100644
--- a/sys-devel/libtool/ChangeLog
+++ b/sys-devel/libtool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/libtool
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.145 2009/09/13 15:41:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.146 2009/09/13 22:50:01 flameeyes Exp $
+
+ 13 Sep 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ libtool-2.2.6a.ebuild:
+ Use -Wl,--no-as-needed with binutils older than 2.20 betas to avoid
+ failure of tests #63. Thanks to Dustin Polke, Roberto Sigalotti and
+ Christian Ruppert for helping me track down the issue.
13 Sep 2009; Diego E. Pettenò <flameeyes@gentoo.org>
libtool-2.2.6a.ebuild, +files/2.2.6a/libtool-2.2.6a-tests-locale.patch:
diff --git a/sys-devel/libtool/libtool-2.2.6a.ebuild b/sys-devel/libtool/libtool-2.2.6a.ebuild
index d67cad7a92e2..696c027a8a0f 100644
--- a/sys-devel/libtool/libtool-2.2.6a.ebuild
+++ b/sys-devel/libtool/libtool-2.2.6a.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.2.6a.ebuild,v 1.7 2009/09/13 15:41:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.2.6a.ebuild,v 1.8 2009/09/13 22:50:01 flameeyes Exp $
LIBTOOLIZE="true" #225559
-inherit eutils autotools
+inherit eutils autotools flag-o-matic
DESCRIPTION="A shared library tool for developers"
HOMEPAGE="http://www.gnu.org/software/libtool/"
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.lzma"
LICENSE="GPL-2"
SLOT="1.5"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="vanilla"
+IUSE="vanilla test"
RDEPEND="sys-devel/gnuconfig
>=sys-devel/autoconf-2.60
@@ -23,6 +23,16 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P%a}
+pkg_setup() {
+ if use test && ! has_version '>sys-devel/binutils-2.19.51'; then
+ einfo "Disabling --as-needed, since you got older binutils and you asked"
+ einfo "to run tests. With the stricter (older) --as-needed behaviour"
+ einfo "you'd be seeing a test failure in test #63; this has been fixed"
+ einfo "in the newer version of binutils."
+ append-ldflags -Wl,--no-as-needed
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"