summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaarten Thibaut <murphy@gentoo.org>2002-04-15 20:36:20 +0000
committerMaarten Thibaut <murphy@gentoo.org>2002-04-15 20:36:20 +0000
commit05425c595b637589ba9b6fb29f73a0640f35ea70 (patch)
tree52249f3ac72a4a6220e6fd110743845aaba669aa /sys-devel
parentRemoved PROVIDE of virtual/imapUW (diff)
downloadgentoo-2-05425c595b637589ba9b6fb29f73a0640f35ea70.tar.gz
gentoo-2-05425c595b637589ba9b6fb29f73a0640f35ea70.tar.bz2
gentoo-2-05425c595b637589ba9b6fb29f73a0640f35ea70.zip
Add configure flags to support long file names and enable 64 bit
filehandles on sparc and other linux platforms.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/patch/ChangeLog10
-rw-r--r--sys-devel/patch/files/digest-patch-2.5.4-r41
-rw-r--r--sys-devel/patch/patch-2.5.4-r4.ebuild40
3 files changed, 50 insertions, 1 deletions
diff --git a/sys-devel/patch/ChangeLog b/sys-devel/patch/ChangeLog
index 5674906d8bb7..a2df49b6c49c 100644
--- a/sys-devel/patch/ChangeLog
+++ b/sys-devel/patch/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/patch
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.1 2002/02/01 21:53:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.2 2002/04/15 20:36:20 murphy Exp $
+
+*patch-2.5.4-r4 (15 Feb 2002)
+
+ 15 Feb 2002; M.Thibaut <murphy@gentoo.org> ChangeLog :
+
+ Added configuration flags that ensure correct compilation of the program
+ on all Linux platforms (more notably 64-bit ones). Fixes bug 1726
+ "fseek: invalid argument" on sparc64 machines with sparc32 userland.
*patch-2.5.4-r3 (1 Feb 2002)
diff --git a/sys-devel/patch/files/digest-patch-2.5.4-r4 b/sys-devel/patch/files/digest-patch-2.5.4-r4
new file mode 100644
index 000000000000..65e848fff1e9
--- /dev/null
+++ b/sys-devel/patch/files/digest-patch-2.5.4-r4
@@ -0,0 +1 @@
+MD5 ee5ae84d115f051d87fcaaef3b4ae782 patch-2.5.4.tar.gz 186879
diff --git a/sys-devel/patch/patch-2.5.4-r4.ebuild b/sys-devel/patch/patch-2.5.4-r4.ebuild
new file mode 100644
index 000000000000..86e1d97cb54c
--- /dev/null
+++ b/sys-devel/patch/patch-2.5.4-r4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.4-r4.ebuild,v 1.1 2002/04/15 20:36:20 murphy Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Utility to apply diffs to files"
+SRC_URI="ftp://ftp.gnu.org/gnu/patch/${A}"
+HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ CFLAGS="$CFLAGS -DLINUX -D_XOPEN_SOURCE=500"; export CFLAGS
+ try ac_cv_sys_long_file_names=yes \
+ ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man install
+ if [ -z "`use build`" ]
+ then
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+
+}
+
+
+