summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2004-08-07 00:09:12 +0000
committerRobert Coie <rac@gentoo.org>2004-08-07 00:09:12 +0000
commit010db68debd1cc78f19f684d28985e9243b6ac5f (patch)
tree4f02a5503655695320a3239034cb90e94914e19d /sys-devel/libperl
parent~amd64 closes bug #58431 (Manifest recommit) (diff)
downloadgentoo-2-010db68debd1cc78f19f684d28985e9243b6ac5f.tar.gz
gentoo-2-010db68debd1cc78f19f684d28985e9243b6ac5f.tar.bz2
gentoo-2-010db68debd1cc78f19f684d28985e9243b6ac5f.zip
restrict maketest, QA fiddling
Diffstat (limited to 'sys-devel/libperl')
-rw-r--r--sys-devel/libperl/ChangeLog8
-rw-r--r--sys-devel/libperl/libperl-5.8.2-r1.ebuild7
-rw-r--r--sys-devel/libperl/libperl-5.8.2.ebuild7
-rw-r--r--sys-devel/libperl/libperl-5.8.3.ebuild7
-rw-r--r--sys-devel/libperl/libperl-5.8.4-r1.ebuild8
-rw-r--r--sys-devel/libperl/libperl-5.8.4.ebuild7
6 files changed, 28 insertions, 16 deletions
diff --git a/sys-devel/libperl/ChangeLog b/sys-devel/libperl/ChangeLog
index b99f418964be..eeadf15bb62a 100644
--- a/sys-devel/libperl/ChangeLog
+++ b/sys-devel/libperl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/libperl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.37 2004/07/29 20:19:53 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.38 2004/08/07 00:09:12 rac Exp $
+
+ 06 Aug 2004; Robert Coie <rac@gentoo.org> libperl-5.8.2-r1.ebuild,
+ libperl-5.8.2.ebuild, libperl-5.8.3.ebuild, libperl-5.8.4-r1.ebuild,
+ libperl-5.8.4.ebuild:
+ restrict maketest, avoid forkbomb in portage 51 with maketest enabled,
+ eliminate some global scope external calls
29 Jul 2004; Guy Martin <gmsoft@gentoo.org> libperl-5.8.4-r1.ebuild:
Stable on hppa.
diff --git a/sys-devel/libperl/libperl-5.8.2-r1.ebuild b/sys-devel/libperl/libperl-5.8.2-r1.ebuild
index fbe7649bb051..3da4b37c8f2f 100644
--- a/sys-devel/libperl/libperl-5.8.2-r1.ebuild
+++ b/sys-devel/libperl/libperl-5.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2-r1.ebuild,v 1.3 2004/06/29 17:43:00 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2-r1.ebuild,v 1.4 2004/08/07 00:09:12 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -64,12 +64,13 @@ filter-flags "-malign-double"
# The slot of this binary compat version of libperl.so
PERLSLOT="1"
-SHORT_PV="`echo ${PV} | cut -d. -f1,2`"
-MY_P="perl-`echo $PV | sed 's/_rc/-RC/'`"
+SHORT_PV="${PV%.*}"
+MY_P="perl-${PV/_rc/-RC}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
SRC_URI="ftp://ftp.cpan.org/pub/CPAN/src/${MY_P}.tar.gz"
HOMEPAGE="http://www.perl.org"
+RESTRICT="maketest"
if [ "${PN}" = "libperl" ]
then
diff --git a/sys-devel/libperl/libperl-5.8.2.ebuild b/sys-devel/libperl/libperl-5.8.2.ebuild
index 0a5bd5b4dc11..598901e8b3c2 100644
--- a/sys-devel/libperl/libperl-5.8.2.ebuild
+++ b/sys-devel/libperl/libperl-5.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2.ebuild,v 1.14 2004/06/29 17:43:00 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2.ebuild,v 1.15 2004/08/07 00:09:12 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -64,12 +64,13 @@ filter-flags "-malign-double"
# The slot of this binary compat version of libperl.so
PERLSLOT="1"
-SHORT_PV="`echo ${PV} | cut -d. -f1,2`"
-MY_P="perl-`echo $PV | sed 's/_rc/-RC/'`"
+SHORT_PV="${PV%.*}"
+MY_P="perl-${PV/_rc/-RC}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
SRC_URI="ftp://ftp.cpan.org/pub/CPAN/src/${MY_P}.tar.gz"
HOMEPAGE="http://www.perl.org"
+RESTRICT="maketest"
if [ "${PN}" = "libperl" ]
then
diff --git a/sys-devel/libperl/libperl-5.8.3.ebuild b/sys-devel/libperl/libperl-5.8.3.ebuild
index e6b5eee4d611..33a670fd102b 100644
--- a/sys-devel/libperl/libperl-5.8.3.ebuild
+++ b/sys-devel/libperl/libperl-5.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.3.ebuild,v 1.8 2004/06/29 17:43:00 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.3.ebuild,v 1.9 2004/08/07 00:09:12 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -64,12 +64,13 @@ filter-flags "-malign-double"
# The slot of this binary compat version of libperl.so
PERLSLOT="1"
-SHORT_PV="`echo ${PV} | cut -d. -f1,2`"
-MY_P="perl-`echo $PV | sed 's/_rc/-RC/'`"
+SHORT_PV="${PV%.*}"
+MY_P="perl-${PV/_rc/-RC}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
SRC_URI="ftp://ftp.cpan.org/pub/CPAN/src/${MY_P}.tar.gz"
HOMEPAGE="http://www.perl.org"
+RESTRICT="maketest"
if [ "${PN}" = "libperl" ]
then
diff --git a/sys-devel/libperl/libperl-5.8.4-r1.ebuild b/sys-devel/libperl/libperl-5.8.4-r1.ebuild
index 44c5f343d904..21bae2e1a023 100644
--- a/sys-devel/libperl/libperl-5.8.4-r1.ebuild
+++ b/sys-devel/libperl/libperl-5.8.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4-r1.ebuild,v 1.4 2004/07/29 20:19:53 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4-r1.ebuild,v 1.5 2004/08/07 00:09:12 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -64,12 +64,13 @@ filter-flags "-malign-double"
# The slot of this binary compat version of libperl.so
PERLSLOT="1"
-SHORT_PV="`echo ${PV} | cut -d. -f1,2`"
-MY_P="perl-`echo $PV | sed 's/_rc/-RC/'`"
+SHORT_PV="${PV%.*}"
+MY_P="perl-${PV/_rc/-RC}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
SRC_URI="ftp://ftp.cpan.org/pub/CPAN/src/${MY_P}.tar.gz"
HOMEPAGE="http://www.perl.org"
+RESTRICT="maketest"
if [ "${PN}" = "libperl" ]
then
@@ -95,6 +96,7 @@ RDEPEND="
PDEPEND=">=dev-lang/perl-${PV}"
pkg_setup() {
+
# I think this should rather be displayed if you *have* 'threads'
# in USE if it could break things ...
if use threads
diff --git a/sys-devel/libperl/libperl-5.8.4.ebuild b/sys-devel/libperl/libperl-5.8.4.ebuild
index 1f783e0e66df..0a29870f0dad 100644
--- a/sys-devel/libperl/libperl-5.8.4.ebuild
+++ b/sys-devel/libperl/libperl-5.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4.ebuild,v 1.10 2004/07/23 22:37:40 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4.ebuild,v 1.11 2004/08/07 00:09:12 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -65,12 +65,13 @@ filter-flags "-malign-double"
# The slot of this binary compat version of libperl.so
PERLSLOT="1"
-SHORT_PV="`echo ${PV} | cut -d. -f1,2`"
-MY_P="perl-`echo $PV | sed 's/_rc/-RC/'`"
+SHORT_PV="${PV%.*}"
+MY_P="perl-${PV/_rc/-RC}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
SRC_URI="ftp://ftp.cpan.org/pub/CPAN/src/${MY_P}.tar.gz"
HOMEPAGE="http://www.perl.org"
+RESTRICT="maketest"
if [ "${PN}" = "libperl" ]
then