summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-07-17 14:58:56 +0000
committerJeroen Roovers <jer@gentoo.org>2013-07-17 14:58:56 +0000
commit3285d68b89387d2b21de4a89876384ac10967de9 (patch)
treef4ba01eaeeaf0b23fb96fec657314353b8f54236 /sys-devel/kgcc64
parentFix path in patch, do not cd in src_prepare(). (diff)
downloadgentoo-2-3285d68b89387d2b21de4a89876384ac10967de9.tar.gz
gentoo-2-3285d68b89387d2b21de4a89876384ac10967de9.tar.bz2
gentoo-2-3285d68b89387d2b21de4a89876384ac10967de9.zip
Version bump.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sys-devel/kgcc64')
-rw-r--r--sys-devel/kgcc64/ChangeLog10
-rw-r--r--sys-devel/kgcc64/kgcc64-4.5.4.ebuild54
-rw-r--r--sys-devel/kgcc64/kgcc64-4.6.4.ebuild54
-rw-r--r--sys-devel/kgcc64/kgcc64-4.7.3.ebuild54
-rw-r--r--sys-devel/kgcc64/metadata.xml1
5 files changed, 172 insertions, 1 deletions
diff --git a/sys-devel/kgcc64/ChangeLog b/sys-devel/kgcc64/ChangeLog
index a2d8aec043bf..7e735ee07e29 100644
--- a/sys-devel/kgcc64/ChangeLog
+++ b/sys-devel/kgcc64/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/kgcc64
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.48 2013/03/02 01:17:39 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.49 2013/07/17 14:58:56 jer Exp $
+
+*kgcc64-4.7.3 (17 Jul 2013)
+*kgcc64-4.6.4 (17 Jul 2013)
+*kgcc64-4.5.4 (17 Jul 2013)
+
+ 17 Jul 2013; Jeroen Roovers <jer@gentoo.org> +kgcc64-4.5.4.ebuild,
+ +kgcc64-4.6.4.ebuild, +kgcc64-4.7.3.ebuild, metadata.xml:
+ Version bump.
02 Mar 2013; Ryan Hill <dirtyepic@gentoo.org> kgcc64-4.7.2.ebuild:
Bump patchset.
diff --git a/sys-devel/kgcc64/kgcc64-4.5.4.ebuild b/sys-devel/kgcc64/kgcc64-4.5.4.ebuild
new file mode 100644
index 000000000000..18e4ad6cd04b
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-4.5.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.5.4.ebuild,v 1.1 2013/07/17 14:58:56 jer Exp $
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="1.2"
+GCC_FILESDIR=${FILESDIR/${PN}/gcc}
+
+inherit toolchain eutils
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on mips and sparc; all other archs, refer to bug #228115
+KEYWORDS="~hppa ~sparc"
+
+RDEPEND=">=dev-libs/gmp-4.3.2
+ >=dev-libs/mpfr-2.4.2
+ >=dev-libs/mpc-0.8.1
+ >=sys-devel/gcc-config-1.4"
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="${RDEPEND}
+ hppa? ( sys-devel/binutils-hppa64 )
+ !sys-devel/gcc-hppa64
+ !sys-devel/gcc-mips64
+ !sys-devel/gcc-powerpc64
+ !sys-devel/gcc-sparc64
+ >=sys-apps/texinfo-4.8
+ >=sys-devel/bison-1.875"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}
diff --git a/sys-devel/kgcc64/kgcc64-4.6.4.ebuild b/sys-devel/kgcc64/kgcc64-4.6.4.ebuild
new file mode 100644
index 000000000000..5b7bf91fb579
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-4.6.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.6.4.ebuild,v 1.1 2013/07/17 14:58:56 jer Exp $
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="1.0"
+GCC_FILESDIR=${FILESDIR/${PN}/gcc}
+
+inherit toolchain
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on mips and sparc; all other archs, refer to bug #228115
+KEYWORDS="~hppa ~sparc"
+
+RDEPEND=">=dev-libs/gmp-4.3.2
+ >=dev-libs/mpfr-2.4.2
+ >=dev-libs/mpc-0.8.1
+ >=sys-devel/gcc-config-1.4"
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="${RDEPEND}
+ hppa? ( sys-devel/binutils-hppa64 )
+ !sys-devel/gcc-hppa64
+ !sys-devel/gcc-mips64
+ !sys-devel/gcc-powerpc64
+ !sys-devel/gcc-sparc64
+ >=sys-apps/texinfo-4.8
+ >=sys-devel/bison-1.875"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}
diff --git a/sys-devel/kgcc64/kgcc64-4.7.3.ebuild b/sys-devel/kgcc64/kgcc64-4.7.3.ebuild
new file mode 100644
index 000000000000..2d19801d5e85
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-4.7.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.7.3.ebuild,v 1.1 2013/07/17 14:58:56 jer Exp $
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="1.0"
+GCC_FILESDIR=${FILESDIR/${PN}/gcc}
+
+inherit toolchain eutils
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on mips and sparc; all other archs, refer to bug #228115
+KEYWORDS="~hppa ~sparc"
+
+RDEPEND=">=dev-libs/gmp-4.3.2
+ >=dev-libs/mpfr-2.4.2
+ >=dev-libs/mpc-0.8.1
+ >=sys-devel/gcc-config-1.4"
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="${RDEPEND}
+ hppa? ( sys-devel/binutils-hppa64 )
+ !sys-devel/gcc-hppa64
+ !sys-devel/gcc-mips64
+ !sys-devel/gcc-powerpc64
+ !sys-devel/gcc-sparc64
+ >=sys-apps/texinfo-4.8
+ >=sys-devel/bison-1.875"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}
diff --git a/sys-devel/kgcc64/metadata.xml b/sys-devel/kgcc64/metadata.xml
index aad6785f50cd..b97a1e08f5bd 100644
--- a/sys-devel/kgcc64/metadata.xml
+++ b/sys-devel/kgcc64/metadata.xml
@@ -5,6 +5,7 @@
<use>
<flag name='multislot'>Allow for SLOTs to include minor version (eg. 3.3.4 instead
of just 3.3)</flag>
+<flag name="regression-test">Run the testsuite and install the results (requires FEATURES=test)</flag>
</use>
</pkgmetadata>