summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-20 08:37:52 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-20 08:37:52 +0000
commite847cb192bc5b41864766c3e6d1d3cd0b6285c3b (patch)
tree1fe3716fd5da36435b1d544001f6018f195a17f8 /sys-devel/gcc
parentStable on ppc (bug #101509). (diff)
downloadgentoo-2-e847cb192bc5b41864766c3e6d1d3cd0b6285c3b.tar.gz
gentoo-2-e847cb192bc5b41864766c3e6d1d3cd0b6285c3b.tar.bz2
gentoo-2-e847cb192bc5b41864766c3e6d1d3cd0b6285c3b.zip
Fix cross-compile support for Playstation 2 targets (ee/iop).
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/ChangeLog7
-rw-r--r--sys-devel/gcc/files/3.2.2/gcc-3.2.2-cross-compile.patch11
-rw-r--r--sys-devel/gcc/files/3.2.2/gcc-3.2.2-no-COPYING-cross-compile.patch40
-rw-r--r--sys-devel/gcc/gcc-3.2.2.ebuild11
4 files changed, 67 insertions, 2 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 4a5d4e85e1bb..2cec270d7b32 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.446 2005/08/20 05:31:05 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.447 2005/08/20 08:37:52 vapier Exp $
+
+ 20 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/3.2.2/gcc-3.2.2-cross-compile.patch,
+ +files/3.2.2/gcc-3.2.2-no-COPYING-cross-compile.patch, gcc-3.2.2.ebuild:
+ Fix cross-compile support for Playstation 2 targets (ee/iop).
*gcc-4.1.0_beta20050819 (20 Aug 2005)
diff --git a/sys-devel/gcc/files/3.2.2/gcc-3.2.2-cross-compile.patch b/sys-devel/gcc/files/3.2.2/gcc-3.2.2-cross-compile.patch
new file mode 100644
index 000000000000..076cbf16bfa2
--- /dev/null
+++ b/sys-devel/gcc/files/3.2.2/gcc-3.2.2-cross-compile.patch
@@ -0,0 +1,11 @@
+--- gcc/configure.orig 2005-08-20 04:28:13.000000000 -0400
++++ gcc/configure 2005-08-20 04:28:38.000000000 -0400
+@@ -6790,7 +6790,7 @@
+ # This prevents libgcc2 from containing any code which requires libc
+ # support.
+ inhibit_libc=
+-if test x$host != x$target && test x$with_headers = x; then
++if test x$host != x$target && { test "x$with_headers" = x || test "x$with_headers" = xno ; } ; then
+ inhibit_libc=-Dinhibit_libc
+ else
+ if test x$with_newlib = xyes; then
diff --git a/sys-devel/gcc/files/3.2.2/gcc-3.2.2-no-COPYING-cross-compile.patch b/sys-devel/gcc/files/3.2.2/gcc-3.2.2-no-COPYING-cross-compile.patch
new file mode 100644
index 000000000000..6f42e74394da
--- /dev/null
+++ b/sys-devel/gcc/files/3.2.2/gcc-3.2.2-no-COPYING-cross-compile.patch
@@ -0,0 +1,40 @@
+--- gcc-3.2.2/configure.in
++++ gcc-3.2.2/configure.in
+@@ -517,37 +517,6 @@
+ esac
+ fi
+
+-# Handle ${copy_dirs}
+-set fnord ${copy_dirs}
+-shift
+-while [ $# != 0 ]; do
+- if [ -f $2/COPIED ] && [ x"`cat $2/COPIED`" = x"$1" ]; then
+- :
+- else
+- echo Copying $1 to $2
+-
+- # Use the install script to create the directory and all required
+- # parent directories.
+- if [ -d $2 ]; then
+- :
+- else
+- echo >config.temp
+- ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
+- fi
+-
+- # Copy the directory, assuming we have tar.
+- # FIXME: Should we use B in the second tar? Not all systems support it.
+- (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
+-
+- # It is the responsibility of the user to correctly adjust all
+- # symlinks. If somebody can figure out how to handle them correctly
+- # here, feel free to add the code.
+-
+- echo $1 > $2/COPIED
+- fi
+- shift; shift
+-done
+-
+ # Configure extra directories which are host specific
+
+ case "${host}" in
diff --git a/sys-devel/gcc/gcc-3.2.2.ebuild b/sys-devel/gcc/gcc-3.2.2.ebuild
index f0e98c756a61..0c03b986a266 100644
--- a/sys-devel/gcc/gcc-3.2.2.ebuild
+++ b/sys-devel/gcc/gcc-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2.ebuild,v 1.27 2005/05/28 07:10:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.2.ebuild,v 1.28 2005/08/20 08:37:52 vapier Exp $
# This version is really meant JUST for the ps2
@@ -20,3 +20,12 @@ inherit toolchain eutils
DESCRIPTION="The GNU Compiler Collection. Includes C/C++ and java compilers"
KEYWORDS="-*"
+
+src_unpack() {
+ gcc_src_unpack
+
+ epatch "${FILESDIR}"/3.2.2/gcc32-pr7768.patch
+ epatch "${FILESDIR}"/3.2.2/gcc32-pr8213.patch
+ epatch "${FILESDIR}"/3.2.2/gcc-3.2.2-cross-compile.patch
+ epatch "${FILESDIR}"/3.2.2/gcc-3.2.2-no-COPYING-cross-compile.patch
+}