summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-02-01 13:16:57 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-02-01 13:16:57 +0000
commitaee8abbff06ccf81f9101b4a3686bedc4ff55b60 (patch)
tree1711ab21addd809b57d5c2309c8401ecf6276b67 /sys-devel/ct-ng
parentCleanup old versions (diff)
downloadgentoo-2-aee8abbff06ccf81f9101b4a3686bedc4ff55b60.tar.gz
gentoo-2-aee8abbff06ccf81f9101b4a3686bedc4ff55b60.tar.bz2
gentoo-2-aee8abbff06ccf81f9101b4a3686bedc4ff55b60.zip
Version bump
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/ct-ng')
-rw-r--r--sys-devel/ct-ng/ChangeLog7
-rw-r--r--sys-devel/ct-ng/ct-ng-1.14.0.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/sys-devel/ct-ng/ChangeLog b/sys-devel/ct-ng/ChangeLog
index a26ac300f12e..f6118d30ed1e 100644
--- a/sys-devel/ct-ng/ChangeLog
+++ b/sys-devel/ct-ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/ct-ng
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.26 2012/01/24 15:09:25 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.27 2012/02/01 13:16:57 blueness Exp $
+
+*ct-ng-1.14.0 (01 Feb 2012)
+
+ 01 Feb 2012; Anthony G. Basile <blueness@gentoo.org> +ct-ng-1.14.0.ebuild:
+ Version bump
*ct-ng-1.13.3 (24 Jan 2012)
diff --git a/sys-devel/ct-ng/ct-ng-1.14.0.ebuild b/sys-devel/ct-ng/ct-ng-1.14.0.ebuild
new file mode 100644
index 000000000000..64ac886e05f5
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.14.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ct-ng-1.14.0.ebuild,v 1.1 2012/02/01 13:16:57 blueness Exp $
+
+EAPI="4"
+
+inherit bash-completion-r1 autotools
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="http://ymorin.is-a-geek.org/projects/crosstool"
+MY_P=${P/ct/crosstool}
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion"
+
+RDEPEND="net-misc/curl
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+src_prepare() {
+ #Upstream provides ${S}/bootstrap which runs autoconf -Wall --force
+ #We'll use eautoconf to be portage friendly
+ eautoconf -Wall --force
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" install || die "install failed"
+ dobashcomp ${PN}.comp
+ dodoc README TODO
+}