summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-06-02 17:03:38 +0000
committerMike Frysinger <vapier@gentoo.org>2015-06-02 17:03:38 +0000
commitc288d12f5ada08b627ba703f7bbc2ef30a807287 (patch)
treea5f252dfe4f066c4ba2c5a8faf6eee207a9e3dfb /sys-devel/crossdev
parentVersion bump which works with >=mercurial-3.3.3, thanks Nico R in bug #549434 (diff)
downloadgentoo-2-c288d12f5ada08b627ba703f7bbc2ef30a807287.tar.gz
gentoo-2-c288d12f5ada08b627ba703f7bbc2ef30a807287.tar.bz2
gentoo-2-c288d12f5ada08b627ba703f7bbc2ef30a807287.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog7
-rw-r--r--sys-devel/crossdev/crossdev-20150602.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index a996e86a1363..55f1ed439a7a 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.121 2015/05/30 04:46:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.122 2015/06/02 17:03:38 vapier Exp $
+
+*crossdev-20150602 (02 Jun 2015)
+
+ 02 Jun 2015; Mike Frysinger <vapier@gentoo.org> +crossdev-20150602.ebuild:
+ Version bump.
30 May 2015; Mike Frysinger <vapier@gentoo.org> crossdev-99999999.ebuild:
Start requiring portage-utils for qmerge.
diff --git a/sys-devel/crossdev/crossdev-20150602.ebuild b/sys-devel/crossdev/crossdev-20150602.ebuild
new file mode 100644
index 000000000000..e0caf0b4eb57
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20150602.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-20150602.ebuild,v 1.1 2015/06/02 17:03:38 vapier Exp $
+
+EAPI="4"
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}