summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-30 06:02:15 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-30 06:02:15 +0000
commit67c3b4154c5f8c6a5eb1c832729dfc690262ce2f (patch)
treebe511bcee68625a71a9531c957711fdc8a3fcd1d /sys-devel/autogen
parentMake cronjob prelinking control tristate (yes, no, user-controlled) as sugges... (diff)
downloadgentoo-2-67c3b4154c5f8c6a5eb1c832729dfc690262ce2f.tar.gz
gentoo-2-67c3b4154c5f8c6a5eb1c832729dfc690262ce2f.tar.bz2
gentoo-2-67c3b4154c5f8c6a5eb1c832729dfc690262ce2f.zip
Make sure -ggdb3 in CFLAGS doesnt cause a test failure #172533 by Kevin F. Quinn.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sys-devel/autogen')
-rw-r--r--sys-devel/autogen/ChangeLog7
-rw-r--r--sys-devel/autogen/autogen-5.8.8.ebuild8
-rw-r--r--sys-devel/autogen/files/autogen-5.8.8-scrub-debug.patch25
3 files changed, 38 insertions, 2 deletions
diff --git a/sys-devel/autogen/ChangeLog b/sys-devel/autogen/ChangeLog
index 8d82266994d3..1f50321b8456 100644
--- a/sys-devel/autogen/ChangeLog
+++ b/sys-devel/autogen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/autogen
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/ChangeLog,v 1.23 2007/03/13 14:33:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/ChangeLog,v 1.24 2007/03/30 06:02:15 vapier Exp $
+
+ 30 Mar 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/autogen-5.8.8-scrub-debug.patch, autogen-5.8.8.ebuild:
+ Make sure -ggdb3 in CFLAGS doesnt cause a test failure #172533 by Kevin F.
+ Quinn.
13 Mar 2007; Raúl Porcel <armin76@gentoo.org> autogen-5.8.8.ebuild:
x86 stable
diff --git a/sys-devel/autogen/autogen-5.8.8.ebuild b/sys-devel/autogen/autogen-5.8.8.ebuild
index edcc75b735bd..722c982a7dde 100644
--- a/sys-devel/autogen/autogen-5.8.8.ebuild
+++ b/sys-devel/autogen/autogen-5.8.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/autogen-5.8.8.ebuild,v 1.7 2007/03/17 21:36:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autogen/autogen-5.8.8.ebuild,v 1.8 2007/03/30 06:02:15 vapier Exp $
inherit eutils
@@ -25,6 +25,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-scrub-debug.patch #172533
+}
+
src_compile() {
econf || die "econf failed"
emake -j1 || die "emake failed"
diff --git a/sys-devel/autogen/files/autogen-5.8.8-scrub-debug.patch b/sys-devel/autogen/files/autogen-5.8.8-scrub-debug.patch
new file mode 100644
index 000000000000..b9e3a142328f
--- /dev/null
+++ b/sys-devel/autogen/files/autogen-5.8.8-scrub-debug.patch
@@ -0,0 +1,25 @@
+The test autoopts/test/immediate.test fails if CFLAGS contains any of the debug
+flags (apart from -g). This is because it tries to filter those flags out by
+using this:
+
+ CFLAGS="-g `echo ${CFLAGS} | \
+ sed 's,-O2,,;s/-g//'`"
+
+which clearly replaces -ggdb2 (for example) with -gdb2 - which isn't a valid
+CFLAG and the test compilation fails. A simple fix is to make the sed script a
+little more consistent.
+
+Kevin F. Quinn <kevquinn@gentoo.org>
+http://bugs.gentoo.org/172533
+
+--- autoopts/test/immediate.test
++++ autoopts/test/immediate.test
+@@ -51,7 +51,7 @@ _EOF_
+
+ INC=`echo ${INC} | sed 's/-lguile//;s/-lqthreads//'`
+ CFLAGS="-g `echo ${CFLAGS} | \
+- sed 's,-O2,,;s/-g//'`"
++ sed 's,-O2,,;s/-g[^[:space:]]*//'`"
+
+ echo ${AG_L} ${testname}.def
+ ${AG_L} ${testname}.def || \