summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2010-01-06 22:40:44 +0000
committerJustin Bronder <jsbronder@gentoo.org>2010-01-06 22:40:44 +0000
commitcce0b023c0413c5707403051ab7e9da2837b7954 (patch)
tree3f890cadf53caa27d720992208edfdd60ce99291 /sys-cluster
parentMarked ~hppa ~ppc (bug #299937). (diff)
downloadgentoo-2-cce0b023c0413c5707403051ab7e9da2837b7954.tar.gz
gentoo-2-cce0b023c0413c5707403051ab7e9da2837b7954.tar.bz2
gentoo-2-cce0b023c0413c5707403051ab7e9da2837b7954.zip
cleanup old versions.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/ChangeLog8
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.6-r1.ebuild97
2 files changed, 6 insertions, 99 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index 62b205d42e7d..6977c1291e41 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/openmpi
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.56 2009/12/10 22:08:10 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.57 2010/01/06 22:40:44 jsbronder Exp $
+
+ 06 Jan 2010; Justin Bronder <jsbronder@gentoo.org>
+ -openmpi-1.2.6-r1.ebuild:
+ cleanup old versions.
10 Dec 2009; Alexis Ballier <aballier@gentoo.org> openmpi-1.4.ebuild:
keyword ~x86-fbsd
diff --git a/sys-cluster/openmpi/openmpi-1.2.6-r1.ebuild b/sys-cluster/openmpi/openmpi-1.2.6-r1.ebuild
deleted file mode 100644
index df9d4a3ad2ae..000000000000
--- a/sys-cluster/openmpi/openmpi-1.2.6-r1.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.6-r1.ebuild,v 1.7 2008/07/21 18:11:31 nixnut Exp $
-
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.2/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-RESTRICT="threads? ( test )"
-KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
-IUSE="pbs fortran nocxx threads romio heterogeneous ipv6"
-RDEPEND="pbs? ( sys-cluster/torque )
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if use threads; then
- ewarn
- ewarn "WARNING: use of threads is still disabled by default in"
- ewarn "upstream builds."
- ewarn "You may stop now and set USE=-threads"
- ewarn
- epause 5
- fi
-
- elog
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- elog
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
-}
-
-src_compile() {
- local myconf="
- --sysconfdir=/etc/${PN}
- --without-xgrid
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm"
-
- if use threads; then
- myconf="${myconf}
- --enable-mpi-threads
- --with-progress-threads
- --with-threads=posix"
- fi
-
- if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
- myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = "gfortran" ]]; then
- # Because that's just a pain in the butt.
- myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
- elif [[ "${FORTRANC}" = if* ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
- fi
- else
- myconf="${myconf}
- --disable-mpi-f90
- --disable-mpi-f77"
- fi
-
- econf ${myconf} \
- $(use_enable !nocxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}