summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-09-11 13:10:30 +0000
committerPeter Volkov <pva@gentoo.org>2011-09-11 13:10:30 +0000
commitb1cac491d261f91a62d51aecebc634861aec07a1 (patch)
treef1532b6c26e2bdd114f173574dd3b35da550417e /sys-cluster
parentFixed installation with USE=-fontforge now too, again bug #379505 wrt Nikolay... (diff)
downloadgentoo-2-b1cac491d261f91a62d51aecebc634861aec07a1.tar.gz
gentoo-2-b1cac491d261f91a62d51aecebc634861aec07a1.tar.bz2
gentoo-2-b1cac491d261f91a62d51aecebc634861aec07a1.zip
Fixed vzeventd failure to stop, bug #382213 thank Vladimir Berezhnoy for report.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/vzctl/ChangeLog9
-rw-r--r--sys-cluster/vzctl/files/vzctl-3.0.28.3-vzeventd-stop.patch37
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.28.3-r1.ebuild83
3 files changed, 128 insertions, 1 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 639209ee4df9..175a91ffcb09 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.82 2011/08/13 13:32:44 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.83 2011/09/11 13:10:30 pva Exp $
+
+*vzctl-3.0.28.3-r1 (11 Sep 2011)
+
+ 11 Sep 2011; Peter Volkov <pva@gentoo.org> +vzctl-3.0.28.3-r1.ebuild,
+ +files/vzctl-3.0.28.3-vzeventd-stop.patch:
+ Fixed vzeventd failure to stop, bug #382213 thank Vladimir Berezhnoy for
+ report.
13 Aug 2011; Peter Volkov <pva@gentoo.org> -vzctl-3.0.26.3.ebuild,
-vzctl-3.0.27.ebuild, -vzctl-3.0.28.2.ebuild, vzctl-3.0.28.3.ebuild:
diff --git a/sys-cluster/vzctl/files/vzctl-3.0.28.3-vzeventd-stop.patch b/sys-cluster/vzctl/files/vzctl-3.0.28.3-vzeventd-stop.patch
new file mode 100644
index 000000000000..960afa266f4d
--- /dev/null
+++ b/sys-cluster/vzctl/files/vzctl-3.0.28.3-vzeventd-stop.patch
@@ -0,0 +1,37 @@
+From cf5b82e9758a96f493469caade1b447552415c5a Mon Sep 17 00:00:00 2001
+From: Peter Volkov <pva@gentoo.org>
+Date: Sun, 11 Sep 2011 15:47:22 +0400
+Subject: [PATCH] etc/init.d/vzeventd-gentoo.in: fix service stop
+
+vzeventd does not create pid file. Drop its mentioning from init script
+to fix /etc/init.d/vzeventd stop.
+
+https://bugs.gentoo.org/show_bug.cgi?id=382213
+---
+ etc/init.d/vzeventd-gentoo.in | 4 +---
+ 1 files changed, 1 insertions(+), 3 deletions(-)
+
+diff --git a/etc/init.d/vzeventd-gentoo.in b/etc/init.d/vzeventd-gentoo.in
+index 2c0da26..d7abcdf 100644
+--- a/etc/init.d/vzeventd-gentoo.in
++++ b/etc/init.d/vzeventd-gentoo.in
+@@ -41,7 +41,6 @@ start() {
+
+ ebegin "Starting vzeventd"
+ start-stop-daemon --start --exec ${VZEVENTD} \
+- --pidfile /var/run/vzeventd.pid \
+ -- ${VZEVENTD_OPTS}
+ eend $?
+ }
+@@ -49,7 +48,6 @@ start() {
+ stop() {
+ check_config || return
+ ebegin "Stopping vzeventd"
+- start-stop-daemon --stop --exec ${VZEVENTD} \
+- --pidfile /var/run/vzeventd.pid
++ start-stop-daemon --stop --exec ${VZEVENTD}
+ eend $?
+ }
+--
+1.7.3.4
+
diff --git a/sys-cluster/vzctl/vzctl-3.0.28.3-r1.ebuild b/sys-cluster/vzctl/vzctl-3.0.28.3-r1.ebuild
new file mode 100644
index 000000000000..cde931cdc048
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.0.28.3-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.28.3-r1.ebuild,v 1.1 2011/09/11 13:10:30 pva Exp $
+
+EAPI="4"
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="OpenVZ ConTainers control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ net-firewall/iptables
+ sys-apps/ed
+ sys-apps/iproute2
+ sys-fs/vzquota"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Set default OSTEMPLATE on gentoo
+ sed -e 's:=redhat-:=gentoo-:' -i etc/dists/default || die
+ epatch "${FILESDIR}/${P}-vzeventd-stop.patch"
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-udev \
+ --enable-bashcomp \
+ --enable-logrotate
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-gentoo
+
+ # install the bash-completion script into the right location
+ rm -rf "${ED}"/etc/bash_completion.d
+ newbashcomp etc/bash_completion.d/vzctl.sh ${PN}
+
+ # We need to keep some dirs
+ keepdir /vz/{dump,lock,root,private,template/cache}
+ keepdir /etc/vz/names /var/lib/vzctl/veip
+}
+
+pkg_postinst() {
+ local conf_without_OSTEMPLATE
+ for file in \
+ $(find "${EROOT}/etc/vz/conf/" \( -name *.conf -a \! -name 0.conf \)); do
+ if ! grep '^OSTEMPLATE' $file > /dev/null; then
+ conf_without_OSTEMPLATE+=" $file"
+ fi
+ done
+
+ if [[ -n ${conf_without_OSTEMPLATE} ]]; then
+ ewarn
+ ewarn "OSTEMPLATE default was changed from redhat-like to gentoo."
+ ewarn "This means that any VEID.conf files without explicit or correct"
+ ewarn "OSTEMPLATE set will use gentoo scripts instead of redhat."
+ ewarn "Please check the following configs:"
+ for file in ${conf_without_OSTEMPLATE}; do
+ ewarn "${file}"
+ done
+ ewarn
+ fi
+
+ ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
+ ewarn "following code to /etc/conf.d/net:"
+ ewarn " postup() {"
+ ewarn " /usr/sbin/vzifup-post \${IFACE}"
+ ewarn " }"
+
+ ewarn "Starting with 3.0.25 there is new vzeventd service to reboot CTs."
+ ewarn "Please, drop /usr/share/vzctl/scripts/vpsnetclean and"
+ ewarn "/usr/share/vzctl/scripts/vpsreboot from crontab and use"
+ ewarn "/etc/init.d/vzeventd."
+}