summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2014-12-12 13:41:15 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2014-12-12 13:41:15 +0000
commitae63488219dbc858fa3e057cf4a98ab6315b22b0 (patch)
tree21b84e35f67ac6ea691885a154755e45e579bc3c /sys-cluster
parentVersion bump (diff)
downloadgentoo-2-ae63488219dbc858fa3e057cf4a98ab6315b22b0.tar.gz
gentoo-2-ae63488219dbc858fa3e057cf4a98ab6315b22b0.tar.bz2
gentoo-2-ae63488219dbc858fa3e057cf4a98ab6315b22b0.zip
fix #526770, drop old and version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/pacemaker/ChangeLog9
-rw-r--r--sys-cluster/pacemaker/files/pacemaker-1.1.10-tinfo.patch21
-rw-r--r--sys-cluster/pacemaker/pacemaker-1.1.10.ebuild10
-rw-r--r--sys-cluster/pacemaker/pacemaker-1.1.12.ebuild (renamed from sys-cluster/pacemaker/pacemaker-1.1.8-r2.ebuild)38
-rw-r--r--sys-cluster/pacemaker/pacemaker-1.1.7.ebuild92
5 files changed, 51 insertions, 119 deletions
diff --git a/sys-cluster/pacemaker/ChangeLog b/sys-cluster/pacemaker/ChangeLog
index 72b4dea40d6a..013c853c14e0 100644
--- a/sys-cluster/pacemaker/ChangeLog
+++ b/sys-cluster/pacemaker/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/pacemaker
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/ChangeLog,v 1.35 2014/12/02 14:45:32 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/ChangeLog,v 1.36 2014/12/12 13:41:15 ultrabug Exp $
+
+*pacemaker-1.1.12 (12 Dec 2014)
+
+ 12 Dec 2014; Ultrabug <ultrabug@gentoo.org> -pacemaker-1.1.7.ebuild,
+ -pacemaker-1.1.8-r2.ebuild, pacemaker-1.1.10.ebuild,
+ +pacemaker-1.1.12.ebuild, +files/pacemaker-1.1.10-tinfo.patch:
+ fix #526770, drop old and version bump
02 Dec 2014; Ultrabug <ultrabug@gentoo.org> pacemaker-1.0.10.ebuild,
pacemaker-1.0.12.ebuild:
diff --git a/sys-cluster/pacemaker/files/pacemaker-1.1.10-tinfo.patch b/sys-cluster/pacemaker/files/pacemaker-1.1.10-tinfo.patch
new file mode 100644
index 000000000000..1dba440c9e79
--- /dev/null
+++ b/sys-cluster/pacemaker/files/pacemaker-1.1.10-tinfo.patch
@@ -0,0 +1,21 @@
+--- a/configure.ac 2014-12-12 14:13:07.262413254 +0100
++++ b/configure.ac 2014-12-12 14:13:14.922480835 +0100
+@@ -885,14 +885,16 @@
+ CURSESLIBS=''
+ if test "$ac_cv_header_ncurses_h" = "yes"; then
+ AC_CHECK_LIB(ncurses, printw,
+- [CURSESLIBS='-lncurses'; AC_DEFINE(HAVE_LIBNCURSES,1, have ncurses library)]
++ [AC_DEFINE(HAVE_LIBNCURSES,1, have ncurses library)]
+ )
++ CURSESLIBS=`$PKGCONFIG --libs ncurses`;
+ fi
+
+ if test "$ac_cv_header_ncurses_ncurses_h" = "yes"; then
+ AC_CHECK_LIB(ncurses, printw,
+- [CURSESLIBS='-lncurses'; AC_DEFINE(HAVE_LIBNCURSES,1, have ncurses library)]
++ [AC_DEFINE(HAVE_LIBNCURSES,1, have ncurses library)]
+ )
++ CURSESLIBS=`$PKGCONFIG --libs ncurses`;
+ fi
+
+ dnl Only look for non-n-library if there was no n-library.
diff --git a/sys-cluster/pacemaker/pacemaker-1.1.10.ebuild b/sys-cluster/pacemaker/pacemaker-1.1.10.ebuild
index f935ce715afc..06a5fca6d93e 100644
--- a/sys-cluster/pacemaker/pacemaker-1.1.10.ebuild
+++ b/sys-cluster/pacemaker/pacemaker-1.1.10.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.10.ebuild,v 1.1 2013/08/29 10:32:25 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.10.ebuild,v 1.2 2014/12/12 13:41:15 ultrabug Exp $
EAPI="5"
-PYTHON_DEPEND="2"
+PYTHON_COMPAT=( python{2_6,2_7} )
WANT_AUTOMAKE="1.12"
-inherit autotools base python
+inherit autotools base python-single-r1
MY_PN="Pacemaker"
MY_P=${MY_PN}-${PV/_/-}
@@ -35,6 +35,8 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=("${FILESDIR}"/pacemaker-1.1.10-tinfo.patch)
+
S="${WORKDIR}/${PN}-${MY_P}"
pkg_setup() {
diff --git a/sys-cluster/pacemaker/pacemaker-1.1.8-r2.ebuild b/sys-cluster/pacemaker/pacemaker-1.1.12.ebuild
index bd5c9d9a41b6..42d5718243e0 100644
--- a/sys-cluster/pacemaker/pacemaker-1.1.8-r2.ebuild
+++ b/sys-cluster/pacemaker/pacemaker-1.1.12.ebuild
@@ -1,20 +1,19 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.8-r2.ebuild,v 1.1 2013/04/23 08:04:02 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.12.ebuild,v 1.1 2014/12/12 13:41:15 ultrabug Exp $
-EAPI=4
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+WANT_AUTOMAKE="1.12"
-PYTHON_DEPEND="2"
+inherit autotools base python-single-r1
-inherit autotools base python
-
-MY_PN=Pacemaker
-MY_P=${MY_PN}-${PV}
-MY_TREE="1f8858c"
+MY_PN="Pacemaker"
+MY_P=${MY_PN}-${PV/_/-}
DESCRIPTION="Pacemaker CRM"
HOMEPAGE="http://www.linux-ha.org/wiki/Pacemaker"
-SRC_URI="https://github.com/ClusterLabs/${PN}/tarball/${MY_P} -> ${P}.tar.gz"
+SRC_URI="https://github.com/ClusterLabs/${PN}/archive/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -36,22 +35,16 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=(
- "${FILESDIR}"/${PV}-backwards_compatibility.patch
- )
-
-S="${WORKDIR}/ClusterLabs-${PN}-${MY_TREE}"
+PATCHES=("${FILESDIR}"/pacemaker-1.1.10-tinfo.patch)
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
+S="${WORKDIR}/${PN}-${MY_P}"
src_prepare() {
base_src_prepare
sed -i -e "/ggdb3/d" configure.ac || die
- sed -e "s:<glib/ghash.h>:<glib.h>:" \
- -i lib/ais/plugin.c || die
+ sed -i -e "s/ -ggdb//g" configure.ac || die
+ sed -i -e "s/uid2username(uid)/uid2username(uid_client)/g" lib/common/ipc.c || die
+ sed -i -e "s:<glib/ghash.h>:<glib.h>:" lib/ais/plugin.c || die
eautoreconf
python_convert_shebangs -r 2 .
}
@@ -65,6 +58,7 @@ src_configure() {
fi
# appends lib to localstatedir automatically
econf \
+ --libdir=/usr/$(get_libdir) \
--localstatedir=/var \
--disable-dependency-tracking \
--disable-fatal-warnings \
@@ -80,7 +74,7 @@ src_configure() {
src_install() {
base_src_install
- rm -rf "${D}"/var/run
+ rm -rf "${D}"/var/run "${D}"/etc/init.d
newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
if has_version "<sys-cluster/corosync-2.0"; then
insinto /etc/corosync/service.d
diff --git a/sys-cluster/pacemaker/pacemaker-1.1.7.ebuild b/sys-cluster/pacemaker/pacemaker-1.1.7.ebuild
deleted file mode 100644
index 1d5071d6728f..000000000000
--- a/sys-cluster/pacemaker/pacemaker-1.1.7.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.7.ebuild,v 1.5 2013/03/08 17:57:03 ultrabug Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2"
-
-inherit autotools base python
-
-MY_PN=Pacemaker
-MY_P=${MY_PN}-${PV}
-MY_TREE="b5b0a7b"
-
-DESCRIPTION="Pacemaker CRM"
-HOMEPAGE="http://www.linux-ha.org/wiki/Pacemaker"
-SRC_URI="https://github.com/ClusterLabs/${PN}/tarball/${MY_P} -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~x86"
-REQUIRED_USE="cman? ( !heartbeat )"
-IUSE="acl cman heartbeat smtp snmp static-libs"
-
-DEPEND="
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- sys-cluster/cluster-glue
- sys-cluster/resource-agents
- cman? ( sys-cluster/cman )
- heartbeat? ( >=sys-cluster/heartbeat-3.0.0 )
- !heartbeat? ( sys-cluster/corosync )
- smtp? ( net-libs/libesmtp )
- snmp? ( net-analyzer/net-snmp )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PV}-glibc2.16.patch )
-
-S="${WORKDIR}/ClusterLabs-${PN}-${MY_TREE}"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- base_src_prepare
- sed -i -e "/ggdb3/d" configure.ac || die
- sed -e "s:<glib/ghash.h>:<glib.h>:" \
- -i lib/ais/plugin.c || die
- eautoreconf
- python_convert_shebangs -r 2 .
-}
-
-src_configure() {
- local myopts=""
- use heartbeat || myopts="--with-ais"
- # appends lib to localstatedir automatically
- econf \
- --localstatedir=/var \
- --disable-dependency-tracking \
- --disable-fatal-warnings \
- $(use_with acl) \
- $(use_with cman cs-quorum) \
- $(use_with cman cman) \
- $(use_with heartbeat) \
- $(use_with smtp esmtp) \
- $(use_with snmp) \
- $(use_enable static-libs static) \
- ${myopts}
-}
-
-src_install() {
- base_src_install
- newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
- insinto /etc/corosync/service.d
- newins "${FILESDIR}/${PN}.service" ${PN} || die
-}
-
-pkg_postinst() {
- elog "This version of Pacemaker uses the new MCP feature"
- elog "and the v1 plugin for CoroSync. Read [1] for more info."
- elog
- elog "To start the Pacemaker Cluster Manager, run:"
- elog "/etc/init.d/pacemaker start"
- elog
- elog "[1] http://theclusterguy.clusterlabs.org/post/907043024/introducing-the-pacemaker-master-control-process-for"
- elog
- elog "Note: sys-cluster/openais is no longer a hard dependency of ${P},"
- elog "so you may need to install it yourself to suit your needs."
-}