summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-03 23:19:35 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-03 23:19:35 +0000
commita41e09b9edb18a22770759d9f0a23684c76ab600 (patch)
tree33029197999105484dbaf7bd20952387ab1fa7a8 /sys-cluster
parentHopefully getting the manifest signed again (diff)
downloadgentoo-2-a41e09b9edb18a22770759d9f0a23684c76ab600.tar.gz
gentoo-2-a41e09b9edb18a22770759d9f0a23684c76ab600.tar.bz2
gentoo-2-a41e09b9edb18a22770759d9f0a23684c76ab600.zip
[sys-cluster/maui] Add slurm || pbs support to maui
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/maui/ChangeLog8
-rw-r--r--sys-cluster/maui/files/maui.initd27
-rw-r--r--sys-cluster/maui/maui-3.3.1-r2.ebuild (renamed from sys-cluster/maui/maui-3.3.1-r1.ebuild)17
-rw-r--r--sys-cluster/maui/metadata.xml6
4 files changed, 27 insertions, 31 deletions
diff --git a/sys-cluster/maui/ChangeLog b/sys-cluster/maui/ChangeLog
index aa592fe566ef..4c7d1ba2dd65 100644
--- a/sys-cluster/maui/ChangeLog
+++ b/sys-cluster/maui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/maui
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/ChangeLog,v 1.21 2011/06/30 08:28:12 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/ChangeLog,v 1.22 2011/07/03 23:19:35 alexxy Exp $
+
+*maui-3.3.1-r2 (03 Jul 2011)
+
+ 03 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> -maui-3.3.1-r1.ebuild,
+ +maui-3.3.1-r2.ebuild, files/maui.initd:
+ Add slurm || pbs support to maui
30 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org> maui-3.3.1-r1.ebuild:
maui->PN, fix order of vars
diff --git a/sys-cluster/maui/files/maui.initd b/sys-cluster/maui/files/maui.initd
index 0bfce8a267ec..b8d747e1c4b8 100644
--- a/sys-cluster/maui/files/maui.initd
+++ b/sys-cluster/maui/files/maui.initd
@@ -1,38 +1,17 @@
#!/sbin/runscript
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/files/maui.initd,v 1.2 2011/06/29 16:15:04 alexxy Exp $
-
-. /etc/conf.d/torque
-PBS_SERVER_HOME="$(. /etc/env.d/25torque; echo ${PBS_SERVER_HOME})"
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/files/maui.initd,v 1.3 2011/07/03 23:19:35 alexxy Exp $
depend() {
need net
- after pbs_server
- before pbs_mom
+ after pbs_server slurmctld
+ before pbs_mom slurmd
after logger
}
-checkconfig() {
- for i in "server_name"; do
- if [ ! -e ${PBS_SERVER_HOME}/${i} ]; then
- eerror "Missing config file ${PBS_SERVER_HOME}/${i}"
- return 1
- fi
- done
-
- if [ -z "$(grep 'queue_type' ${PBS_SERVER_HOME}/server_priv/queues/*)" ]; then
- eerror "No queues have been defined yet."
- return 1
- fi
-}
-
start() {
- checkconfig || return 1
-
ebegin "Starting Maui scheduler"
- local extra_args=""
-
start-stop-daemon --start --exec /usr/sbin/maui
eend ${?}
}
diff --git a/sys-cluster/maui/maui-3.3.1-r1.ebuild b/sys-cluster/maui/maui-3.3.1-r2.ebuild
index d04ad58fb639..1ef2aeb762fc 100644
--- a/sys-cluster/maui/maui-3.3.1-r1.ebuild
+++ b/sys-cluster/maui/maui-3.3.1-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/maui-3.3.1-r1.ebuild,v 1.3 2011/06/30 08:28:12 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/maui-3.3.1-r2.ebuild,v 1.1 2011/07/03 23:19:35 alexxy Exp $
-EAPI="3"
+EAPI="4"
inherit autotools eutils multilib
@@ -13,9 +13,13 @@ SRC_URI="http://www.adaptivecomputing.com/download/${PN}/${P}.tar.gz"
LICENSE="maui"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE=""
+IUSE="pbs slurm"
-DEPEND="sys-cluster/torque"
+REQUIRED_USE="^^ ( pbs slurm )"
+
+DEPEND="
+ pbs? ( sys-cluster/torque )
+ slurm? ( sys-cluster/slurm )"
RDEPEND="${DEPEND}"
RESTRICT="fetch mirror"
@@ -28,9 +32,12 @@ src_prepare() {
}
src_configure() {
+ local myconf
+ use pbs && myconf="--with-pbs="${EPREFIX}"/usr"
+ use slurm && myconf="--with-wiki"
econf \
--with-spooldir="${EPREFIX}"/var/spool/${PN} \
- --with-pbs="${EPREFIX}"/usr
+ ${myconf}
}
src_install() {
diff --git a/sys-cluster/maui/metadata.xml b/sys-cluster/maui/metadata.xml
index 348e6c4de815..3d65f12cae0c 100644
--- a/sys-cluster/maui/metadata.xml
+++ b/sys-cluster/maui/metadata.xml
@@ -1,5 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>cluster</herd>
+ <herd>cluster</herd>
+ <use>
+ <flag name='pbs'>Enable pbs integration</flag>
+ <flag name='slurm'>Enable slurm integration</flag>
+ </use>
</pkgmetadata>