summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2009-08-13 01:42:06 +0000
committerJustin Bronder <jsbronder@gentoo.org>2009-08-13 01:42:06 +0000
commita1051730b1ca9cc08211fea6a71fdf1febe5360e (patch)
treebb8f0c3e3426586ef5775594d7e6dff4cdf3aa01 /sys-cluster
parentBump EAPI. Add the vt use flag for VampirTrace. Add blocker against dev-libs/... (diff)
downloadgentoo-2-a1051730b1ca9cc08211fea6a71fdf1febe5360e.tar.gz
gentoo-2-a1051730b1ca9cc08211fea6a71fdf1febe5360e.tar.bz2
gentoo-2-a1051730b1ca9cc08211fea6a71fdf1febe5360e.zip
Remove old version
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/openmpi-1.3.2.ebuild113
1 files changed, 0 insertions, 113 deletions
diff --git a/sys-cluster/openmpi/openmpi-1.3.2.ebuild b/sys-cluster/openmpi/openmpi-1.3.2.ebuild
deleted file mode 100644
index bb3ab98e09e7..000000000000
--- a/sys-cluster/openmpi/openmpi-1.3.2.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.3.2.ebuild,v 1.2 2009/06/13 19:02:14 jsbronder Exp $
-
-EAPI=1
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.3/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-RESTRICT="mpi-threads? ( test )"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+cxx fortran heterogeneous ipv6 mpi-threads pbs romio threads"
-RDEPEND="pbs? ( sys-cluster/torque )
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2
- !sys-cluster/mpiexec"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if use mpi-threads; then
- ewarn
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- ewarn
- epause 5
- fi
-
- elog
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- elog
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-}
-
-src_compile() {
- local myconf="
- --sysconfdir=/etc/${PN}
- --without-xgrid
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm"
-
- if use mpi-threads; then
- myconf="${myconf}
- --enable-mpi-threads
- --enable-progress-threads"
- fi
-
- if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
- myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = "gfortran" ]]; then
- # Because that's just a pain in the butt.
- myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
- elif [[ "${FORTRANC}" = if* ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
- fi
- else
- myconf="${myconf}
- --disable-mpi-f90
- --disable-mpi-f77"
- fi
-
- # Push Vampir Trace includes to a subdir.
- myconf="${myconf} --with-contrib-vt-flags=\"--includedir=/usr/include/vt\""
-
- econf ${myconf} \
- $(use_enable cxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}