summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2007-12-13 02:10:16 +0000
committerJustin Bronder <jsbronder@gentoo.org>2007-12-13 02:10:16 +0000
commit990b6b2d362e93c6d179896301742182de03b67e (patch)
tree4cf1793f9630cfa85a4629c4227658c016e8a556 /sys-cluster
parentMake the wxrc wrapper better at error handling and work properly with (diff)
downloadgentoo-2-990b6b2d362e93c6d179896301742182de03b67e.tar.gz
gentoo-2-990b6b2d362e93c6d179896301742182de03b67e.tar.bz2
gentoo-2-990b6b2d362e93c6d179896301742182de03b67e.zip
Bump sys-cluster/openmpi-1.2.4 (Bug #166787). Change virtual/pbs to sys-cluster/torque. Add use flags nocxx romio slurm heterogeneous smp and ipv6. Disable xgrid support (OS X). Include /usr/include by default with gfortran and mpif77.
(Portage version: 2.1.3.19)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/ChangeLog10
-rw-r--r--sys-cluster/openmpi/files/digest-openmpi-1.2.43
-rw-r--r--sys-cluster/openmpi/openmpi-1.1.1.ebuild4
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.4.ebuild73
4 files changed, 87 insertions, 3 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index e7afbfe73387..0a02142f04d5 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.9 2007/04/26 06:12:57 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.10 2007/12/13 02:10:15 jsbronder Exp $
+
+*openmpi-1.2.4 (13 Dec 2007)
+
+ 13 Dec 2007; Justin Bronder <jsbronder@gentoo.org> +openmpi-1.2.4.ebuild:
+ Bump sys-cluster/openmpi-1.2.4 (Bug #166787). Change virtual/pbs to
+ sys-cluster/torque. Add use flags nocxx romio slurm heterogeneous smp and
+ ipv6. Disable xgrid support (OS X). Include /usr/include by default with
+ gfortran and mpif77.
26 Apr 2007; Donnie Berkholz <dberkholz@gentoo.org>; metadata.xml:
Update for cluster herd split to hp-cluster and ha-cluster.
diff --git a/sys-cluster/openmpi/files/digest-openmpi-1.2.4 b/sys-cluster/openmpi/files/digest-openmpi-1.2.4
new file mode 100644
index 000000000000..f19425117f77
--- /dev/null
+++ b/sys-cluster/openmpi/files/digest-openmpi-1.2.4
@@ -0,0 +1,3 @@
+MD5 311b38c597f54d8d6b277225ef458666 openmpi-1.2.4.tar.bz2 3541543
+RMD160 3eea820f19fcc69b4c1813331aa43171549aad25 openmpi-1.2.4.tar.bz2 3541543
+SHA256 594a3a0af69cc7895e0d8f9add776a44bf9ed389794323d0b1b45e181a97e538 openmpi-1.2.4.tar.bz2 3541543
diff --git a/sys-cluster/openmpi/openmpi-1.1.1.ebuild b/sys-cluster/openmpi/openmpi-1.1.1.ebuild
index 7fddaf4f90aa..461f57ff8ba5 100644
--- a/sys-cluster/openmpi/openmpi-1.1.1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.1.1.ebuild,v 1.7 2007/07/14 22:18:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.1.1.ebuild,v 1.8 2007/12/13 02:10:15 jsbronder Exp $
inherit eutils multilib flag-o-matic toolchain-funcs fortran
diff --git a/sys-cluster/openmpi/openmpi-1.2.4.ebuild b/sys-cluster/openmpi/openmpi-1.2.4.ebuild
new file mode 100644
index 000000000000..a0c8e49f3c5c
--- /dev/null
+++ b/sys-cluster/openmpi/openmpi-1.2.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.4.ebuild,v 1.1 2007/12/13 02:10:15 jsbronder Exp $
+
+inherit eutils multilib flag-o-matic toolchain-funcs fortran
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A high-performance message passing library (MPI)"
+HOMEPAGE="http://www.open-mpi.org"
+SRC_URI="http://www.open-mpi.org/software/ompi/v1.2/downloads/${MY_P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pbs fortran nocxx threads romio slurm heterogeneous smp ipv6"
+RDEPEND="pbs? ( sys-cluster/torque )
+ !sys-cluster/mpich
+ !sys-cluster/lam-mpi
+ !sys-cluster/mpich2"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if use fortran; then
+ FORTRAN="g77 gfortran ifc"
+ fortran_pkg_setup
+ fi
+}
+
+src_compile() {
+ local myconf="
+ --sysconfdir=/etc/${PN}
+ --without-xgrid
+ --enable-pretty-print-stacktrace
+ --enable-orterun-prefix-by-default"
+
+ if use threads; then
+ myconf="${myconf}
+ --enable-mpi-threads
+ --with-progress-threads
+ --with-threads=posix"
+ fi
+
+ if [[ -n "${FORTRANC}" ]]; then
+ if [[ "${FORTRANC}" = "g77" ]]; then
+ myconf="${myconf} --disable-mpi-f90"
+ elif [[ "${FORTRANC}" = "gfortran" ]]; then
+ # Because that's just a pain in the butt.
+ myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
+ fi
+ else
+ myconf="${myconf}
+ --disable-mpi-f90
+ --disable-mpi-f77"
+ fi
+
+ econf ${myconf} \
+ $(use_enable !nocxx mpi-cxx) \
+ $(use_enable romio romio-io) \
+ $(use_enable smp smp-locks) \
+ $(use_enable heterogeneous heterogeneous) \
+ $(use_with pbs tm /usr/$(get_libdir)/pbs) \
+ $(use_with slurm) \
+ $(use_enable ipv6) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README AUTHORS NEWS VERSION
+}