summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-12-29 02:25:05 +0000
committerMike Gilbert <floppym@gentoo.org>2012-12-29 02:25:05 +0000
commit52044460ec3a6d7994a6e62347c6102d3063d916 (patch)
tree07bccf83a366dc9365c1d3248785b8ec5525dcd5 /sys-cluster
parentAttempt to re-unify portage and x11 overlay ebuilds. (diff)
downloadgentoo-2-52044460ec3a6d7994a6e62347c6102d3063d916.tar.gz
gentoo-2-52044460ec3a6d7994a6e62347c6102d3063d916.tar.bz2
gentoo-2-52044460ec3a6d7994a6e62347c6102d3063d916.zip
Add patch for init script, bug 449110 by slepnoga.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/vzctl/ChangeLog7
-rw-r--r--sys-cluster/vzctl/files/vzctl-4.1.1-VZREBOOTDIR.patch32
-rw-r--r--sys-cluster/vzctl/vzctl-4.1.1.ebuild3
3 files changed, 39 insertions, 3 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 848deb3f30d7..e4383c0c3e0a 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.97 2012/12/13 08:45:38 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.98 2012/12/29 02:25:05 floppym Exp $
+
+ 29 Dec 2012; Mike Gilbert <floppym@gentoo.org>
+ +files/vzctl-4.1.1-VZREBOOTDIR.patch, vzctl-4.1.1.ebuild:
+ Add patch for init script, bug 449110 by slepnoga.
13 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> vzctl-9999.ebuild:
Sync live ebuild with 4.1.1
@@ -541,4 +545,3 @@
+files/vzctl-2.7.0-gentoo_etc_vz.patch, +files/vz.initd, +metadata.xml,
+vzctl-2.7.0.21.ebuild:
Initial release. thx to kir
-
diff --git a/sys-cluster/vzctl/files/vzctl-4.1.1-VZREBOOTDIR.patch b/sys-cluster/vzctl/files/vzctl-4.1.1-VZREBOOTDIR.patch
new file mode 100644
index 000000000000..c868918b84ae
--- /dev/null
+++ b/sys-cluster/vzctl/files/vzctl-4.1.1-VZREBOOTDIR.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/show_bug.cgi?id=449110
+
+From 9e84e33023a31bc65479784113aad10c69ba0e36 Mon Sep 17 00:00:00 2001
+From: Kir Kolyshkin <kir@openvz.org>
+Date: Fri, 28 Dec 2012 13:31:07 -0800
+Subject: [PATCH] etc/init.d/vz-gentoo: fix missing VZREBOOTDIR
+
+That was pretty lame from my side. Fix for commit af5bf43.
+
+http://bugzilla.openvz.org/2467
+
+Reported-by: Andrei Vinogradov <spamslepnoga@inbox.ru>
+Signed-off-by: Kir Kolyshkin <kir@openvz.org>
+---
+ etc/init.d/vz-gentoo.in | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/etc/init.d/vz-gentoo.in b/etc/init.d/vz-gentoo.in
+index 05ef4e7..2dd2186 100755
+--- a/etc/init.d/vz-gentoo.in
++++ b/etc/init.d/vz-gentoo.in
+@@ -17,6 +17,7 @@ check_config() {
+ : ${VZVEINFO:=/proc/vz/veinfo}
+ : ${VESTAT:=/proc/vz/vestat}
+ : ${VPSCONFDIR:=@VPSCONFDIR@}
++ : ${VZREBOOTDIR:=@VZREBOOTDIR@}
+ : ${VZDEV:=venet0}
+ : ${VZCONF:=@PKGCONFDIR@/vz.conf}
+ : ${VE_STOP_MODE:=suspend}
+--
+1.7.1
+
diff --git a/sys-cluster/vzctl/vzctl-4.1.1.ebuild b/sys-cluster/vzctl/vzctl-4.1.1.ebuild
index 048fcd1148c4..89c9d19a0281 100644
--- a/sys-cluster/vzctl/vzctl-4.1.1.ebuild
+++ b/sys-cluster/vzctl/vzctl-4.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-4.1.1.ebuild,v 1.2 2012/12/11 18:17:36 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-4.1.1.ebuild,v 1.3 2012/12/29 02:25:05 floppym Exp $
EAPI="5"
@@ -33,6 +33,7 @@ src_prepare() {
sed -i -e "s:/lib/udev:$(udev_get_udevdir):" src/lib/dev.c || die 'sed on src/lib/dev.c failed'
+ local PATCHES=( "${FILESDIR}/${P}-VZREBOOTDIR.patch" )
base_src_prepare
}