summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-06-10 06:38:46 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-06-10 06:38:46 +0000
commit4ff5615082dad14db91255630141d348f1e536de (patch)
tree8482e658c151d034b46cb4802c9354e0f56eb47d /sys-cluster
parentkeyword ~amd64-linux ~x86-linux (diff)
downloadgentoo-2-4ff5615082dad14db91255630141d348f1e536de.tar.gz
gentoo-2-4ff5615082dad14db91255630141d348f1e536de.tar.bz2
gentoo-2-4ff5615082dad14db91255630141d348f1e536de.zip
Add patch from upstream to fix default hostfile location wrt #420431 by William Throwe <wtt6@cornell.edu>
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/ChangeLog10
-rw-r--r--sys-cluster/openmpi/files/openmpi-1.6-hostfile.patch16
-rw-r--r--sys-cluster/openmpi/openmpi-1.6-r1.ebuild (renamed from sys-cluster/openmpi/openmpi-1.6.ebuild)3
3 files changed, 27 insertions, 2 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index f0cafe28a8e8..806310019d2c 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.106 2012/05/30 12:54:36 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.107 2012/06/10 06:38:46 xarthisius Exp $
+
+*openmpi-1.6-r1 (10 Jun 2012)
+
+ 10 Jun 2012; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/openmpi-1.6-hostfile.patch, +openmpi-1.6-r1.ebuild,
+ -openmpi-1.6.ebuild:
+ Add patch from upstream to fix default hostfile location wrt #420431 by
+ William Throwe <wtt6@cornell.edu>
30 May 2012; Alexis Ballier <aballier@gentoo.org> openmpi-1.6.ebuild:
keyword ~amd64-fbsd
diff --git a/sys-cluster/openmpi/files/openmpi-1.6-hostfile.patch b/sys-cluster/openmpi/files/openmpi-1.6-hostfile.patch
new file mode 100644
index 000000000000..880c42926166
--- /dev/null
+++ b/sys-cluster/openmpi/files/openmpi-1.6-hostfile.patch
@@ -0,0 +1,16 @@
+Fix default hostfile location (backported r26440)
+
+https://bugs.gentoo.org/show_bug.cgi?id=420431
+
+Patch by Orion Poplawski <orion AT SPAMFREE cora DOT nwra DOT com>
+--- a/orte/runtime/orte_mca_params.c
++++ b/orte/runtime/orte_mca_params.c
+@@ -225,7 +225,7 @@ int orte_register_params(void)
+ false, false, 1000, &orte_timeout_usec_per_proc);
+
+ /* default hostfile */
+- asprintf(&orte_default_hostfile, "%s/etc/openmpi-default-hostfile", opal_install_dirs.prefix);
++ asprintf(&orte_default_hostfile, "%s/openmpi-default-hostfile", opal_install_dirs.sysconfdir);
+ mca_base_param_reg_string_name("orte", "default_hostfile",
+ "Name of the default hostfile (relative or absolute path, \"none\" to ignore environmental or default MCA param setting)",
+ false, false, orte_default_hostfile, &orte_default_hostfile);
diff --git a/sys-cluster/openmpi/openmpi-1.6.ebuild b/sys-cluster/openmpi/openmpi-1.6-r1.ebuild
index cbb8134a848a..34cbdef00ee9 100644
--- a/sys-cluster/openmpi/openmpi-1.6.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.6.ebuild,v 1.2 2012/05/30 12:54:36 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.6-r1.ebuild,v 1.1 2012/06/10 06:38:46 xarthisius Exp $
EAPI=4
inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs versionator
@@ -88,6 +88,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-hostfile.patch
# Necessary for scalibility, see
# http://www.open-mpi.org/community/lists/users/2008/09/6514.php
if use threads; then