summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-10-17 10:21:02 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-10-17 10:21:02 +0000
commit5b737b58459f58a9bc48284b380e0497dc4613a3 (patch)
tree3ecf6e28f435984f72147d0945fb8cf8c915460c /sys-cluster/vzctl
parentadd sys-power/upower to RDEPEND, fix bug 524620, thanks to Priit Laes (IRC: ... (diff)
downloadgentoo-2-5b737b58459f58a9bc48284b380e0497dc4613a3.tar.gz
gentoo-2-5b737b58459f58a9bc48284b380e0497dc4613a3.tar.bz2
gentoo-2-5b737b58459f58a9bc48284b380e0497dc4613a3.zip
Bump to 4.8, thanks to slepnoga
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'sys-cluster/vzctl')
-rw-r--r--sys-cluster/vzctl/ChangeLog8
-rw-r--r--sys-cluster/vzctl/files/vzctl-initscript-typo-patch-4.8.patch32
-rw-r--r--sys-cluster/vzctl/vzctl-4.8.ebuild98
3 files changed, 137 insertions, 1 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index e84daec39cd1..8b09a7fced5b 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.129 2014/08/14 17:07:31 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.130 2014/10/17 10:21:02 maksbotan Exp $
+
+*vzctl-4.8 (17 Oct 2014)
+
+ 17 Oct 2014; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/vzctl-initscript-typo-patch-4.8.patch, +vzctl-4.8.ebuild:
+ Bump to 4.8, thanks to slepnoga
14 Aug 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> vzctl-4.7.2.ebuild:
x86 stable wrt bug #515872
diff --git a/sys-cluster/vzctl/files/vzctl-initscript-typo-patch-4.8.patch b/sys-cluster/vzctl/files/vzctl-initscript-typo-patch-4.8.patch
new file mode 100644
index 000000000000..ee4818f19d27
--- /dev/null
+++ b/sys-cluster/vzctl/files/vzctl-initscript-typo-patch-4.8.patch
@@ -0,0 +1,32 @@
+From: Kir Kolyshkin <kir@openvz.org>
+Date: Tue, 14 Oct 2014 09:22:49 +0000 (-0700)
+Subject: init.d/vz-gentoo: fix a typo
+X-Git-Url: http://git.openvz.org/?p=vzctl;a=commitdiff_plain;h=7dd296400299f13964b2665792fbe1ea89ac6241
+
+init.d/vz-gentoo: fix a typo
+
+As reported in
+
+http://forum.openvz.org/index.php?t=msg&th=12775&S=cec69936a4b7d441bf7f44478dbb6c3c#msg_51690
+
+there's a missing bracket.
+
+This is a fix to commit 8e7fdb5.
+
+Reported-by: Sergey Ya Korshunoff
+Signed-off-by: Kir Kolyshkin <kir@openvz.org>
+---
+
+diff --git a/etc/init.d/vz-gentoo.in b/etc/init.d/vz-gentoo.in
+index d937408..c7b5604 100755
+--- a/etc/init.d/vz-gentoo.in
++++ b/etc/init.d/vz-gentoo.in
+@@ -202,7 +202,7 @@ start_ve() {
+
+ get_parallel()
+ {
+- [ -n "${VE_PARALLEL}" -a "${VE_PARALLEL" != "0" ] && return
++ [ -n "${VE_PARALLEL}" -a "${VE_PARALLEL}" != "0" ] && return
+ VE_PARALLEL=`awk '
+ BEGIN { num=0; }
+ $1 == "processor" { num++; }
diff --git a/sys-cluster/vzctl/vzctl-4.8.ebuild b/sys-cluster/vzctl/vzctl-4.8.ebuild
new file mode 100644
index 000000000000..895018b3492a
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-4.8.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-4.8.ebuild,v 1.1 2014/10/17 10:21:02 maksbotan Exp $
+
+EAPI="5"
+
+inherit base bash-completion-r1 eutils toolchain-funcs udev
+
+DESCRIPTION="OpenVZ ConTainers control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc64 -amd64-fbsd -x86-fbsd -sparc-fbsd"
+IUSE="+ploop +vzmigrate"
+
+RDEPEND="net-firewall/iptables
+ sys-apps/ed
+ >=sys-apps/iproute2-3.3.0
+ >=sys-fs/vzquota-3.1
+ ploop? (
+ >=sys-cluster/ploop-1.12
+ sys-block/parted
+ sys-fs/quota
+ dev-libs/libxml2
+ )
+ >=dev-libs/libcgroup-0.38
+ vzmigrate? (
+ net-misc/openssh
+ net-misc/rsync[xattr,acl]
+ app-arch/tar[xattr,acl]
+ net-misc/bridge-utils
+ sys-apps/gawk
+ )
+ virtual/udev
+ "
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ "
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/vzctl-initscript-typo-patch-4.8.patch
+
+ # Set default OSTEMPLATE on gentoo
+ sed -i -e 's:=redhat-:=gentoo-:' etc/dists/default || die 'sed on etc/dists/default failed'
+ # Set proper udev directory
+ sed -i -e "s:/lib/udev:$(get_udevdir):" src/lib/dev.c || die 'sed on src/lib/dev.c failed'
+}
+
+src_configure() {
+
+ econf \
+ --localstatedir=/var \
+ --enable-udev \
+ --enable-bashcomp \
+ --enable-logrotate \
+ --with-vz \
+ $(use_with ploop) \
+ --with-cgroup
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" udevdir="$(get_udevdir)"/rules.d install install-gentoo
+
+ # install the bash-completion script into the right location
+ rm -rf "${ED}"/etc/bash_completion.d
+ newbashcomp etc/bash_completion.d/vzctl.sh ${PN}
+
+ # We need to keep some dirs
+ keepdir /vz/{dump,lock,root,private,template/cache}
+ keepdir /etc/vz/names /var/lib/vzctl/veip
+}
+
+pkg_postinst() {
+ ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
+ ewarn "following code to /etc/conf.d/net:"
+ ewarn " postup() {"
+ ewarn " /usr/sbin/vzifup-post \${IFACE}"
+ ewarn " }"
+
+ ewarn "Starting with 3.0.25 there is new vzeventd service to reboot CTs."
+ ewarn "Please, drop /usr/share/vzctl/scripts/vpsnetclean and"
+ ewarn "/usr/share/vzctl/scripts/vpsreboot from crontab and use"
+ ewarn "/etc/init.d/vzeventd."
+
+ einfo "You have chose to "vanilla" kernel."
+ einfo "If you have checkpoint suspend/restore feature in vanilla kernel"
+ einfo "please install "sys-process/criu" "
+ einfo "This is experimental and not stable ( in gentoo ) now"
+
+ einfo "if you have work with .xz compressed template, please install app-arch/xz-utils"
+ einfo "if you have check signature donwloaded template - install gpg "
+
+}