summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-01-02 08:51:30 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-01-02 08:51:30 +0000
commitc1c67f5f430d3e90d4b99b2949b560988fc7638d (patch)
tree58027f0015a1669576f1fbdd7c0a9014b58b3d11 /sys-cluster/maui/maui-3.2.6_p21.ebuild
parentVersion bump (diff)
downloadgentoo-2-c1c67f5f430d3e90d4b99b2949b560988fc7638d.tar.gz
gentoo-2-c1c67f5f430d3e90d4b99b2949b560988fc7638d.tar.bz2
gentoo-2-c1c67f5f430d3e90d4b99b2949b560988fc7638d.zip
Version bump, bug 164373
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'sys-cluster/maui/maui-3.2.6_p21.ebuild')
-rw-r--r--sys-cluster/maui/maui-3.2.6_p21.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-cluster/maui/maui-3.2.6_p21.ebuild b/sys-cluster/maui/maui-3.2.6_p21.ebuild
new file mode 100644
index 000000000000..09a08152e510
--- /dev/null
+++ b/sys-cluster/maui/maui-3.2.6_p21.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/maui-3.2.6_p21.ebuild,v 1.1 2009/01/02 08:51:30 weaver Exp $
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Maui Cluster Scheduler"
+HOMEPAGE="http://www.clusterresources.com/products/maui/"
+SRC_URI="http://www.clusterresources.com/downloads/maui/${P/_/}.tar.gz"
+IUSE=""
+DEPEND="virtual/pbs"
+RDEPEND="${DEPEND}
+ virtual/libc"
+SLOT="0"
+LICENSE="maui"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="fetch mirror"
+
+S="${WORKDIR}/${P/_/}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-autoconf-2.60-compat.patch
+ sed -i \
+ -e "s~BUILDROOT=~BUILDROOT=${D}~" \
+ "${S}"/Makefile.in
+ eautoreconf
+}
+
+src_compile() {
+ econf --with-spooldir=/usr/spool/maui || die
+ emake || die
+}
+
+src_install() {
+ make install INST_DIR="${D}/usr"
+ cd docs
+ dodoc README mauidocs.html
+}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}, obtain the file"
+ einfo "${P/_/}.tar.gz and put it in ${DISTDIR}"
+}