summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-06 01:01:52 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-06 01:01:52 +0000
commitb8cc859661666fd13b0ddf806d75a2f3024a9c50 (patch)
treeccc375f42c03fac6cfdfa5bf8c7662105b819666 /sys-cluster/hpl
parentstabilize (diff)
downloadgentoo-2-b8cc859661666fd13b0ddf806d75a2f3024a9c50.tar.gz
gentoo-2-b8cc859661666fd13b0ddf806d75a2f3024a9c50.tar.bz2
gentoo-2-b8cc859661666fd13b0ddf806d75a2f3024a9c50.zip
Update hpl build to work with virtual/mpi including fixing it to compile via mpicc so it works with lam-mpi. Also include parameters to /usr/share/hpl and force the user to copy them instead of polluting /usr/bin.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-cluster/hpl')
-rw-r--r--sys-cluster/hpl/ChangeLog11
-rw-r--r--sys-cluster/hpl/Manifest3
-rw-r--r--sys-cluster/hpl/files/digest-hpl-1.0-r11
-rw-r--r--sys-cluster/hpl/hpl-1.0-r1.ebuild56
4 files changed, 69 insertions, 2 deletions
diff --git a/sys-cluster/hpl/ChangeLog b/sys-cluster/hpl/ChangeLog
index ec2beefc6767..41ff475fd724 100644
--- a/sys-cluster/hpl/ChangeLog
+++ b/sys-cluster/hpl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/hpl
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/ChangeLog,v 1.4 2004/12/28 22:05:47 ribosome Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/ChangeLog,v 1.5 2005/07/06 01:01:52 robbat2 Exp $
+
+*hpl-1.0-r1 (06 Jul 2005)
+
+ 06 Jul 2005; Robin H. Johnson <robbat2@gentoo.org> +hpl-1.0-r1.ebuild:
+ Update hpl build to work with virtual/mpi including fixing it to compile via
+ mpicc so it works with lam-mpi. Also include parameters to /usr/share/hpl
+ and force the user to copy them instead of polluting /usr/bin.
28 Dec 2004; Olivier Fisette <ribosome@gentoo.org> hpl-1.0.ebuild:
Dependency update: dev-libs/atlas -> sci-libs/atlas.
diff --git a/sys-cluster/hpl/Manifest b/sys-cluster/hpl/Manifest
index daf1e5471e86..54bf3361b99e 100644
--- a/sys-cluster/hpl/Manifest
+++ b/sys-cluster/hpl/Manifest
@@ -1,5 +1,8 @@
+MD5 c94ad9b2720f53511d75ef71d910191b d 1186
+MD5 c902f74b49f2d2327a77f0ce18a6adaf hpl-1.0-r1.ebuild 1598
MD5 87c27e6afa51d175e8088e38450a8c3d hpl-1.0.ebuild 1131
MD5 2b271bb4085370330c77a609207fcfd4 ChangeLog 587
MD5 41664043c4624dedcfeeb07950f08d13 metadata.xml 312
MD5 6ba8acccaf6e3ca998fe7383c6765457 files/digest-hpl-1.0 52
MD5 56b70745bddaadc9125b94e1a92889e4 files/Make.gentoo_hpl_cblas_x86.diff.bz2 757
+MD5 6ba8acccaf6e3ca998fe7383c6765457 files/digest-hpl-1.0-r1 52
diff --git a/sys-cluster/hpl/files/digest-hpl-1.0-r1 b/sys-cluster/hpl/files/digest-hpl-1.0-r1
new file mode 100644
index 000000000000..6b64c3df6adc
--- /dev/null
+++ b/sys-cluster/hpl/files/digest-hpl-1.0-r1
@@ -0,0 +1 @@
+MD5 32b432af96e674dcb657ef1d63e6d591 hpl.tgz 523139
diff --git a/sys-cluster/hpl/hpl-1.0-r1.ebuild b/sys-cluster/hpl/hpl-1.0-r1.ebuild
new file mode 100644
index 000000000000..fe6d8deaf8f9
--- /dev/null
+++ b/sys-cluster/hpl/hpl-1.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-1.0-r1.ebuild,v 1.1 2005/07/06 01:01:52 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="HPL - A Portable Implementation of the High-Performance Linpack Benchmark for Distributed-Memory Computers"
+HOMEPAGE="http://www.netlib.org/benchmark/hpl/"
+SRC_URI="http://www.netlib.org/benchmark/hpl/hpl.tgz"
+LICENSE="HPL"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+S="${WORKDIR}/${PN}"
+
+DEPEND="virtual/mpi
+ sci-libs/blas
+ sci-libs/atlas"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp setup/Make.Linux_PII_CBLAS Make.gentoo_hpl_cblas_x86
+ sed -i \
+ -e '/^HPL_OPTS\>/s,= .*,= -DHPL_CALL_CBLAS -DHPL_DETAILED_TIMING -DHPL_COPY_L,' \
+ -e '/^ARCH\>/s,Linux_PII_CBLAS,gentoo_hpl_cblas_x86,' \
+ -e '/^MPdir\>/s,= .*,=,' \
+ -e '/^MPlib\>/s,= .*,=,' \
+ -e "/^LAdir\>/s,= .*,= /usr/$(get_libdir)," \
+ -e '/^LINKER\>/s,= .*,= mpicc,' \
+ -e '/^CC\>/s,= .*,= mpicc,' \
+ Make.gentoo_hpl_cblas_x86
+}
+
+src_compile() {
+ # do NOT use emake here
+ HOME=${WORKDIR} make arch=gentoo_hpl_cblas_x86 || die "Failed to build"
+}
+
+src_install() {
+ doman man/man3/*.3
+ dodoc INSTALL BUGS COPYRIGHT HISTORY README TUNING
+ dobin bin/gentoo_hpl_cblas_x86/xhpl || die "Failed to install bins"
+ insinto /usr/share/hpl
+ doins bin/gentoo_hpl_cblas_x86/HPL.dat || die "Failed to install HPL parameters"
+ dohtml -r www/*
+ dolib lib/gentoo_hpl_cblas_x86/libhpl.a || die "Failed to install lib"
+}
+
+pkg_postinst() {
+ einfo "Remember to copy /usr/share/hpl/HPL.dat to your working directory first!"
+ einfo "For mpich, run linpack by executing this in your working directory"
+ einfo "\"mpirun -np 4 /usr/bin/xhpl\""
+ einfo "where -np specifies the number of processes."
+ einfo "Other methods are needed lam-mpi etc."
+}