summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-04-21 09:42:07 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-04-21 09:42:07 +0000
commitc4a0c2c7edb72145c838bba98ba4fa68e3caa32f (patch)
tree72de58c1b465068622acb6b1d9caadd24bed2ce3 /sys-boot
parentFix iproute dep after spanky broke it ;P (Manifest recommit) (diff)
downloadgentoo-2-c4a0c2c7edb72145c838bba98ba4fa68e3caa32f.tar.gz
gentoo-2-c4a0c2c7edb72145c838bba98ba4fa68e3caa32f.tar.bz2
gentoo-2-c4a0c2c7edb72145c838bba98ba4fa68e3caa32f.zip
New revision of colo. Adds a number of new features, including booting from RAID, loadable initrd, and other bits.
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/colo/ChangeLog9
-rw-r--r--sys-boot/colo/Manifest5
-rw-r--r--sys-boot/colo/colo-1.6.ebuild95
-rw-r--r--sys-boot/colo/files/colo-1.6-gentoo.patch36
-rw-r--r--sys-boot/colo/files/digest-colo-1.61
5 files changed, 144 insertions, 2 deletions
diff --git a/sys-boot/colo/ChangeLog b/sys-boot/colo/ChangeLog
index 2248bc2b989a..3883e6c5c65e 100644
--- a/sys-boot/colo/ChangeLog
+++ b/sys-boot/colo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/colo
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.1 2004/04/05 07:49:06 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.2 2004/04/21 09:42:07 kumba Exp $
+
+*colo-1.6 (21 Apr 2004)
+
+ 21 Apr 2004; Joshua Kinard <kumba@gentoo.org> +files/colo-1.6-gentoo.patch,
+ +colo-1.6.ebuild:
+ New revision of colo. Adds a number of new features, including booting from
+ RAID, loadable initrd, and other bits.
*colo-1.4 (05 Apr 2004)
diff --git a/sys-boot/colo/Manifest b/sys-boot/colo/Manifest
index c3e1b9f51a94..6ac3fffa666b 100644
--- a/sys-boot/colo/Manifest
+++ b/sys-boot/colo/Manifest
@@ -1,6 +1,9 @@
MD5 2b00b89b8df12875085e6bfb2524a632 colo-1.4.ebuild 3326
MD5 821bbe104fd36eab5f08495277bc5adb metadata.xml 364
-MD5 7eca1d5456c8a526fef159421d5947de ChangeLog 420
+MD5 f553a91e86ecb3682da3775872f9d45c colo-1.6.ebuild 3052
+MD5 eb50e74043c5b2df67f9374e99dd7e76 ChangeLog 663
MD5 c1b257fb8b0e15a8f27cbef798f5aede files/colo-1.4-gentoo.patch 2631
MD5 7c11a1ef9a1547e23ae00c09ef797d11 files/digest-colo-1.4 63
MD5 6a9e242bf3b159c4ead248ff40151b32 files/default.boot.example 9
+MD5 da6cc3a10feca032228e456bd9e77502 files/colo-1.6-gentoo.patch 1285
+MD5 68f29ebc1f7fc45aaf0b1a75db19a3e5 files/digest-colo-1.6 60
diff --git a/sys-boot/colo/colo-1.6.ebuild b/sys-boot/colo/colo-1.6.ebuild
new file mode 100644
index 000000000000..4318a2dbd5de
--- /dev/null
+++ b/sys-boot/colo/colo-1.6.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/colo-1.6.ebuild,v 1.1 2004/04/21 09:42:07 kumba Exp $
+
+inherit eutils
+
+DESCRIPTION="CObalt Linux lOader - Modern bootloader for Cobalt MIPS machines"
+HOMEPAGE="http://www.colonel-panic.org/cobalt-mips/"
+SRC_URI="http://www.colonel-panic.org/cobalt-mips/colo/colo-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~mips"
+IUSE=""
+DEPEND=""
+RESTRICT="nostrip"
+
+
+pkg_setup() {
+ # See if we're on a cobalt system (must use the cobalt-mips profile)
+ if [ "${PROFILE_ARCH}" != "cobalt" ]; then
+ echo -e ""
+ eerror "This package is only intended for the Cobalt Microserver MIPS-based"
+ eerror "systems. It will not function on any other MIPS-based system or any"
+ eerror "other architecture"
+ echo -e ""
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # patch Docs
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ # boot-loader
+ cd ${S}
+ make clean || die # emake breaks the build
+ make || die
+
+ # flash-tool
+ cd ${S}/tools/flash-tool
+ make clean || die
+ make || die
+}
+
+src_install() {
+ # bins
+ cd ${S}
+ dodir /usr/lib/colo
+ cp binaries/colo-chain.elf ${D}/usr/lib/colo
+ cp binaries/colo-rom-image.bin ${D}/usr/lib/colo
+ cp ${FILESDIR}/default.boot.example ${D}/usr/lib/colo/default.colo.example
+
+ # docs
+ dodoc CHANGES COPYING INSTALL README README.{restore,shell} TODO
+
+ # flash-tool
+ dosbin tools/flash-tool/flash-tool
+}
+
+pkg_postinst() {
+ echo -e ""
+ einfo "Binaries for this bootloader have been stored in"
+ einfo "/usr/lib/cobalt-bootloader. Documentation has been"
+ einfo "installed in /usr/share/doc/${PF}. The flash utility"
+ einfo "has been installed as /usr/sbin/flash-tool. An example"
+ einfo "default.colo has been placed in /usr/lib/colo. It is"
+ einfo "a script file the bootloader uses to execute a series"
+ einfo "of commands to load the machine. If you desire the"
+ einfo "machine to boot to the bootloader command prompt, copy"
+ einfo "/usr/lib/colo/default.colo.example to /boot/default.colo,"
+ einfo "otherwise the bootloader will attempt to automatically"
+ einfo "boot /boot/vmlinux.gz. It is recommended that you edit"
+ einfo "the default.colo.example script to fit your needs and"
+ einfo "place it in /boot as default.colo."
+ echo -e ""
+ ewarn "Note: It is HIGHLY recommended that you use the chain"
+ ewarn "bootloader (colo-chain.elf) first before attempting to"
+ ewarn "write the bootloader to the flash chip to verify that"
+ ewarn "it will work for you. It is also recommended that"
+ ewarn "you read the documentation in /usr/share/doc/${PF}"
+ ewarn "as it explains how to properly use this package."
+ echo -e ""
+ eerror "Warning: Make sure that IF you plan on flashing the"
+ eerror "bootloader into the flash chip that you are using a"
+ eerror "modern 2.4 Linux kernel (i.e., >2.4.18), otherwise"
+ eerror "you run a risk of destroying the contents of the"
+ eerror "flash chip and rendering the machine unusable."
+ echo -e ""
+ echo -e ""
+}
diff --git a/sys-boot/colo/files/colo-1.6-gentoo.patch b/sys-boot/colo/files/colo-1.6-gentoo.patch
new file mode 100644
index 000000000000..ee1df65e4809
--- /dev/null
+++ b/sys-boot/colo/files/colo-1.6-gentoo.patch
@@ -0,0 +1,36 @@
+--- INSTALL.orig 2004-04-21 01:18:46.000000000 -0400
++++ INSTALL 2004-04-21 01:20:09.000000000 -0400
+@@ -8,11 +8,11 @@ possible to use the original Cobalt boot
+ loader - chain mode. This does away with the risk of trashing your unit,
+ though it extends the time required to boot.
+
+-Just copy 'chain.bin' to your boot directory, rename into 'vmlinux' and gzip
++Just copy 'colo-chain.elf' to your boot directory, rename into 'vmlinux' and gzip
+ it to 'vmlinux.gz'
+
+ cp -f /boot/vmlinux.gz /boot/backup.gz
+- cp chain.bin /boot/vmlinux
++ cp colo-chain.elf /boot/vmlinux
+ gzip -9 /boot/vmlinux
+ reboot
+
+@@ -82,7 +82,7 @@ Step 4 - install the new boot loader
+ Write the new boot loader into the Flash. Don't interrupt the programming
+ process or you will probably land up with a unit that doesn't boot!
+
+- flash-tool -w boot.bin
++ flash-tool -w colo-rom-image.bin
+
+ If for any reason programming fails you might just be able to write the
+ original boot loader back into the Flash
+--- README.shell.orig 2004-04-21 01:23:51.000000000 -0400
++++ README.shell 2004-04-21 01:24:02.000000000 -0400
+@@ -11,7 +11,7 @@ If no SPACE character is detected the bo
+ using the default script :-
+
+ mount
+- -script /boot/default.boot
++ -script /boot/default.colo
+ load /boot/vmlinux.gz
+ execute
+
diff --git a/sys-boot/colo/files/digest-colo-1.6 b/sys-boot/colo/files/digest-colo-1.6
new file mode 100644
index 000000000000..4ff83e95e205
--- /dev/null
+++ b/sys-boot/colo/files/digest-colo-1.6
@@ -0,0 +1 @@
+MD5 20cdca3fa4045b85869137425fed0577 colo-1.6.tar.gz 146206