summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-02-18 15:22:00 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-02-18 15:22:00 +0000
commita4cf67b269bc70ec6b688226d8ee4729259c1a12 (patch)
tree3109bfdf321fa8062a478c91671e00f2da213ec0 /sys-boot
parentremove old (diff)
downloadgentoo-2-a4cf67b269bc70ec6b688226d8ee4729259c1a12.tar.gz
gentoo-2-a4cf67b269bc70ec6b688226d8ee4729259c1a12.tar.bz2
gentoo-2-a4cf67b269bc70ec6b688226d8ee4729259c1a12.zip
Version bump, bug #457974.
(Portage version: 2.1.11.50/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/ChangeLog8
-rw-r--r--sys-boot/syslinux/syslinux-5.01.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 546b4572ba5b..8f0f0bb38738 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/syslinux
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.94 2013/01/11 17:24:42 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.95 2013/02/18 15:22:00 chithanh Exp $
+
+*syslinux-5.01 (18 Feb 2013)
+
+ 18 Feb 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +syslinux-5.01.ebuild:
+ Version bump, bug #457974.
11 Jan 2013; Rick Farina <zerochaos@gentoo.org> syslinux-4.06.ebuild,
syslinux-5.00.ebuild:
diff --git a/sys-boot/syslinux/syslinux-5.01.ebuild b/sys-boot/syslinux/syslinux-5.01.ebuild
new file mode 100644
index 000000000000..2e44bc34eb94
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-5.01.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-5.01.ebuild,v 1.1 2013/02/18 15:22:00 chithanh Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="SYSLINUX, PXELINUX, ISOLINUX, EXTLINUX and MEMDISK bootloaders"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${PV:0:1}.xx/${P/_/-}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="custom-cflags"
+
+RDEPEND="sys-fs/mtools
+ dev-perl/Crypt-PasswdMD5
+ dev-perl/Digest-SHA1"
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ virtual/os-headers"
+
+S=${WORKDIR}/${P/_/-}
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# These are executables which come precompiled and are run by the boot loader
+QA_PREBUILT="usr/share/${PN}/*.c32"
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_prepare() {
+ # Fix building on hardened
+ epatch "${FILESDIR}"/${PN}-4.05-nopie.patch
+
+ rm -f gethostip #bug 137081
+
+ # Don't prestrip or override user LDFLAGS, bug #305783
+ local SYSLINUX_MAKEFILES="extlinux/Makefile linux/Makefile mtools/Makefile \
+ sample/Makefile utils/Makefile"
+ sed -i ${SYSLINUX_MAKEFILES} -e '/^LDFLAGS/d' || die "sed failed"
+
+ if use custom-cflags; then
+ sed -i ${SYSLINUX_MAKEFILES} \
+ -e 's|-g -Os||g' \
+ -e 's|-Os||g' \
+ -e 's|CFLAGS[[:space:]]\+=|CFLAGS +=|g' \
+ || die "sed custom-cflags failed"
+ fi
+
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) installer
+}
+
+src_install() {
+ emake INSTALLSUBDIRS=utils INSTALLROOT="${D}" MANDIR=/usr/share/man install
+ dodoc README NEWS doc/*.txt
+}