summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Matejka <yac@gentoo.org>2014-05-11 14:29:45 +0000
committerJan Matejka <yac@gentoo.org>2014-05-11 14:29:45 +0000
commit809a39f1f962fb3a8265fe64c4f6e0e01f0c7106 (patch)
tree3ea64d59ee4fb04ce85244902c812182984d4844 /sys-boot
parentVersion bump. Cleanup old. (diff)
downloadgentoo-2-809a39f1f962fb3a8265fe64c4f6e0e01f0c7106.tar.gz
gentoo-2-809a39f1f962fb3a8265fe64c4f6e0e01f0c7106.tar.bz2
gentoo-2-809a39f1f962fb3a8265fe64c4f6e0e01f0c7106.zip
Adding sys-boot/winusb
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F97A36A1)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/winusb/ChangeLog9
-rw-r--r--sys-boot/winusb/metadata.xml10
-rw-r--r--sys-boot/winusb/winusb-1.0.11.ebuild41
3 files changed, 60 insertions, 0 deletions
diff --git a/sys-boot/winusb/ChangeLog b/sys-boot/winusb/ChangeLog
new file mode 100644
index 000000000000..ca9d5f0d8eca
--- /dev/null
+++ b/sys-boot/winusb/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-boot/winusb
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/winusb/ChangeLog,v 1.1 2014/05/11 14:29:45 yac Exp $
+
+*winusb-1.0.11 (11 May 2014)
+
+ 11 May 2014; Jan Matejka <yac@gentoo.org> +metadata.xml,
+ +winusb-1.0.11.ebuild:
+ Adding sys-boot/winusb
diff --git a/sys-boot/winusb/metadata.xml b/sys-boot/winusb/metadata.xml
new file mode 100644
index 000000000000..57aaaa1668f3
--- /dev/null
+++ b/sys-boot/winusb/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>yac@gentoo.org</email>
+<name>Jan Matejka</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
diff --git a/sys-boot/winusb/winusb-1.0.11.ebuild b/sys-boot/winusb/winusb-1.0.11.ebuild
new file mode 100644
index 000000000000..89f3410b8193
--- /dev/null
+++ b/sys-boot/winusb/winusb-1.0.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/winusb/winusb-1.0.11.ebuild,v 1.1 2014/05/11 14:29:45 yac Exp $
+
+EAPI=5
+
+DESCRIPTION="Creates windows installer on usb media from an iso image"
+HOMEPAGE="http://en.congelli.eu/prog_info_winusb.html"
+SRC_URI="http://en.congelli.eu/directdl/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND="${DEPEND}
+ sys-apps/coreutils
+ sys-apps/grep
+ sys-apps/util-linux
+ sys-block/parted
+ sys-boot/grub:2
+ sys-fs/ntfs3g
+"
+
+src_prepare() {
+ sed -i "s#grub-install#grub2-install#" src/winusb ||
+ die "sed failed"
+}
+
+src_compile() {
+ return; # noop
+}
+
+src_configure() {
+ return; # noop
+}
+
+src_install() {
+ dosbin src/winusb
+}